The Meta Model for Select Component Architect 4

Model
Action State
Activity Diagram
Actor
Association
Attribute
Basic Type
Business Actor
Business Event
Business Process
Business Transition
Class
Class Diagram
Column
Column Sort
Complex Process
Database
Dependency
Diagram Data
PTD::Diagram Swimlane
AD::Diagram Swimlane
Diagrams
Dictionary
Enumeration Literal
Event
Event Action Block
Exclusive Arc
External Reference
File Reference
General Graphics Diagram
Generalization
Increment
Index
Interaction
Join Column
Object Collaboration Diagram
Object Sequence Diagram
Operation
Package
Parameter
AD::Parent
Process Break
Process Hierarchy Diagram
Process Thread Diagram
Qualifier
Relationship
Requirement
Role
Specialization
State
State Diagram
Synchronization Bar
Table
Ternary Association
Ternary Role
Text Diagram
Transition
Typedef
Use Case
Use Case Diagram

Generated on 19 February 2002


Model

Represents the model (an abstraction of a system).

Attributes

Database Level
Long Name
Type
Description
Directory
Last Author
Last Change Date
Project Type
Reference
Schema Version
UML Short Dotted Name

Associations

Diagrams
Dictionary
Action State
Activity Diagram
Actor
Basic Type
Business Actor
Business Event
Business Process
Class Diagram
Complex Process
Iteration
Process Break
Increment
Use Case
Text Diagram
General Graphics Diagram
Process Hierarchy Diagram
Process Thread Diagram
Object Sequence Diagram
Object Collaboration Diagram
State Diagram
Use Case Diagram
Event
OCD Instance
OSD Instance
Table
Table Relationships Diagram
Database
Scoped Package
Corporate View
External User Class
External UML Interface
External Business Class
User Class
UML Interface
Exception
Business Class
External Exception
Class
External Class
Local Class
Typedef
Alias
Array
Enumeration
Sequence
Scoped Item
Scoped Requirement


Model.Database Level

Model

Attribute: Database Level

A unique number indicating a baseline for the structure of object types and connectivity between these object types (meta-metamodel). Required for 5.1 compatability, which now equates to the model schema version.

Read only
32 bit signed integer

Parent class: Model


Model.Long Name

Model

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Model


Model.Type

Model

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Model


Model.Description

Model

Attribute: Description

String containing the description of the model.

Read/Write
String of up to 16385 characters

Parent class: Model


Model.Directory

Model

Attribute: Directory

The directory that the template.txt file is located in

Read only
String of up to 255 characters

Parent class: Model


Model.Last Author

Model

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Model


Model.Last Change Date

Model

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Model


Model.Project Type

Model

Attribute: Project Type

A string which indicates the type of the model (project).

Read/Write
String of up to 50 characters

Parent class: Model


Model.Reference

Model

Attribute: Reference

The model reference eg \\Enabler\SomeServer\Models\New Model\0

Read only
String of up to 513 characters

Parent class: Model


Model.Schema Version

Model

Attribute: Schema Version

The Schema Version of this instance of the Model - the value is updated by ProjectServices when a new Model (or Model version) is created

Read only
32 bit signed integer

Parent class: Model


Model.UML Short Dotted Name

Model

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Model


Model.Diagrams

Model

Association: Diagrams

Description:
Read/Write
This role can be used to create an object of Class: CID_Diagrams
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Diagrams


Model.Dictionary

Model

Association: Dictionary

Description:
Read/Write
This role can be used to create an object of Class: CID_Dictionary
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Dictionary


Model.Action State

Model

Association: Action State

Description:
Read/Write
This role can be used to create an object of Class: CID_ActionState
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Action State
This role propagates delete

Parent Class: Model
Inverse roles: ActionState


Model.Activity Diagram

Model

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ActivityDiagram


Model.Actor

Model

Association: Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_Actor
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Actor
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Actor


Model.Basic Type

Model

Association: Basic Type

Description:
Read/Write
This role can be used to create an object of Class: CID_BasicType
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Basic Type
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: BasicType


Model.Business Actor

Model

Association: Business Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessActor
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Actor
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: BusinessActor


Model.Business Event

Model

Association: Business Event

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessEvent
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Event
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: BusinessEvent


Model.Business Process

Model

Association: Business Process

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessProcess
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: BusinessProcess


Model.Class Diagram

Model

Association: Class Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ClassDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ClassDiagram


Model.Complex Process

Model

Association: Complex Process

Description:
Read/Write
This role can be used to create an object of Class: CID_ComplexProcess
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: ComplexProcess


Model.Iteration

Model

Association: Iteration

Description:
Read/Write
This role can be used to create an object of Class: CID_ComplexProcess
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.Process Break

Model

Association: Process Break

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessBreak
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Break
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: ProcessBreak


Model.Increment

Model

Association: Increment

Description:
Read/Write
This role can be used to create an object of Class: CID_Increment
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Increment


Model.Use Case

Model

Association: Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: UseCase


Model.Text Diagram

Model

Association: Text Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_TextDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Text Diagram
This role propagates delete

Parent Class: Model
Inverse roles: TextDiagram


Model.General Graphics Diagram

Model

Association: General Graphics Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_GeneralGraphicsDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: General Graphics Diagram
This role propagates delete

Parent Class: Model
Inverse roles: GeneralGraphicsDiagram


Model.Process Hierarchy Diagram

Model

Association: Process Hierarchy Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessHierarchyDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Hierarchy Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ProcessHierarchyDiagram


Model.Process Thread Diagram

Model

Association: Process Thread Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessThreadDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Thread Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ProcessThreadDiagram


Model.Object Sequence Diagram

Model

Association: Object Sequence Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectSequenceDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Object Sequence Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ObjectSequenceDiagram


Model.Object Collaboration Diagram

Model

Association: Object Collaboration Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectCollaborationDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Object Collaboration Diagram
This role propagates delete

Parent Class: Model
Inverse roles: ObjectCollaborationDiagram


Model.State Diagram

Model

Association: State Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_StateDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: State Diagram
This role propagates delete

Parent Class: Model
Inverse roles: StateDiagram


Model.Use Case Diagram

Model

Association: Use Case Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCaseDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Use Case Diagram
This role propagates delete

Parent Class: Model
Inverse roles: UseCaseDiagram


Model.Event

Model

Association: Event

Description:
Read/Write
This role can be used to create an object of Class: CID_Event
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Event
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Event


Model.OCD Instance

Model

Association: OCD Instance

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Instance

Parent Class: Model


Model.OSD Instance

Model

Association: OSD Instance

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OSD::Instance

Parent Class: Model


Model.Table

Model

Association: Table

Description:
Read/Write
This role can be used to create an object of Class: CID_Table
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Table
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Table


Model.Table Relationships Diagram

Model

Association: Table Relationships Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_TableRelationshipsDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Table Relationships Diagram
This role propagates delete

Parent Class: Model
Inverse roles: TableRelationshipsDiagram


Model.Database

Model

Association: Database

Description:
Read/Write
This role can be used to create an object of Class: CID_Database
This role connects to 0 or more objects of classes: Database
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Database


Model.Scoped Package

Model

Association: Scoped Package

Description:
Read/Write
This role can be used to create an object of Class: CID_Package
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Package
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Package


Model.Corporate View

Model

Association: Corporate View

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is an alias of: RID_Namespace_To_ExternalClass
This role connects to 0 or more objects of classes: Class

Parent Class: Model


Model.External User Class

Model

Association: External User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.External UML Interface

Model

Association: External UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.External Business Class

Model

Association: External Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.User Class

Model

Association: User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Model


Model.UML Interface

Model

Association: UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Model


Model.Exception

Model

Association: Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Model


Model.Business Class

Model

Association: Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Model


Model.External Exception

Model

Association: External Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.Class

Model

Association: Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Class


Model.External Class

Model

Association: External Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.Local Class

Model

Association: Local Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model


Model.Typedef

Model

Association: Typedef

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Typedef


Model.Alias

Model

Association: Alias

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Model


Model.Array

Model

Association: Array

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Model


Model.Enumeration

Model

Association: Enumeration

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Model


Model.Sequence

Model

Association: Sequence

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Model


Model.Scoped Item

Model

Association: Scoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Model
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Model.Scoped Requirement

Model

Association: Scoped Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Model
Inverse roles: Requirement


Action State

A state on an activity diagram. An action state indicates some action to be carried out. When the action is completed, one of the state's outgoing transitions is taken.

Attributes

Constraints
Description
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Event Action Block
Dictionary
External Reference
Activity Diagram
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Action State.Constraints

Action State

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Action State


Action State.Description

Action State

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Action State


Action State.Name

Action State

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Action State


Action State.Full Name

Action State

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Action State


Action State.Full Scoped Name

Action State

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Action State


Action State.Scoped Name

Action State

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Action State


Action State.Comp Pointer

Action State

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Action State


Action State.External Link Last Updated

Action State

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Action State


Action State.Is External

Action State

Attribute: Is External

Read/Write
boolean

Parent class: Action State


Action State.Long Name

Action State

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Action State


Action State.UML Short Dotted Name

Action State

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Action State


Action State.Type

Action State

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Action State


Action State.Last Author

Action State

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Action State


Action State.Last Change Date

Action State

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Action State


Action State.Stereotype

Action State

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Action State


ActionState.Event Action Block

Action State

Association: Event Action Block

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_EventActionBlock
This role connects to 0 or more objects of classes: Event Action Block
This role propagates delete

Parent Class: Action State
Inverse roles: EventActionBlock


ActionState.Dictionary

Action State

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Action State
Inverse roles: Dictionary


ActionState.External Reference

Action State

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Action State
Inverse roles: ExternalReference


ActionState.Activity Diagram

Action State

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Action State
Inverse roles: ActivityDiagram


ActionState.Decomposition Diagram

Action State

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Action State
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ActionState.Using Diagram

Action State

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Action State


ActionState.Child Diagram

Action State

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Action State
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ActionState.External Dictionary Item

Action State

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Action State


ActionState.The External Reference

Action State

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Action State
Inverse roles: ExternalReference


ActionState.File Reference

Action State

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Action State
Inverse roles: FileReference


ActionState.Target Requirement

Action State

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Action State
Inverse roles: Requirement


ActionState.Source Requirement

Action State

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Action State
Inverse roles: Requirement


Activity Diagram

Represent an Activity Diagram

Attributes

Default View Show Action Name
Default View Show Start State Name
Default View Show Stop State Name
Default View Show Transition Name
Page Ref
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Container
Parent AD
Diagrams
Swimlane
AD Diagram Swimlane
AD Parent
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Activity Diagram.Default View Show Action Name

Activity Diagram

Attribute: Default View Show Action Name

Indicates whether the default view option for a state is to display it's name or not.

Read/Write
boolean

Parent class: Activity Diagram


Activity Diagram.Default View Show Start State Name

Activity Diagram

Attribute: Default View Show Start State Name

Read/Write
boolean

Parent class: Activity Diagram


Activity Diagram.Default View Show Stop State Name

Activity Diagram

Attribute: Default View Show Stop State Name

Read/Write
boolean

Parent class: Activity Diagram


Activity Diagram.Default View Show Transition Name

Activity Diagram

Attribute: Default View Show Transition Name

Read/Write
boolean

Parent class: Activity Diagram


Activity Diagram.Page Ref

Activity Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Activity Diagram


Activity Diagram.Filename

Activity Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Activity Diagram


Activity Diagram.Full Type

Activity Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Activity Diagram


Activity Diagram.Pathname

Activity Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Activity Diagram


Activity Diagram.Title

Activity Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Activity Diagram


Activity Diagram.Description

Activity Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Activity Diagram


Activity Diagram.Meta File

Activity Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Activity Diagram


Activity Diagram.Page Orientation

Activity Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Activity Diagram


Activity Diagram.Page Count

Activity Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Activity Diagram


Activity Diagram.Full Name

Activity Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Full Scoped Name

Activity Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Local Full Scoped Name

Activity Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Local Scoped Name

Activity Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Scoped Name

Activity Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.UML Short Dotted Name

Activity Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Long Name

Activity Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Activity Diagram


Activity Diagram.Type

Activity Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Activity Diagram


Activity Diagram.Last Author

Activity Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Activity Diagram


Activity Diagram.Last Change Date

Activity Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Activity Diagram


Activity Diagram.Stereotype

Activity Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Activity Diagram


ActivityDiagram.Container

Activity Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Model


ActivityDiagram.Parent AD

Activity Diagram

Association: Parent AD

Description:
Read/Write
This role connects to 0 or 1 object of classes: Use Case, Action State, Actor, Class, Operation, Package
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: UseCase, ActionState, Actor, Class, Operation, Package


ActivityDiagram.Diagrams

Activity Diagram

Association: Diagrams

Description:
Read/Write
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Diagrams


ActivityDiagram.Swimlane

Activity Diagram

Association: Swimlane

Description: TODO
Read only
This role is derived
This role connects to 0 or more objects of classes: AD::Diagram Swimlane, AD::Swimlane

Parent Class: Activity Diagram


ActivityDiagram.AD Diagram Swimlane

Activity Diagram

Association: AD Diagram Swimlane

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_ADDiagramSwimlane
This role connects to 1 object of classes: AD::Diagram Swimlane
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Activity Diagram
Inverse roles: ADDiagramSwimlane


ActivityDiagram.AD Parent

Activity Diagram

Association: AD Parent

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_ADParent
This role connects to 0 or 1 object of classes: AD::Parent
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Activity Diagram
Inverse roles: ADParent


ActivityDiagram.Decomposed Dictionary Item

Activity Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ActivityDiagram.Parent Dictionary Item

Activity Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Activity Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ActivityDiagram.Category

Activity Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Package


ActivityDiagram.Package

Activity Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Package


ActivityDiagram.Dependee Item

Activity Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Activity Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ActivityDiagram.Dependent Item

Activity Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Activity Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ActivityDiagram.Scoping Item

Activity Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Activity Diagram
Inverse roles: Class, Package, Model, Requirement


ActivityDiagram.File Reference

Activity Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Activity Diagram
Inverse roles: FileReference


ActivityDiagram.Target Requirement

Activity Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Activity Diagram
Inverse roles: Requirement


ActivityDiagram.Source Requirement

Activity Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Activity Diagram
Inverse roles: Requirement


Actor

An active object that drives the data flow graph by producing or consuming values.

All objects of this class are name unique within a Model

Attributes

Constraints
Description
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype
Is Abstract

Associations

Use Case
Interaction
Class
External Reference
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Generalization
Specialization
SubType
SuperType
Activity Diagram


Actor.Constraints

Actor

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Actor


Actor.Description

Actor

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Actor


Actor.Full Name

Actor

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Actor


Actor.Full Scoped Name

Actor

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Actor


Actor.Local Full Scoped Name

Actor

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Actor


Actor.Local Scoped Name

Actor

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Actor


Actor.Scoped Name

Actor

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Actor


Actor.UML Short Dotted Name

Actor

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Actor


Actor.Name

Actor

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Actor


Actor.Comp Pointer

Actor

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Actor


Actor.External Link Last Updated

Actor

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Actor


Actor.Is External

Actor

Attribute: Is External

Read/Write
boolean

Parent class: Actor


Actor.Long Name

Actor

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Actor


Actor.Type

Actor

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Actor


Actor.Last Author

Actor

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Actor


Actor.Last Change Date

Actor

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Actor


Actor.Stereotype

Actor

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Actor


Actor.Is Abstract

Actor

Attribute: Is Abstract

Indicates whether the taxonomy is abstract or not.

Read/Write
boolean

Parent class: Actor


Actor.Use Case

Actor

Association: Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role is derived
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: UseCase


Actor.Interaction

Actor

Association: Interaction

Description:
Read/Write
This role connects to 0 or more objects of classes: Interaction
This role propagates delete

Parent Class: Actor
Inverse roles: Interaction


Actor.Class

Actor

Association: Class

Description:
Read/Write
This role connects to 0 or more objects of classes: Class

Parent Class: Actor
Inverse roles: Class


Actor.External Reference

Actor

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: ExternalReference


Actor.Category

Actor

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: Package


Actor.Package

Actor

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: Package


Actor.Dependee Item

Actor

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Actor
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Actor.Dependent Item

Actor

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Actor
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Actor.Scoping Item

Actor

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: Class, Package, Model, Requirement


Actor.Decomposition Diagram

Actor

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Actor
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Actor.Using Diagram

Actor

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Actor


Actor.Child Diagram

Actor

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Actor
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Actor.External Dictionary Item

Actor

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Actor


Actor.The External Reference

Actor

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Actor
Inverse roles: ExternalReference


Actor.File Reference

Actor

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Actor
Inverse roles: FileReference


Actor.Target Requirement

Actor

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Actor
Inverse roles: Requirement


Actor.Source Requirement

Actor

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Actor
Inverse roles: Requirement


Actor.Generalization

Actor

Association: Generalization

Description:
Read/Write
This role can be used to create an object of Class: CID_Generalization
This role connects to 0 or more objects of classes: Generalization
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Actor
Inverse roles: Generalization


Actor.Specialization

Actor

Association: Specialization

Description:
Read/Write
This role can be used to create an object of Class: CID_Specialization
This role connects to 0 or more objects of classes: Specialization
This role propagates delete

Parent Class: Actor
Inverse roles: Specialization


Actor.SubType

Actor

Association: SubType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Actor
Inverse roles: Class, Actor, UseCase


Actor.SuperType

Actor

Association: SuperType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Actor
Inverse roles: Class, Actor, UseCase


Actor.Activity Diagram

Actor

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Actor
Inverse roles: ActivityDiagram


Association

A relationship among instances of two classes describing a group of links with common structure and semantics. Note: relationships involving three or more class instances are handled by ternary associations.

Attributes

End Class
End Multiplicity Text
End Qualifier
Full Name
Start Class
Start Multiplicity Text
Start Qualifier
Type
Aggregate
Constraints
Description
Is Derived
Is Persistent
Name Direction
Navigation
UML Short Dotted Name
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Last Author
Last Change Date
Stereotype

Associations

End Role
Start Role
Start Class
End Class
Qualifier
Start Qualifier
External Reference
Link Class
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Storage Model


Association.End Class

Association

Attribute: End Class

Provided for backward compatibility. A string containing the name of the corporate class and the end of the corporate association.

Read only
String of up to 50 characters

Parent class: Association


Association.End Multiplicity Text

Association

Attribute: End Multiplicity Text

The multiplicity text for the end of the association.

Read/Write
String of up to 50 characters

Parent class: Association


Association.End Qualifier

Association

Attribute: End Qualifier

Name of the qualifiers at the end of the association.

Read/Write
String of up to 50 characters

Parent class: Association


Association.Full Name

Association

Attribute: Full Name

Full name of an Association, e.g. Assoc1 [c1 - c2]

Read only
String of up to 100 characters

Parent class: Association


Association.Start Class

Association

Attribute: Start Class

Provided for backward compatibility. A string containing the name of the corporate class and the start of the corporate association.

Read only
String of up to 50 characters

Parent class: Association


Association.Start Multiplicity Text

Association

Attribute: Start Multiplicity Text

The multiplicity text for the start of the association.

Read/Write
String of up to 50 characters

Parent class: Association


Association.Start Qualifier

Association

Attribute: Start Qualifier

Name of the qualifiers at the start of the association.

Read/Write
String of up to 50 characters

Parent class: Association


Association.Type

Association

Attribute: Type

The object type.

Read only
String of up to 50 characters

Parent class: Association


Association.Aggregate

Association

Attribute: Aggregate

Indicates whether the association is an aggregate or not.

Read/Write
Enumeration, values: Start, End, None

Parent class: Association


Association.Constraints

Association

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Association


Association.Description

Association

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Association


Association.Is Derived

Association

Attribute: Is Derived

Indicates that the association is derived

Read/Write
boolean

Parent class: Association


Association.Is Persistent

Association

Attribute: Is Persistent

Indicates whether the association is persistent.

Read/Write
boolean

Parent class: Association


Association.Name Direction

Association

Attribute: Name Direction

Indicates the direction in which the association name should be read (e.g. start-to-end or end-to-start).

Read/Write
Enumeration, values: start-end, end-start

Parent class: Association


Association.Navigation

Association

Attribute: Navigation

Indicates the direction the association can be navigated (e.g. start-to-end, bi-directional etc.).

Read/Write
Enumeration, values: start-end, end-start, bi-directional, none

Parent class: Association


Association.UML Short Dotted Name

Association

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Association


Association.Name

Association

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Association


Association.Full Scoped Name

Association

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Association


Association.Scoped Name

Association

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Association


Association.Comp Pointer

Association

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Association


Association.External Link Last Updated

Association

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Association


Association.Is External

Association

Attribute: Is External

Read/Write
boolean

Parent class: Association


Association.Long Name

Association

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Association


Association.Last Author

Association

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Association


Association.Last Change Date

Association

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Association


Association.Stereotype

Association

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Association


Association.End Role

Association

Association: End Role

Description:
Read/Write
This role can be used to create an object of Class: CID_Role
This role is derived
This role connects to 1 object of classes: Role
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Association


Association.Start Role

Association

Association: Start Role

Description:
Read/Write
This role can be used to create an object of Class: CID_Role
This role is derived
This role connects to 1 object of classes: Role
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Association


Association.Start Class

Association

Association: Start Class

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Association
Inverse roles: Class


Association.End Class

Association

Association: End Class

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Association
Inverse roles: Class


Association.Qualifier

Association

Association: Qualifier

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Qualifier

Parent Class: Association
Inverse roles: Qualifier


Association.Start Qualifier

Association

Association: Start Qualifier

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Qualifier
This role connects to 0 or more objects of classes: Qualifier
This role propagates delete

Parent Class: Association
Inverse roles: Qualifier


Association.External Reference

Association

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Association
Inverse roles: ExternalReference


Association.Link Class

Association

Association: Link Class

Description:
Read/Write
This role connects to 0 or 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Association
Inverse roles: Class


Association.Decomposition Diagram

Association

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Association
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Association.Using Diagram

Association

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Association


Association.Child Diagram

Association

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Association
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Association.External Dictionary Item

Association

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Association


Association.The External Reference

Association

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Association
Inverse roles: ExternalReference


Association.File Reference

Association

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Association
Inverse roles: FileReference


Association.Target Requirement

Association

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Association
Inverse roles: Requirement


Association.Source Requirement

Association

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Association
Inverse roles: Requirement


Association.Storage Model

Association

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Association
Inverse roles: Relationship, Column, Table


Attribute

A named property of a class describing a data value held by each object of the class.

Attributes

Full Name
Full Scoped Name
Has Role
Read Only
Scoped Name
Short UmlSignature
Signature
Uml Signature
Is Derived
Is Unique
Name
Access
Changeability
Default Value
Is Static
UML Short Dotted Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype
Array Dimensions
Has Interpreted Data Type
Type Declaration
Is Array
Is Pointer
Constraints
Description
Uninterpreted Data Type

Associations

Class
Corporate Attribute
External Reference
Role
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Storage Model
Data Type


Attribute.Full Name

Attribute

Attribute: Full Name

Full name for an Attribute, e.g. a1 [cat1.cat2.c3.]

Read only
String of up to 100 characters

Parent class: Attribute


Attribute.Full Scoped Name

Attribute

Attribute: Full Scoped Name

Full scoped name for an Attribute, e.g. cat1::cat2::c3.a1

Read only
String of up to 100 characters

Parent class: Attribute


Attribute.Has Role

Attribute

Attribute: Has Role

Read/Write
boolean

Parent class: Attribute


Attribute.Read Only

Attribute

Attribute: Read Only

Read-only (const) attribute

Read/Write
boolean

Parent class: Attribute


Attribute.Scoped Name

Attribute

Attribute: Scoped Name

Scoped name for an Attribute, e.g. c3.a1

Read only
String of up to 100 characters

Parent class: Attribute


Attribute.Short UmlSignature

Attribute

Attribute: Short UmlSignature

A string giving the Attribute signature in UML syntax. Data type is expressed with no scoping information.

Read only
String of up to 65536 characters

Parent class: Attribute


Attribute.Signature

Attribute

Attribute: Signature

A string containing the data type of the attribute followed by the name of the attribute.

Read/Write
String of up to 65536 characters

Parent class: Attribute


Attribute.Uml Signature

Attribute

Attribute: Uml Signature

A string giving the Attribute signature in UML syntax. Data type is expressed in dotted notation.

Read/Write
String of up to 65536 characters

Parent class: Attribute


Attribute.Is Derived

Attribute

Attribute: Is Derived

Indicates that the attribute is derived

Read/Write
boolean

Parent class: Attribute


Attribute.Is Unique

Attribute

Attribute: Is Unique

Indicates whether the attribute is unique or not (i.e. The attribute in the class will always be unique to one object e.g. class id will uniquely identify a class)

Read/Write
boolean

Parent class: Attribute


Attribute.Name

Attribute

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Attribute


Attribute.Access

Attribute

Attribute: Access

The visibility/access of an attribute of a class.

Read/Write
Enumeration, values: Public, Protected, Package Protected, Private

Parent class: Attribute


Attribute.Changeability

Attribute

Attribute: Changeability

The visibility/access of an attribute of a class.

Read/Write
Enumeration, values: Changeable, Frozen, Read Only, Add Only

Parent class: Attribute


Attribute.Default Value

Attribute

Attribute: Default Value

The default value to which the attribute should be set on creation.

Read/Write
String of up to 16385 characters

Parent class: Attribute


Attribute.Is Static

Attribute

Attribute: Is Static

Indicates that the attribute is static (has on class storage)

Read/Write
boolean

Parent class: Attribute


Attribute.UML Short Dotted Name

Attribute

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Attribute


Attribute.Comp Pointer

Attribute

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Attribute


Attribute.External Link Last Updated

Attribute

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Attribute


Attribute.Is External

Attribute

Attribute: Is External

Read/Write
boolean

Parent class: Attribute


Attribute.Long Name

Attribute

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Attribute


Attribute.Type

Attribute

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Attribute


Attribute.Last Author

Attribute

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Attribute


Attribute.Last Change Date

Attribute

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Attribute


Attribute.Stereotype

Attribute

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Attribute


Attribute.Array Dimensions

Attribute

Attribute: Array Dimensions

Derived property returning the number of dimensions of an array

Read/Write
32 bit signed integer

Parent class: Attribute


Attribute.Has Interpreted Data Type

Attribute

Attribute: Has Interpreted Data Type

Indicates if the Attribute has an interpreted (Dictionary linked) data type.

Read only
boolean

Parent class: Attribute


Attribute.Type Declaration

Attribute

Attribute: Type Declaration

A string containing the data type. This is either the true data type which is the dotted name of the dictionary item connected via the data type dictionary link or the uninterpreted data type string.

Read/Write
String of up to 16385 characters

Parent class: Attribute


Attribute.Is Array

Attribute

Attribute: Is Array

Indicates whether the parameter is an array or not.

Read/Write
boolean

Parent class: Attribute


Attribute.Is Pointer

Attribute

Attribute: Is Pointer

Indicates whether the attribute is a pointer or not.

Read/Write
boolean

Parent class: Attribute


Attribute.Constraints

Attribute

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Attribute


Attribute.Description

Attribute

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Attribute


Attribute.Uninterpreted Data Type

Attribute

Attribute: Uninterpreted Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Attribute


Attribute.Class

Attribute

Association: Class

Description:
Read/Write
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Attribute
Inverse roles: Class


Attribute.Corporate Attribute

Attribute

Association: Corporate Attribute

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Attribute
All objects connected in this role are uniquely named

Parent Class: Attribute


Attribute.External Reference

Attribute

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Attribute
Inverse roles: ExternalReference


Attribute.Role

Attribute

Association: Role

Description:
Read/Write
This role connects to 0 or 1 object of classes: Role
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Attribute
Inverse roles: Role


Attribute.Decomposition Diagram

Attribute

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Attribute
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Attribute.Using Diagram

Attribute

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Attribute


Attribute.Child Diagram

Attribute

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Attribute
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Attribute.External Dictionary Item

Attribute

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Attribute


Attribute.The External Reference

Attribute

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Attribute
Inverse roles: ExternalReference


Attribute.File Reference

Attribute

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Attribute
Inverse roles: FileReference


Attribute.Target Requirement

Attribute

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Attribute
Inverse roles: Requirement


Attribute.Source Requirement

Attribute

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Attribute
Inverse roles: Requirement


Attribute.Storage Model

Attribute

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Attribute
Inverse roles: Relationship, Column, Table


Attribute.Data Type

Attribute

Association: Data Type

Description:
Read/Write
This role connects to 0 or 1 object of classes: Basic Type, Typedef, Class
All objects connected in this role are uniquely named

Parent Class: Attribute
Inverse roles: BasicType, Typedef, Class


Basic Type

A language-dependent type of an attribute.

All objects of this class are name unique within a Model

Attributes

Constraints
Data Type
Description
Is Signed
Name
Precision
Scale
Length
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Typed Attribute
Type Definition
Typed Operation
Typed Parameter
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Typed Column


Basic Type.Constraints

Basic Type

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Basic Type


Basic Type.Data Type

Basic Type

Attribute: Data Type

The target SQL data type of a column.

Read/Write
String of up to 100 characters

Parent class: Basic Type


Basic Type.Description

Basic Type

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Basic Type


Basic Type.Is Signed

Basic Type

Attribute: Is Signed

Read/Write
boolean

Parent class: Basic Type


Basic Type.Name

Basic Type

Attribute: Name

Name of the basic type

Read/Write
String of up to 100 characters

Parent class: Basic Type


Basic Type.Precision

Basic Type

Attribute: Precision

A text string containing the precision or scale of a numeric value or the size of a text string.

Read/Write
String of up to 1024 characters

Parent class: Basic Type


Basic Type.Scale

Basic Type

Attribute: Scale

TODO

Read/Write
String of up to 1024 characters

Parent class: Basic Type


Basic Type.Length

Basic Type

Attribute: Length

TODO

Read/Write
String of up to 1024 characters

Parent class: Basic Type


Basic Type.Full Name

Basic Type

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Basic Type


Basic Type.Full Scoped Name

Basic Type

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Basic Type


Basic Type.Scoped Name

Basic Type

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Basic Type


Basic Type.Comp Pointer

Basic Type

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Basic Type


Basic Type.External Link Last Updated

Basic Type

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Basic Type


Basic Type.Is External

Basic Type

Attribute: Is External

Read/Write
boolean

Parent class: Basic Type


Basic Type.Long Name

Basic Type

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Basic Type


Basic Type.UML Short Dotted Name

Basic Type

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Basic Type


Basic Type.Type

Basic Type

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Basic Type


Basic Type.Last Author

Basic Type

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Basic Type


Basic Type.Last Change Date

Basic Type

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Basic Type


Basic Type.Stereotype

Basic Type

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Basic Type


BasicType.External Reference

Basic Type

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Basic Type
Inverse roles: ExternalReference


BasicType.Typed Attribute

Basic Type

Association: Typed Attribute

Description:
Read/Write
This role connects to 0 or more objects of classes: Qualifier, Attribute

Parent Class: Basic Type
Inverse roles: Qualifier, Attribute


BasicType.Type Definition

Basic Type

Association: Type Definition

Description:
Read/Write
This role connects to 0 or more objects of classes: Typedef

Parent Class: Basic Type
Inverse roles: Typedef


BasicType.Typed Operation

Basic Type

Association: Typed Operation

Description:
Read/Write
This role connects to 0 or more objects of classes: Operation

Parent Class: Basic Type
Inverse roles: Operation


BasicType.Typed Parameter

Basic Type

Association: Typed Parameter

Description:
Read/Write
This role connects to 0 or more objects of classes: Parameter

Parent Class: Basic Type
Inverse roles: Parameter


BasicType.Decomposition Diagram

Basic Type

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Basic Type
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BasicType.Using Diagram

Basic Type

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Basic Type


BasicType.Child Diagram

Basic Type

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Basic Type
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BasicType.External Dictionary Item

Basic Type

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Basic Type


BasicType.The External Reference

Basic Type

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Basic Type
Inverse roles: ExternalReference


BasicType.File Reference

Basic Type

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Basic Type
Inverse roles: FileReference


BasicType.Target Requirement

Basic Type

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Basic Type
Inverse roles: Requirement


BasicType.Source Requirement

Basic Type

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Basic Type
Inverse roles: Requirement


BasicType.Typed Column

Basic Type

Association: Typed Column

Description: TODO
Read/Write
This role connects to 0 or more objects of classes: Column

Parent Class: Basic Type
Inverse roles: Column


Business Actor

This represent a Business actor within the Business Process Model.

All objects of this class are name unique within a Model

Attributes

Job Function
Cost Unit
Cost Value
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Actor
Business Process
External Reference
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Business Actor.Job Function

Business Actor

Attribute: Job Function

String containing a description of the actors job function.

Read/Write
String of up to 16385 characters

Parent class: Business Actor


Business Actor.Cost Unit

Business Actor

Attribute: Cost Unit

The units (in time) of the cost of a business actor.

Read/Write
String of up to 1024 characters

Parent class: Business Actor


Business Actor.Cost Value

Business Actor

Attribute: Cost Value

The unit cost of the Business Actor. Text that represents the unit cost may contain a non-numeric character as the first character. The rest must be a number optionally containing a decimal point. E.g. $12.78

Read/Write
String of up to 50 characters

Parent class: Business Actor


Business Actor.Full Name

Business Actor

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Full Scoped Name

Business Actor

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Local Full Scoped Name

Business Actor

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Local Scoped Name

Business Actor

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Scoped Name

Business Actor

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.UML Short Dotted Name

Business Actor

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Name

Business Actor

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Business Actor


Business Actor.Comp Pointer

Business Actor

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Business Actor


Business Actor.External Link Last Updated

Business Actor

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Business Actor


Business Actor.Is External

Business Actor

Attribute: Is External

Read/Write
boolean

Parent class: Business Actor


Business Actor.Long Name

Business Actor

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Business Actor


Business Actor.Type

Business Actor

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Business Actor


Business Actor.Last Author

Business Actor

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Business Actor


Business Actor.Last Change Date

Business Actor

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Business Actor


Business Actor.Stereotype

Business Actor

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Business Actor


BusinessActor.Actor

Business Actor

Association: Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_Actor
This role connects to 0 or more objects of classes: Actor
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: Actor


BusinessActor.Business Process

Business Actor

Association: Business Process

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessProcess
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: BusinessProcess


BusinessActor.External Reference

Business Actor

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: ExternalReference


BusinessActor.Category

Business Actor

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: Package


BusinessActor.Package

Business Actor

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: Package


BusinessActor.Dependee Item

Business Actor

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Actor
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessActor.Dependent Item

Business Actor

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Actor
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessActor.Scoping Item

Business Actor

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: Class, Package, Model, Requirement


BusinessActor.Decomposition Diagram

Business Actor

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Actor
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessActor.Using Diagram

Business Actor

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Actor


BusinessActor.Child Diagram

Business Actor

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Actor
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessActor.External Dictionary Item

Business Actor

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Business Actor


BusinessActor.The External Reference

Business Actor

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Actor
Inverse roles: ExternalReference


BusinessActor.File Reference

Business Actor

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Business Actor
Inverse roles: FileReference


BusinessActor.Target Requirement

Business Actor

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Actor
Inverse roles: Requirement


BusinessActor.Source Requirement

Business Actor

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Actor
Inverse roles: Requirement


Business Event

A stimulus which triggers an elementary business process(EBP).

All objects of this class are name unique within a Model

Attributes

Growth Unit
Frequency Unit
Is High Priority
Is External Event
Description
Frequency Value
Growth Value
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Out Transition
In Transition
Transition To
Transition From
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Business Event.Growth Unit

Business Event

Attribute: Growth Unit

The units (in time) of growth of a business event (e.g. business events in some businesses may grow a matter of minutes or may grow a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Event


Business Event.Frequency Unit

Business Event

Attribute: Frequency Unit

The units (in time) of the frequency of a business event (e.g. business events in some businesses may happen every matter minutes or may happen every matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Event


Business Event.Is High Priority

Business Event

Attribute: Is High Priority

Indicates whether the business event is high priority or not.

Read/Write
boolean

Parent class: Business Event


Business Event.Is External Event

Business Event

Attribute: Is External Event

Indicates whether the business event is external (event from outside of the organisation) or not.

Read/Write
boolean

Parent class: Business Event


Business Event.Description

Business Event

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Business Event


Business Event.Frequency Value

Business Event

Attribute: Frequency Value

The frequency (as a number of units) that the business event occurs.

Read/Write
String of up to 50 characters

Parent class: Business Event


Business Event.Growth Value

Business Event

Attribute: Growth Value

The growth (as a number of units) of the business event.

Read/Write
String of up to 50 characters

Parent class: Business Event


Business Event.Full Name

Business Event

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Full Scoped Name

Business Event

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Local Full Scoped Name

Business Event

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Local Scoped Name

Business Event

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Scoped Name

Business Event

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.UML Short Dotted Name

Business Event

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Name

Business Event

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Business Event


Business Event.Comp Pointer

Business Event

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Business Event


Business Event.External Link Last Updated

Business Event

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Business Event


Business Event.Is External

Business Event

Attribute: Is External

Read/Write
boolean

Parent class: Business Event


Business Event.Long Name

Business Event

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Business Event


Business Event.Type

Business Event

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Business Event


Business Event.Last Author

Business Event

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Business Event


Business Event.Last Change Date

Business Event

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Business Event


Business Event.Stereotype

Business Event

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Business Event


BusinessEvent.External Reference

Business Event

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Event
Inverse roles: ExternalReference


BusinessEvent.Out Transition

Business Event

Association: Out Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Business Event
Inverse roles: BusinessTransition


BusinessEvent.In Transition

Business Event

Association: In Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Business Event
Inverse roles: BusinessTransition


BusinessEvent.Transition To

Business Event

Association: Transition To

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Business Event
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessEvent.Transition From

Business Event

Association: Transition From

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Business Event
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessEvent.Category

Business Event

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Event
Inverse roles: Package


BusinessEvent.Package

Business Event

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Event
Inverse roles: Package


BusinessEvent.Dependee Item

Business Event

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Event
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessEvent.Dependent Item

Business Event

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Event
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessEvent.Scoping Item

Business Event

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Business Event
Inverse roles: Class, Package, Model, Requirement


BusinessEvent.Decomposition Diagram

Business Event

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Event
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessEvent.Using Diagram

Business Event

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Event


BusinessEvent.Child Diagram

Business Event

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Event
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessEvent.External Dictionary Item

Business Event

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Business Event


BusinessEvent.The External Reference

Business Event

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Event
Inverse roles: ExternalReference


BusinessEvent.File Reference

Business Event

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Business Event
Inverse roles: FileReference


BusinessEvent.Target Requirement

Business Event

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Event
Inverse roles: Requirement


BusinessEvent.Source Requirement

Business Event

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Event
Inverse roles: Requirement


Business Process

A collection of activities that takes one or more kinds of input and creates an output that is of value to the customer.

All objects of this class are name unique within a Model

Attributes

Service Unit
Idle Unit
Busy Unit
Growth Unit
Icost Unit
Frequency Unit
Description
Objective
Service Value
Idle Value
Frequency Value
Busy Cost
Idle Cost
Growth Value
Full Scoped Name
Scoped Name
UML Short Dotted Name
Full Name
Local Full Scoped Name
Local Scoped Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Business Actor
Child Process
Parent Process
Use Case
The Dictionary
Process Thread Diagram
Process Hierarchy Diagram
External Reference
Parent
Out Transition
In Transition
Transition To
Transition From
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Business Process.Service Unit

Business Process

Attribute: Service Unit

The units (in time) that a business process takes to complete (e.g. business processes in some businesses may take a matter of minutes or may take a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Idle Unit

Business Process

Attribute: Idle Unit

The units (in time) of a business process will be idle (e.g. business processes in some businesses may be idle for a matter of minutes or may be idle for a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Busy Unit

Business Process

Attribute: Busy Unit

The units (in time) of a business process when it is busy (e.g. business processes in some businesses may take a matter of minutes or may take a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Growth Unit

Business Process

Attribute: Growth Unit

The units (in time) of growth of a business process (e.g. business processes in some businesses may grow a matter of minutes or may grow a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Icost Unit

Business Process

Attribute: Icost Unit

The units (in time) of a business process when it is idle (e.g. business processes in some businesses may take a matter of minutes or may take a matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Frequency Unit

Business Process

Attribute: Frequency Unit

The units (in time) of the frequency of a business process (e.g. business processes in some businesses may happen every matter minutes or may happen every matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.Description

Business Process

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Business Process


Business Process.Objective

Business Process

Attribute: Objective

String containing the object of the business process.

Read/Write
String of up to 16385 characters

Parent class: Business Process


Business Process.Service Value

Business Process

Attribute: Service Value

The time (as a number of units) that it takes for the business process to complete.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Idle Value

Business Process

Attribute: Idle Value

The time (as a number of units) that the business process will be idle.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Frequency Value

Business Process

Attribute: Frequency Value

The frequency (as a number of units) that the business process will be run.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Busy Cost

Business Process

Attribute: Busy Cost

The cost (as a number of units) of the business process when it is busy.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Idle Cost

Business Process

Attribute: Idle Cost

The cost (as a number of units) of the business process when it is idle.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Growth Value

Business Process

Attribute: Growth Value

The growth (as a number of units) of the business process.

Read/Write
String of up to 50 characters

Parent class: Business Process


Business Process.Full Scoped Name

Business Process

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Scoped Name

Business Process

Attribute: Scoped Name

Scoped name for a Nestable Item, e.g. Iteration1:Business Process2

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.UML Short Dotted Name

Business Process

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Full Name

Business Process

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Local Full Scoped Name

Business Process

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Local Scoped Name

Business Process

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Name

Business Process

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Business Process


Business Process.Comp Pointer

Business Process

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Business Process


Business Process.External Link Last Updated

Business Process

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Business Process


Business Process.Is External

Business Process

Attribute: Is External

Read/Write
boolean

Parent class: Business Process


Business Process.Long Name

Business Process

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Business Process


Business Process.Type

Business Process

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Business Process


Business Process.Last Author

Business Process

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Business Process


Business Process.Last Change Date

Business Process

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Business Process


Business Process.Stereotype

Business Process

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Business Process


BusinessProcess.Business Actor

Business Process

Association: Business Actor

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Actor
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: BusinessActor


BusinessProcess.Child Process

Business Process

Association: Child Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: BusinessProcess


BusinessProcess.Parent Process

Business Process

Association: Parent Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: BusinessProcess


BusinessProcess.Use Case

Business Process

Association: Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: UseCase


BusinessProcess.The Dictionary

Business Process

Association: The Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: Dictionary


BusinessProcess.Process Thread Diagram

Business Process

Association: Process Thread Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessThreadDiagram
This role connects to 0 or 1 object of classes: Process Thread Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Business Process
Inverse roles: ProcessThreadDiagram


BusinessProcess.Process Hierarchy Diagram

Business Process

Association: Process Hierarchy Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessHierarchyDiagram
This role connects to 0 or 1 object of classes: Process Hierarchy Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Business Process
Inverse roles: ProcessHierarchyDiagram


BusinessProcess.External Reference

Business Process

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: ExternalReference


BusinessProcess.Parent

Business Process

Association: Parent

Description:
Read/Write
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: ComplexProcess


BusinessProcess.Out Transition

Business Process

Association: Out Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Business Process
Inverse roles: BusinessTransition


BusinessProcess.In Transition

Business Process

Association: In Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Business Process
Inverse roles: BusinessTransition


BusinessProcess.Transition To

Business Process

Association: Transition To

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Business Process
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessProcess.Transition From

Business Process

Association: Transition From

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Business Process
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessProcess.Category

Business Process

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: Package


BusinessProcess.Package

Business Process

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: Package


BusinessProcess.Dependee Item

Business Process

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Process
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessProcess.Dependent Item

Business Process

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Process
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessProcess.Scoping Item

Business Process

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: Class, Package, Model, Requirement


BusinessProcess.Decomposition Diagram

Business Process

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Process
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessProcess.Using Diagram

Business Process

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Process


BusinessProcess.Child Diagram

Business Process

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Process
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessProcess.External Dictionary Item

Business Process

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Business Process


BusinessProcess.The External Reference

Business Process

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Process
Inverse roles: ExternalReference


BusinessProcess.File Reference

Business Process

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Business Process
Inverse roles: FileReference


BusinessProcess.Target Requirement

Business Process

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Process
Inverse roles: Requirement


BusinessProcess.Source Requirement

Business Process

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Process
Inverse roles: Requirement


Business Transition

This represents a business transition of the Business Process Model.

Attributes

Delay Unit
Delay Value
Description
Is Optional
Split
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Start
End
Exclusive Arc
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Business Transition.Delay Unit

Business Transition

Attribute: Delay Unit

The units (in time) of the delay caused by a transition (e.g. tranistions in some businesses may happen every matter minutes or may happen every matter of days).

Read/Write
String of up to 1024 characters

Parent class: Business Transition


Business Transition.Delay Value

Business Transition

Attribute: Delay Value

The delay (as a number of units) caused by the transition.

Read/Write
String of up to 50 characters

Parent class: Business Transition


Business Transition.Description

Business Transition

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Business Transition


Business Transition.Is Optional

Business Transition

Attribute: Is Optional

Indicates whether the business transition is optional or not.

Read/Write
boolean

Parent class: Business Transition


Business Transition.Split

Business Transition

Attribute: Split

Indicates the percentage of times the business transition occurs with respect to all transitions which occur from the process.

Read/Write
32 bit signed integer

Parent class: Business Transition


Business Transition.Name

Business Transition

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Business Transition


Business Transition.Full Name

Business Transition

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Business Transition


Business Transition.Full Scoped Name

Business Transition

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Business Transition


Business Transition.Scoped Name

Business Transition

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Business Transition


Business Transition.Comp Pointer

Business Transition

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Business Transition


Business Transition.External Link Last Updated

Business Transition

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Business Transition


Business Transition.Is External

Business Transition

Attribute: Is External

Read/Write
boolean

Parent class: Business Transition


Business Transition.Long Name

Business Transition

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Business Transition


Business Transition.UML Short Dotted Name

Business Transition

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Business Transition


Business Transition.Type

Business Transition

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Business Transition


Business Transition.Last Author

Business Transition

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Business Transition


Business Transition.Last Change Date

Business Transition

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Business Transition


Business Transition.Stereotype

Business Transition

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Business Transition


BusinessTransition.Start

Business Transition

Association: Start

Description:
Read/Write
This role connects to 1 object of classes: Business Event, Business Process, Process Break, Complex Process
All objects connected in this role are uniquely named

Parent Class: Business Transition
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessTransition.End

Business Transition

Association: End

Description:
Read/Write
This role connects to 1 object of classes: Business Event, Business Process, Process Break, Complex Process
All objects connected in this role are uniquely named

Parent Class: Business Transition
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


BusinessTransition.Exclusive Arc

Business Transition

Association: Exclusive Arc

Description:
Read/Write
This role can be used to create an object of Class: CID_ExclusiveArc
This role connects to 0 or 1 object of classes: Exclusive Arc
All objects connected in this role are uniquely named

Parent Class: Business Transition
Inverse roles: ExclusiveArc


BusinessTransition.External Reference

Business Transition

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Transition
Inverse roles: ExternalReference


BusinessTransition.Decomposition Diagram

Business Transition

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Transition
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessTransition.Using Diagram

Business Transition

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Transition


BusinessTransition.Child Diagram

Business Transition

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Business Transition
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


BusinessTransition.External Dictionary Item

Business Transition

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Business Transition


BusinessTransition.The External Reference

Business Transition

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Business Transition
Inverse roles: ExternalReference


BusinessTransition.File Reference

Business Transition

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Business Transition
Inverse roles: FileReference


BusinessTransition.Target Requirement

Business Transition

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Transition
Inverse roles: Requirement


BusinessTransition.Source Requirement

Business Transition

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Business Transition
Inverse roles: Requirement


Class

A description of a group of objects with similar properties, common behaviour, common relationships and common semantics.

Attributes

Architectural Level
External
Is Inner Class
Is Parent
Type
Access
Constraints
Description
Is Persistent
Is Structure
Name
Parameters
Stereotype
Template Class
Is Abstract
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Last Author
Last Change Date

Associations

Actor
Association Start
Association End
Association
Attribute
Inherited Attribute
Role Attribute
Data Attribute
Sub Class
Super Class
Parent Association
Sends Events
Receives Events
Ternary Role
Role
Child UML Interface
Parent UML Interface
Realized UML Interface
Realizing Class
Parent Class
Child Class
States
Inherited Operation
Increment
Use Case
Corporate Class
Operation
Scoped Class
Scoping Class
Namespace
Other Role
Accessible Operation
CD Realization
External Reference
Raising Operation
Corporate View
External User Class
External UML Interface
External Business Class
User Class
UML Interface
Exception
Business Class
External Exception
Class
External Class
Local Class
Typedef
Alias
Array
Enumeration
Sequence
Scoped Item
Generalization
Specialization
SubType
SuperType
Storage Model
Typed Attribute
Type Definition
Typed Operation
Typed Parameter
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
SCMComponent
Activity Diagram


Class.Architectural Level

Class

Attribute: Architectural Level

Alias of Stereotype for backward compatibility with Corporate Views.

Read/Write
Enumeration, values: Business, User, Interface, Exception

Parent class: Class


Class.External

Class

Attribute: External

6.x compatibility.

Read/Write
boolean

Parent class: Class


Class.Is Inner Class

Class

Attribute: Is Inner Class

Returns true if the class is an inner class.

Read only
boolean

Parent class: Class


Class.Is Parent

Class

Attribute: Is Parent

Returns true if the class has any items scoped to it.

Read only
boolean

Parent class: Class


Class.Type

Class

Attribute: Type

The object type.

Read only
String of up to 50 characters

Parent class: Class


Class.Access

Class

Attribute: Access

The visibility/access of a class.

Read/Write
Enumeration, values: Public, Protected, Package Protected, Private

Parent class: Class


Class.Constraints

Class

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Class


Class.Description

Class

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Class


Class.Is Persistent

Class

Attribute: Is Persistent

Indicates whether the class is persistent (requires storage) or not.

Read/Write
boolean

Parent class: Class


Class.Is Structure

Class

Attribute: Is Structure

Indicates whether the class is a structure or not (C++ constructs).

Read/Write
boolean

Parent class: Class


Class.Name

Class

Attribute: Name

Name of the object - this is an over ride of the NamedDictionaryItem attribute to propagate change to Exceptions

Read/Write
String of up to 100 characters

Parent class: Class


Class.Parameters

Class

Attribute: Parameters

String containing a comma separated list of parameter of the class.

Read/Write
String of up to 16385 characters

Parent class: Class


Class.Stereotype

Class

Attribute: Stereotype

Read/Write
Enumeration, values: Business, User, Interface, Exception

Parent class: Class


Class.Template Class

Class

Attribute: Template Class

Indicates whether the class is a template class. (generally used by the C++ generator).

Read/Write
boolean

Parent class: Class


Class.Is Abstract

Class

Attribute: Is Abstract

Indicates whether the taxonomy is abstract or not.

Read/Write
boolean

Parent class: Class


Class.Full Name

Class

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Class


Class.Full Scoped Name

Class

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Class


Class.Local Full Scoped Name

Class

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Class


Class.Local Scoped Name

Class

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Class


Class.Scoped Name

Class

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Class


Class.UML Short Dotted Name

Class

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Class


Class.Comp Pointer

Class

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Class


Class.External Link Last Updated

Class

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Class


Class.Is External

Class

Attribute: Is External

Read/Write
boolean

Parent class: Class


Class.Long Name

Class

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Class


Class.Last Author

Class

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Class


Class.Last Change Date

Class

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Class


Class.Actor

Class

Association: Actor

Description:
Read/Write
This role connects to 1 object of classes: Actor
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Actor


Class.Association Start

Class

Association: Association Start

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Association

Parent Class: Class
Inverse roles: Association


Class.Association End

Class

Association: Association End

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Association

Parent Class: Class
Inverse roles: Association


Class.Association

Class

Association: Association

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Association

Parent Class: Class


Class.Attribute

Class

Association: Attribute

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Attribute
This role connects to 0 or more objects of classes: Attribute
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class
Inverse roles: Attribute


Class.Inherited Attribute

Class

Association: Inherited Attribute

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Attribute

Parent Class: Class


Class.Role Attribute

Class

Association: Role Attribute

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Attribute

Parent Class: Class


Class.Data Attribute

Class

Association: Data Attribute

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Attribute

Parent Class: Class


Class.Sub Class

Class

Association: Sub Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Super Class

Class

Association: Super Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Parent Association

Class

Association: Parent Association

Description:
Read/Write
This role connects to 0 or 1 object of classes: Association, Ternary Association
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Association, TernaryAssociation


Class.Sends Events

Class

Association: Sends Events

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Event
All objects connected in this role are uniquely named

Parent Class: Class


Class.Receives Events

Class

Association: Receives Events

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Event
All objects connected in this role are uniquely named

Parent Class: Class


Class.Ternary Role

Class

Association: Ternary Role

Description:
Read/Write
This role connects to 0 or more objects of classes: Ternary Role
This role propagates delete

Parent Class: Class
Inverse roles: TernaryRole


Class.Role

Class

Association: Role

Description:
Read/Write
This role connects to 0 or more objects of classes: Role
This role propagates delete

Parent Class: Class
Inverse roles: Role


Class.Child UML Interface

Class

Association: Child UML Interface

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Parent UML Interface

Class

Association: Parent UML Interface

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Realized UML Interface

Class

Association: Realized UML Interface

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Realizing Class

Class

Association: Realizing Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Parent Class

Class

Association: Parent Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.Child Class

Class

Association: Child Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Class
Inverse roles: Class


Class.States

Class

Association: States

Description:
Read/Write
This role connects to 0 or more objects of classes: State
This role propagates delete

Parent Class: Class
Inverse roles: State


Class.Inherited Operation

Class

Association: Inherited Operation

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Operation

Parent Class: Class


Class.Increment

Class

Association: Increment

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Increment


Class.Use Case

Class

Association: Use Case

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: UseCase


Class.Corporate Class

Class

Association: Corporate Class

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class


Class.Operation

Class

Association: Operation

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Operation
This role connects to 0 or more objects of classes: Operation
This role propagates delete

Parent Class: Class
Inverse roles: Operation


Class.Scoped Class

Class

Association: Scoped Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Class
Inverse roles: Class


Class.Scoping Class

Class

Association: Scoping Class

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Class


Class.Namespace

Class

Association: Namespace

Description:
Read/Write
This role connects to 1 object of classes: Class, Package, Model
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Class, Package, Model


Class.Other Role

Class

Association: Other Role

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Role

Parent Class: Class


Class.Accessible Operation

Class

Association: Accessible Operation

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Operation

Parent Class: Class


Class.CD Realization

Class

Association: CD Realization

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: CD::Realization

Parent Class: Class
Inverse roles: CDRealization


Class.External Reference

Class

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: ExternalReference


Class.Raising Operation

Class

Association: Raising Operation

Description:
Read/Write
This role connects to 0 or more objects of classes: Operation

Parent Class: Class
Inverse roles: Operation


Class.Corporate View

Class

Association: Corporate View

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is an alias of: RID_Namespace_To_ExternalClass
This role connects to 0 or more objects of classes: Class

Parent Class: Class


Class.External User Class

Class

Association: External User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.External UML Interface

Class

Association: External UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.External Business Class

Class

Association: External Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.User Class

Class

Association: User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class


Class.UML Interface

Class

Association: UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class


Class.Exception

Class

Association: Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class


Class.Business Class

Class

Association: Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Class


Class.External Exception

Class

Association: External Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.Class

Class

Association: Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class
Inverse roles: Class


Class.External Class

Class

Association: External Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.Local Class

Class

Association: Local Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class


Class.Typedef

Class

Association: Typedef

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class
Inverse roles: Typedef


Class.Alias

Class

Association: Alias

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Class


Class.Array

Class

Association: Array

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Class


Class.Enumeration

Class

Association: Enumeration

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Class


Class.Sequence

Class

Association: Sequence

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Class


Class.Scoped Item

Class

Association: Scoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Class.Generalization

Class

Association: Generalization

Description:
Read/Write
This role can be used to create an object of Class: CID_Generalization
This role connects to 0 or more objects of classes: Generalization
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Class
Inverse roles: Generalization


Class.Specialization

Class

Association: Specialization

Description:
Read/Write
This role can be used to create an object of Class: CID_Specialization
This role connects to 0 or more objects of classes: Specialization
This role propagates delete

Parent Class: Class
Inverse roles: Specialization


Class.SubType

Class

Association: SubType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Class
Inverse roles: Class, Actor, UseCase


Class.SuperType

Class

Association: SuperType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Class
Inverse roles: Class, Actor, UseCase


Class.Storage Model

Class

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Class
Inverse roles: Relationship, Column, Table


Class.Typed Attribute

Class

Association: Typed Attribute

Description:
Read/Write
This role connects to 0 or more objects of classes: Qualifier, Attribute

Parent Class: Class
Inverse roles: Qualifier, Attribute


Class.Type Definition

Class

Association: Type Definition

Description:
Read/Write
This role connects to 0 or more objects of classes: Typedef

Parent Class: Class
Inverse roles: Typedef


Class.Typed Operation

Class

Association: Typed Operation

Description:
Read/Write
This role connects to 0 or more objects of classes: Operation

Parent Class: Class
Inverse roles: Operation


Class.Typed Parameter

Class

Association: Typed Parameter

Description:
Read/Write
This role connects to 0 or more objects of classes: Parameter

Parent Class: Class
Inverse roles: Parameter


Class.Category

Class

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Package


Class.Package

Class

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Package


Class.Dependee Item

Class

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Class.Dependent Item

Class

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Class.Scoping Item

Class

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: Class, Package, Model, Requirement


Class.Decomposition Diagram

Class

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Class.Using Diagram

Class

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class


Class.Child Diagram

Class

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Class.External Dictionary Item

Class

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Class


Class.The External Reference

Class

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Class
Inverse roles: ExternalReference


Class.File Reference

Class

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Class
Inverse roles: FileReference


Class.Target Requirement

Class

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Class
Inverse roles: Requirement


Class.Source Requirement

Class

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Class
Inverse roles: Requirement


Class.SCMComponent

Class

Association: SCMComponent

Description:
Read/Write
This role connects to 0 or more objects of classes: SCMComponent
This role propagates delete

Parent Class: Class
Inverse roles: SCMComponent


Class.Activity Diagram

Class

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Class
Inverse roles: ActivityDiagram


Class Diagram

Represents a Class Diagram.

Attributes

Default View Access Character
Default View Association Name
Default View Private Attributes
Default View Private Operations
Default View Protected Attributes
Default View Protected Operations
Default View Public Attributes
Default View Public Operations
Default View Role Names
Page Ref
Default View Show Signature
Default View Packaged Attributes
Default View Packaged Operations
Default View Package Short Name Always
Default View Class Short Name Always
Default View Role Attributes
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

CD Association Link
CD Class
Diagrams
CD Ternary Association
CD Ternary Role
Container
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Class Diagram.Default View Access Character

Class Diagram

Attribute: Default View Access Character

Indicates whether the default view option for a class is to have the access character (for an attribute or operation) to be displayed or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Association Name

Class Diagram

Attribute: Default View Association Name

Indicates whether the default view option for an association is to have the name displayed or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Private Attributes

Class Diagram

Attribute: Default View Private Attributes

Indicates whether the default view option for a class is to display private attributes or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Private Operations

Class Diagram

Attribute: Default View Private Operations

Indicates whether the default view option for a class is to display it's private operations or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Protected Attributes

Class Diagram

Attribute: Default View Protected Attributes

Indicates whether the default view option for a class is to display it's protected attributes or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Protected Operations

Class Diagram

Attribute: Default View Protected Operations

Indicates whether the default view option for a class is to display it's protected operations or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Public Attributes

Class Diagram

Attribute: Default View Public Attributes

Indicates whether the default view option for a class is to display it's public attributes or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Public Operations

Class Diagram

Attribute: Default View Public Operations

Indicates whether the default view option for a class is to display it's public operations or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Role Names

Class Diagram

Attribute: Default View Role Names

Indicates whether the default view option for a association is to display it's role names or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Page Ref

Class Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Class Diagram


Class Diagram.Default View Show Signature

Class Diagram

Attribute: Default View Show Signature

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Packaged Attributes

Class Diagram

Attribute: Default View Packaged Attributes

Indicates whether the default view option for a class is to display it's within package attributes or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Packaged Operations

Class Diagram

Attribute: Default View Packaged Operations

Indicates whether the default view option for a class is to display it's within package operations or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Package Short Name Always

Class Diagram

Attribute: Default View Package Short Name Always

Property used to specifiy that the default package name should always be displayed in a short format with no scoping information

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Class Short Name Always

Class Diagram

Attribute: Default View Class Short Name Always

Indicates whether the short name is to be displayed by default when the class symbol is drawn.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Default View Role Attributes

Class Diagram

Attribute: Default View Role Attributes

Indicates whether the default view option for a class is to display private attributes or not.

Read/Write
boolean

Parent class: Class Diagram


Class Diagram.Filename

Class Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Class Diagram


Class Diagram.Full Type

Class Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Class Diagram


Class Diagram.Pathname

Class Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Class Diagram


Class Diagram.Title

Class Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Class Diagram


Class Diagram.Description

Class Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Class Diagram


Class Diagram.Meta File

Class Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Class Diagram


Class Diagram.Page Orientation

Class Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Class Diagram


Class Diagram.Page Count

Class Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Class Diagram


Class Diagram.Full Name

Class Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Full Scoped Name

Class Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Local Full Scoped Name

Class Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Local Scoped Name

Class Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Scoped Name

Class Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.UML Short Dotted Name

Class Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Long Name

Class Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Class Diagram


Class Diagram.Type

Class Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Class Diagram


Class Diagram.Last Author

Class Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Class Diagram


Class Diagram.Last Change Date

Class Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Class Diagram


Class Diagram.Stereotype

Class Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Class Diagram


ClassDiagram.CD Association Link

Class Diagram

Association: CD Association Link

Description:
Read/Write
This role can be used to create an object of Class: CID_CDAssociationLink
This role connects to 0 or more objects of classes: CD::Association Link
This role propagates delete

Parent Class: Class Diagram
Inverse roles: CDAssociationLink


ClassDiagram.CD Class

Class Diagram

Association: CD Class

Description:
Read/Write
This role can be used to create an object of Class: CID_CDClass
This role connects to 0 or more objects of classes: CD::Class
This role propagates delete

Parent Class: Class Diagram
Inverse roles: CDClass


ClassDiagram.Diagrams

Class Diagram

Association: Diagrams

Description:
Read/Write
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Diagrams


ClassDiagram.CD Ternary Association

Class Diagram

Association: CD Ternary Association

Description:
Read/Write
This role can be used to create an object of Class: CID_CDTernaryAssociation
This role connects to 0 or more objects of classes: CD::Ternary Association
This role propagates delete

Parent Class: Class Diagram
Inverse roles: CDTernaryAssociation


ClassDiagram.CD Ternary Role

Class Diagram

Association: CD Ternary Role

Description:
Read/Write
This role can be used to create an object of Class: CID_CDTernaryRole
This role connects to 0 or more objects of classes: CD::Ternary Role
This role propagates delete

Parent Class: Class Diagram
Inverse roles: CDTernaryRole


ClassDiagram.Container

Class Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Model


ClassDiagram.Decomposed Dictionary Item

Class Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ClassDiagram.Parent Dictionary Item

Class Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Class Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ClassDiagram.Category

Class Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Package


ClassDiagram.Package

Class Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Package


ClassDiagram.Dependee Item

Class Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ClassDiagram.Dependent Item

Class Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Class Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ClassDiagram.Scoping Item

Class Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Class Diagram
Inverse roles: Class, Package, Model, Requirement


ClassDiagram.File Reference

Class Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Class Diagram
Inverse roles: FileReference


ClassDiagram.Target Requirement

Class Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Class Diagram
Inverse roles: Requirement


ClassDiagram.Source Requirement

Class Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Class Diagram
Inverse roles: Requirement


Column

Analogous to the attributes of an object.

Attributes

Data Type
Full Name
Full Scoped Name
Has Data Type
Is Foreign
Is Signed
Length
Physical Length
Physical Scale
Precision
Scale
Scoped Name
Type Declaration
Can Be Null
Constraints
Default Values
Description
Domain Values
Is Prime
Is Unique
Physical Data Type
Physical Is Signed
Physical Precision
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Basic Type
Foreign Column
Prime Column
Index
Table
Column Sort
External Reference
Data Type
Class Model
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Column.Data Type

Column

Attribute: Data Type

The target SQL data type of a column.

Read/Write
String of up to 100 characters

Parent class: Column


Column.Full Name

Column

Attribute: Full Name

Full name for a Column, e.g. c1 [t1.]

Read only
String of up to 100 characters

Parent class: Column


Column.Full Scoped Name

Column

Attribute: Full Scoped Name

Full scoped name for a Column, e.g. t1.c1

Read only
String of up to 100 characters

Parent class: Column


Column.Has Data Type

Column

Attribute: Has Data Type

Indicates if the Column has an interpreted (Dictionary linked) data type.

Read only
boolean

Parent class: Column


Column.Is Foreign

Column

Attribute: Is Foreign

Read only attribute - returns TRUE if there is a Column attached via the role RID_ForeignColumn_To_JoinColumn

Read only
boolean

Parent class: Column


Column.Is Signed

Column

Attribute: Is Signed

Read/Write
boolean

Parent class: Column


Column.Length

Column

Attribute: Length

TODO

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Physical Length

Column

Attribute: Physical Length

TODO

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Physical Scale

Column

Attribute: Physical Scale

TODO

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Precision

Column

Attribute: Precision

A text string containing the precision or scale of a numeric value or the size of a text string.

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Scale

Column

Attribute: Scale

TODO

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Scoped Name

Column

Attribute: Scoped Name

Full name for a Column, e.g. t1.c1

Read only
String of up to 100 characters

Parent class: Column


Column.Type Declaration

Column

Attribute: Type Declaration

A string containing the true data type which is the dotted name of the dictionary item connected via the data type dictionary link.

Read only
String of up to 16385 characters

Parent class: Column


Column.Can Be Null

Column

Attribute: Can Be Null

Indicates whether a column can be null or not.

Read/Write
boolean

Parent class: Column


Column.Constraints

Column

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Column


Column.Default Values

Column

Attribute: Default Values

String containing default values for the column.

Read/Write
String of up to 16385 characters

Parent class: Column


Column.Description

Column

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Column


Column.Domain Values

Column

Attribute: Domain Values

String containing domain values (range of valid values) for the column.

Read/Write
String of up to 16385 characters

Parent class: Column


Column.Is Prime

Column

Attribute: Is Prime

Indicates whether the column is part of a prime key for the table or not.

Read/Write
boolean

Parent class: Column


Column.Is Unique

Column

Attribute: Is Unique

Indicates whether the column is unique or not (i.e. The column in the table will always identify one item e.g. part number will uniquely identify a part)

Read/Write
boolean

Parent class: Column


Column.Physical Data Type

Column

Attribute: Physical Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Column


Column.Physical Is Signed

Column

Attribute: Physical Is Signed

Read/Write
boolean

Parent class: Column


Column.Physical Precision

Column

Attribute: Physical Precision

A text string containing the precision or scale of a numeric value or the size of a text string.

Read/Write
String of up to 1024 characters

Parent class: Column


Column.UML Short Dotted Name

Column

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Column


Column.Name

Column

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Column


Column.Comp Pointer

Column

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Column


Column.External Link Last Updated

Column

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Column


Column.Is External

Column

Attribute: Is External

Read/Write
boolean

Parent class: Column


Column.Long Name

Column

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Column


Column.Type

Column

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Column


Column.Last Author

Column

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Column


Column.Last Change Date

Column

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Column


Column.Stereotype

Column

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Column


Column.Basic Type

Column

Association: Basic Type

Description: TODO
Read only
This role is derived
This role connects to 1 object of classes: Basic Type
All objects connected in this role are uniquely named

Parent Class: Column


Column.Foreign Column

Column

Association: Foreign Column

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Column

Parent Class: Column
Inverse roles: Column


Column.Prime Column

Column

Association: Prime Column

Description:
Read only
This role is derived
This role connects to 1 or more objects of classes: Column

Parent Class: Column
Inverse roles: Column


Column.Index

Column

Association: Index

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Index

Parent Class: Column
Inverse roles: Index


Column.Table

Column

Association: Table

Description:
Read/Write
This role connects to 1 object of classes: Table
All objects connected in this role are uniquely named

Parent Class: Column
Inverse roles: Table


Column.Column Sort

Column

Association: Column Sort

Description:
Read/Write
This role can be used to create an object of Class: CID_ColumnSort
This role connects to 0 or more objects of classes: Column Sort
This role propagates delete

Parent Class: Column
Inverse roles: ColumnSort


Column.External Reference

Column

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Column
Inverse roles: ExternalReference


Column.Data Type

Column

Association: Data Type

Description: TODO
Read/Write
This role connects to 0 or 1 object of classes: Basic Type, Typedef
All objects connected in this role are uniquely named

Parent Class: Column
Inverse roles: BasicType, Typedef


Column.Class Model

Column

Association: Class Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Class, Association, Ternary Association, Ternary Role, Attribute, Specialization

Parent Class: Column
Inverse roles: Class, Association, TernaryAssociation, TernaryRole, Attribute, Specialization


Column.Decomposition Diagram

Column

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Column.Using Diagram

Column

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column


Column.Child Diagram

Column

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Column.External Dictionary Item

Column

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Column


Column.The External Reference

Column

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Column
Inverse roles: ExternalReference


Column.File Reference

Column

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Column
Inverse roles: FileReference


Column.Target Requirement

Column

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Column
Inverse roles: Requirement


Column.Source Requirement

Column

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Column
Inverse roles: Requirement


Column Sort

Represents the data on the association between index and column (i.e. ordering of a column within an index).

Attributes

Full Name
Is Ascending
Scoped Name
Full Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Column
Index
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Column Sort.Full Name

Column Sort

Attribute: Full Name

Full name for a Column Sort, e.g. cs1 [index1.c1.]

Read only
String of up to 100 characters

Parent class: Column Sort


Column Sort.Is Ascending

Column Sort

Attribute: Is Ascending

True if the sort direction of the associated column is Ascending.

Read/Write
boolean

Parent class: Column Sort


Column Sort.Scoped Name

Column Sort

Attribute: Scoped Name

Scoped name for a Column Sort, e.g. c1.cs1

Read only
String of up to 100 characters

Parent class: Column Sort


Column Sort.Full Scoped Name

Column Sort

Attribute: Full Scoped Name

Full scoped name for a Column Sort, e.g. index1.c1.cs1

Read only
String of up to 100 characters

Parent class: Column Sort


Column Sort.UML Short Dotted Name

Column Sort

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Column Sort


Column Sort.Name

Column Sort

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Column Sort


Column Sort.Comp Pointer

Column Sort

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Column Sort


Column Sort.External Link Last Updated

Column Sort

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Column Sort


Column Sort.Is External

Column Sort

Attribute: Is External

Read/Write
boolean

Parent class: Column Sort


Column Sort.Long Name

Column Sort

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Column Sort


Column Sort.Type

Column Sort

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Column Sort


Column Sort.Last Author

Column Sort

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Column Sort


Column Sort.Last Change Date

Column Sort

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Column Sort


Column Sort.Stereotype

Column Sort

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Column Sort


ColumnSort.Column

Column Sort

Association: Column

Description:
Read/Write
This role connects to 1 object of classes: Column
All objects connected in this role are uniquely named

Parent Class: Column Sort
Inverse roles: Column


ColumnSort.Index

Column Sort

Association: Index

Description:
Read/Write
This role connects to 1 object of classes: Index
All objects connected in this role are uniquely named

Parent Class: Column Sort
Inverse roles: Index


ColumnSort.External Reference

Column Sort

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Column Sort
Inverse roles: ExternalReference


ColumnSort.Decomposition Diagram

Column Sort

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column Sort
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ColumnSort.Using Diagram

Column Sort

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column Sort


ColumnSort.Child Diagram

Column Sort

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Column Sort
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ColumnSort.External Dictionary Item

Column Sort

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Column Sort


ColumnSort.The External Reference

Column Sort

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Column Sort
Inverse roles: ExternalReference


ColumnSort.File Reference

Column Sort

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Column Sort
Inverse roles: FileReference


ColumnSort.Target Requirement

Column Sort

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Column Sort
Inverse roles: Requirement


ColumnSort.Source Requirement

Column Sort

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Column Sort
Inverse roles: Requirement


Complex Process

This represents any Dictionary Item which can encapsulate Business Process logic. Formerly known as: Parallel/Iteration

All objects of this class are name unique within a Model

Attributes

Type
Is Iteration
Description
Constraints
Number
Logic
Full Scoped Name
Scoped Name
UML Short Dotted Name
Full Name
Local Full Scoped Name
Local Scoped Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Nested Child
Dictionary
External Reference
Parent
Out Transition
In Transition
Transition To
Transition From
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Complex Process.Type

Complex Process

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Complex Process


Complex Process.Is Iteration

Complex Process

Attribute: Is Iteration

The type of process thread container which is either Iteration or Concurrence.

Read/Write
boolean

Parent class: Complex Process


Complex Process.Description

Complex Process

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Complex Process


Complex Process.Constraints

Complex Process

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Complex Process


Complex Process.Number

Complex Process

Attribute: Number

Value which indicates the number of iterations of the process (for an iteration complex business process).

Read/Write
32 bit signed integer

Parent class: Complex Process


Complex Process.Logic

Complex Process

Attribute: Logic

Text string which states the logic which initiates the iteration of the process (for an iteration complex business process).

Read/Write
String of up to 16385 characters

Parent class: Complex Process


Complex Process.Full Scoped Name

Complex Process

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Scoped Name

Complex Process

Attribute: Scoped Name

Scoped name for a Nestable Item, e.g. Iteration1:Business Process2

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.UML Short Dotted Name

Complex Process

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Full Name

Complex Process

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Local Full Scoped Name

Complex Process

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Local Scoped Name

Complex Process

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Name

Complex Process

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Complex Process


Complex Process.Comp Pointer

Complex Process

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Complex Process


Complex Process.External Link Last Updated

Complex Process

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Complex Process


Complex Process.Is External

Complex Process

Attribute: Is External

Read/Write
boolean

Parent class: Complex Process


Complex Process.Long Name

Complex Process

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Complex Process


Complex Process.Last Author

Complex Process

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Complex Process


Complex Process.Last Change Date

Complex Process

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Complex Process


Complex Process.Stereotype

Complex Process

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Complex Process


ComplexProcess.Nested Child

Complex Process

Association: Nested Child

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process, Process Break, Complex Process
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: BusinessProcess, ProcessBreak, ComplexProcess


ComplexProcess.Dictionary

Complex Process

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: Dictionary


ComplexProcess.External Reference

Complex Process

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: ExternalReference


ComplexProcess.Parent

Complex Process

Association: Parent

Description:
Read/Write
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: ComplexProcess


ComplexProcess.Out Transition

Complex Process

Association: Out Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Complex Process
Inverse roles: BusinessTransition


ComplexProcess.In Transition

Complex Process

Association: In Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Complex Process
Inverse roles: BusinessTransition


ComplexProcess.Transition To

Complex Process

Association: Transition To

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Complex Process
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


ComplexProcess.Transition From

Complex Process

Association: Transition From

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Complex Process
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


ComplexProcess.Category

Complex Process

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: Package


ComplexProcess.Package

Complex Process

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: Package


ComplexProcess.Dependee Item

Complex Process

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Complex Process
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ComplexProcess.Dependent Item

Complex Process

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Complex Process
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ComplexProcess.Scoping Item

Complex Process

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: Class, Package, Model, Requirement


ComplexProcess.Decomposition Diagram

Complex Process

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Complex Process
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ComplexProcess.Using Diagram

Complex Process

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Complex Process


ComplexProcess.Child Diagram

Complex Process

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Complex Process
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ComplexProcess.External Dictionary Item

Complex Process

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Complex Process


ComplexProcess.The External Reference

Complex Process

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Complex Process
Inverse roles: ExternalReference


ComplexProcess.File Reference

Complex Process

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Complex Process
Inverse roles: FileReference


ComplexProcess.Target Requirement

Complex Process

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Complex Process
Inverse roles: Requirement


ComplexProcess.Source Requirement

Complex Process

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Complex Process
Inverse roles: Requirement


Database

All objects of this class are name unique within a Model

Attributes

Description
Constraints
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Container
Table
Dictionary
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Database.Description

Database

Attribute: Description

Read/Write
String of up to 16385 characters

Parent class: Database


Database.Constraints

Database

Attribute: Constraints

Read/Write
String of up to 16385 characters

Parent class: Database


Database.Name

Database

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Database


Database.Full Name

Database

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Database


Database.Full Scoped Name

Database

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Database


Database.Scoped Name

Database

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Database


Database.Comp Pointer

Database

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Database


Database.External Link Last Updated

Database

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Database


Database.Is External

Database

Attribute: Is External

Read/Write
boolean

Parent class: Database


Database.Long Name

Database

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Database


Database.UML Short Dotted Name

Database

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Database


Database.Type

Database

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Database


Database.Last Author

Database

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Database


Database.Last Change Date

Database

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Database


Database.Stereotype

Database

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Database


Database.Container

Database

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Database
Inverse roles: Model


Database.Table

Database

Association: Table

Description:
Read/Write
This role can be used to create an object of Class: CID_Table
This role connects to 0 or more objects of classes: Table
All objects connected in this role are uniquely named

Parent Class: Database
Inverse roles: Table


Database.Dictionary

Database

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Database
Inverse roles: Dictionary


Database.Decomposition Diagram

Database

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Database
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Database.Using Diagram

Database

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Database


Database.Child Diagram

Database

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Database
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Database.External Dictionary Item

Database

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Database


Database.The External Reference

Database

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Database
Inverse roles: ExternalReference


Database.File Reference

Database

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Database
Inverse roles: FileReference


Database.Target Requirement

Database

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Database
Inverse roles: Requirement


Database.Source Requirement

Database

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Database
Inverse roles: Requirement


Dependency

Shows client-supplier dependency between categories.

All objects of this class are name unique within a Model

Attributes

Constraints
Description
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Dependent
Dependee
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Dependency.Constraints

Dependency

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Dependency


Dependency.Description

Dependency

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Dependency


Dependency.Name

Dependency

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Dependency


Dependency.Full Name

Dependency

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Dependency


Dependency.Full Scoped Name

Dependency

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Dependency


Dependency.Scoped Name

Dependency

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Dependency


Dependency.Comp Pointer

Dependency

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Dependency


Dependency.External Link Last Updated

Dependency

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Dependency


Dependency.Is External

Dependency

Attribute: Is External

Read/Write
boolean

Parent class: Dependency


Dependency.Long Name

Dependency

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Dependency


Dependency.UML Short Dotted Name

Dependency

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Dependency


Dependency.Type

Dependency

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Dependency


Dependency.Last Author

Dependency

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Dependency


Dependency.Last Change Date

Dependency

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Dependency


Dependency.Stereotype

Dependency

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Dependency


Dependency.Dependent

Dependency

Association: Dependent

Description:
Read/Write
This role connects to 1 object of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram
All objects connected in this role are uniquely named

Parent Class: Dependency
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Dependency.Dependee

Dependency

Association: Dependee

Description:
Read/Write
This role connects to 1 object of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram
All objects connected in this role are uniquely named

Parent Class: Dependency
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Dependency.External Reference

Dependency

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Dependency
Inverse roles: ExternalReference


Dependency.Decomposition Diagram

Dependency

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Dependency
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Dependency.Using Diagram

Dependency

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Dependency


Dependency.Child Diagram

Dependency

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Dependency
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Dependency.External Dictionary Item

Dependency

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Dependency


Dependency.The External Reference

Dependency

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Dependency
Inverse roles: ExternalReference


Dependency.File Reference

Dependency

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Dependency
Inverse roles: FileReference


Dependency.Target Requirement

Dependency

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Dependency
Inverse roles: Requirement


Dependency.Source Requirement

Dependency

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Dependency
Inverse roles: Requirement


Diagram Data

A fix up to allow us to read Filename even when another User has the Diagram open - and therefore locked. Note: To create a new diagram with a unique name, all filenames must be read (to determine a unique name) and locked (to ensure the no filenames are changed during creation of the new diagram). This can't be achieved if a diagram is open as read/write because the diagram and it's filename are locked. Therefore this class is created when the diagram is created, with it's name matching the diagram's filename, so that the name can be read and locked when the diagram is being updated.

All objects of this class are name unique within a Model

Attributes

Associations


PTD::Diagram Swimlane

TODO

Attributes

Long Name
Type
Last Author
Last Change Date

Associations

Process Thread Diagram
PTD Business Process
PTD Event
PTD Process Break
PTD Result


PTD::Diagram Swimlane.Long Name

PTD::Diagram Swimlane

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: PTD::Diagram Swimlane


PTD::Diagram Swimlane.Type

PTD::Diagram Swimlane

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: PTD::Diagram Swimlane


PTD::Diagram Swimlane.Last Author

PTD::Diagram Swimlane

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: PTD::Diagram Swimlane


PTD::Diagram Swimlane.Last Change Date

PTD::Diagram Swimlane

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: PTD::Diagram Swimlane


PTDDiagramSwimlane.Process Thread Diagram

PTD::Diagram Swimlane

Association: Process Thread Diagram

Description: TODO
Read/Write
This role connects to 1 object of classes: Process Thread Diagram
All objects connected in this role are uniquely named

Parent Class: PTD::Diagram Swimlane
Inverse roles: ProcessThreadDiagram


PTDDiagramSwimlane.PTD Business Process

PTD::Diagram Swimlane

Association: PTD Business Process

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDBusinessProcess
This role connects to 0 or more objects of classes: PTD::Business Process
This role propagates delete

Parent Class: PTD::Diagram Swimlane
Inverse roles: PTDBusinessProcess


PTDDiagramSwimlane.PTD Event

PTD::Diagram Swimlane

Association: PTD Event

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDEvent
This role connects to 0 or more objects of classes: PTD::Event
This role propagates delete

Parent Class: PTD::Diagram Swimlane
Inverse roles: PTDEvent


PTDDiagramSwimlane.PTD Process Break

PTD::Diagram Swimlane

Association: PTD Process Break

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDProcessBreak
This role connects to 0 or more objects of classes: PTD::Process Break
This role propagates delete

Parent Class: PTD::Diagram Swimlane
Inverse roles: PTDProcessBreak


PTDDiagramSwimlane.PTD Result

PTD::Diagram Swimlane

Association: PTD Result

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDResult
This role connects to 0 or more objects of classes: PTD::Result
This role propagates delete

Parent Class: PTD::Diagram Swimlane
Inverse roles: PTDResult


AD::Diagram Swimlane

TODO

Attributes

Long Name
Type
Last Author
Last Change Date

Associations

Activity Diagram


AD::Diagram Swimlane.Long Name

AD::Diagram Swimlane

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: AD::Diagram Swimlane


AD::Diagram Swimlane.Type

AD::Diagram Swimlane

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: AD::Diagram Swimlane


AD::Diagram Swimlane.Last Author

AD::Diagram Swimlane

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: AD::Diagram Swimlane


AD::Diagram Swimlane.Last Change Date

AD::Diagram Swimlane

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: AD::Diagram Swimlane


ADDiagramSwimlane.Activity Diagram

AD::Diagram Swimlane

Association: Activity Diagram

Description: TODO
Read/Write
This role connects to 1 object of classes: Activity Diagram
All objects connected in this role are uniquely named

Parent Class: AD::Diagram Swimlane
Inverse roles: ActivityDiagram


Diagrams

Represents the collection of Diagrams in the model.

This class has a default role: RID_Diagrams_To_Diagram

Attributes

Long Name
Type
Last Author
Last Change Date

Associations

Parentless Activity Diagram
Activity Diagram
Class Diagram
Use Case Diagram
State Diagram
Process Thread Diagram
Collaboration Dgm
Sequence Diagram
Process Thread
Process Hierarchy
General Graphics
Text Document
Unscoped Item
Table Relationships Diagram
Storage Class


Diagrams.Long Name

Diagrams

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Diagrams


Diagrams.Type

Diagrams

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Diagrams


Diagrams.Last Author

Diagrams

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Diagrams


Diagrams.Last Change Date

Diagrams

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Diagrams


Diagrams.Parentless Activity Diagram

Diagrams

Association: Parentless Activity Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Activity Diagram

Parent Class: Diagrams


Diagrams.Activity Diagram

Diagrams

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: ActivityDiagram


Diagrams.Class Diagram

Diagrams

Association: Class Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ClassDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: ClassDiagram


Diagrams.Use Case Diagram

Diagrams

Association: Use Case Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCaseDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Use Case Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: UseCaseDiagram


Diagrams.State Diagram

Diagrams

Association: State Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_StateDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: State Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: StateDiagram


Diagrams.Process Thread Diagram

Diagrams

Association: Process Thread Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessThreadDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Thread Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: ProcessThreadDiagram


Diagrams.Collaboration Dgm

Diagrams

Association: Collaboration Dgm

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectCollaborationDiagram
This role is an alias of: RID_Diagrams_To_ObjectCollaborationDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Object Collaboration Diagram

Parent Class: Diagrams


Diagrams.Sequence Diagram

Diagrams

Association: Sequence Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectSequenceDiagram
This role is an alias of: RID_Diagrams_To_ObjectSequenceDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Object Sequence Diagram

Parent Class: Diagrams


Diagrams.Process Thread

Diagrams

Association: Process Thread

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessThreadDiagram
This role is an alias of: RID_Diagrams_To_ProcessThreadDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Thread Diagram

Parent Class: Diagrams


Diagrams.Process Hierarchy

Diagrams

Association: Process Hierarchy

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessHierarchyDiagram
This role is an alias of: RID_Diagrams_To_ProcessHierarchyDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Hierarchy Diagram

Parent Class: Diagrams


Diagrams.General Graphics

Diagrams

Association: General Graphics

Description:
Read/Write
This role can be used to create an object of Class: CID_GeneralGraphicsDiagram
This role is an alias of: RID_Diagrams_To_GeneralGraphicsDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: General Graphics Diagram

Parent Class: Diagrams


Diagrams.Text Document

Diagrams

Association: Text Document

Description:
Read/Write
This role can be used to create an object of Class: CID_TextDiagram
This role is an alias of: RID_Diagrams_To_TextDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Text Diagram

Parent Class: Diagrams


Diagrams.Unscoped Item

Diagrams

Association: Unscoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Diagrams


Diagrams.Table Relationships Diagram

Diagrams

Association: Table Relationships Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_TableRelationshipsDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Table Relationships Diagram
This role propagates delete

Parent Class: Diagrams
Inverse roles: TableRelationshipsDiagram


Diagrams.Storage Class

Diagrams

Association: Storage Class

Description:
Read/Write
This role can be used to create an object of Class: CID_TableRelationshipsDiagram
This role is an alias of: RID_Diagrams_To_TableRelationshipsDiagram
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Table Relationships Diagram

Parent Class: Diagrams


Dictionary

Represents the collection of Dictionary Items in the model.

This class has a default role: RID_Dictionary_To_DictionaryItem

Attributes

Count Dict Items
Long Name
Type
Last Author
Last Change Date

Associations

Model
Action State
Actor
Association
Corp Association
Local Association
Attribute
Basic Type
Business Actor
Business Event
Parentless Business Process
Business Process
Business Transition
Class
User Class
Unscoped User Class
External Business Class
Unscoped External User Class
Unscoped External UML Interface
External User Class
External UML Interface
Unscoped External Business Class
External Class
Corporate View
Unscoped Business Class
Unscoped UML Interface
Business Class
UML Interface
Exception
Unscoped Exception
External Exception
Unscoped External Exception
Unscoped External Class
Unscoped Class
Local Class
Column
Parallel/Iteration
Complex Process
Database
Dependency
Dictionary Item
Exclusive Arc
Qualifier
Role
Ternary Role
Generalization
Specialization
Operation
Parameter
Enumeration Literal
Typedef
Unscoped Item
Category
Synchronization Bar
OCD Instance
Inheritance
Realization
Package
Process Break
Event
Increment
Use Case
Unscoped Typedef
State
Transition
Ternary Association
User Stereotype List
User Stereotype
Interaction
Requirement
SCMComponent
Join Column
Unused Table
Index
Relationship
Table
Published Component
Reused Component
External Reference
Alias
Array
Enumeration
Sequence
File Reference


Dictionary.Count Dict Items

Dictionary

Attribute: Count Dict Items

Count of the number of Dictionary Items.

Read only
32 bit signed integer

Parent class: Dictionary


Dictionary.Long Name

Dictionary

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Dictionary


Dictionary.Type

Dictionary

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Dictionary


Dictionary.Last Author

Dictionary

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Dictionary


Dictionary.Last Change Date

Dictionary

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Dictionary


Dictionary.Model

Dictionary

Association: Model

Description:
Read only
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Dictionary
Inverse roles: Model


Dictionary.Action State

Dictionary

Association: Action State

Description:
Read/Write
This role can be used to create an object of Class: CID_ActionState
This role connects to 0 or more objects of classes: Action State
This role propagates delete

Parent Class: Dictionary
Inverse roles: ActionState


Dictionary.Actor

Dictionary

Association: Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_Actor
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Actor
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Actor


Dictionary.Association

Dictionary

Association: Association

Description:
Read/Write
This role can be used to create an object of Class: CID_Association
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Association
This role propagates delete

Parent Class: Dictionary
Inverse roles: Association


Dictionary.Corp Association

Dictionary

Association: Corp Association

Description:
Read/Write
This role can be used to create an object of Class: CID_Association
This role is derived
This role connects to 0 or more objects of classes: Association
This role propagates delete

Parent Class: Dictionary


Dictionary.Local Association

Dictionary

Association: Local Association

Description:
Read/Write
This role can be used to create an object of Class: CID_Association
This role is derived
This role connects to 0 or more objects of classes: Association
This role propagates delete

Parent Class: Dictionary


Dictionary.Attribute

Dictionary

Association: Attribute

Description:
Read/Write
This role can be used to create an object of Class: CID_Attribute
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Attribute
This role propagates delete

Parent Class: Dictionary
Inverse roles: Attribute


Dictionary.Basic Type

Dictionary

Association: Basic Type

Description:
Read/Write
This role can be used to create an object of Class: CID_BasicType
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Basic Type
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: BasicType


Dictionary.Business Actor

Dictionary

Association: Business Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessActor
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Actor
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: BusinessActor


Dictionary.Business Event

Dictionary

Association: Business Event

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessEvent
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Event
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: BusinessEvent


Dictionary.Parentless Business Process

Dictionary

Association: Parentless Business Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Dictionary
Inverse roles: BusinessProcess


Dictionary.Business Process

Dictionary

Association: Business Process

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessProcess
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: BusinessProcess


Dictionary.Business Transition

Dictionary

Association: Business Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Dictionary
Inverse roles: BusinessTransition


Dictionary.Class

Dictionary

Association: Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary
Inverse roles: Class


Dictionary.User Class

Dictionary

Association: User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Unscoped User Class

Dictionary

Association: Unscoped User Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.External Business Class

Dictionary

Association: External Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Unscoped External User Class

Dictionary

Association: Unscoped External User Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Unscoped External UML Interface

Dictionary

Association: Unscoped External UML Interface

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.External User Class

Dictionary

Association: External User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.External UML Interface

Dictionary

Association: External UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Unscoped External Business Class

Dictionary

Association: Unscoped External Business Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.External Class

Dictionary

Association: External Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Corporate View

Dictionary

Association: Corporate View

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is an alias of: RID_Dictionary_To_ExternalClass
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Unscoped Business Class

Dictionary

Association: Unscoped Business Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Unscoped UML Interface

Dictionary

Association: Unscoped UML Interface

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Business Class

Dictionary

Association: Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.UML Interface

Dictionary

Association: UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Exception

Dictionary

Association: Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Unscoped Exception

Dictionary

Association: Unscoped Exception

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.External Exception

Dictionary

Association: External Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Unscoped External Exception

Dictionary

Association: Unscoped External Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Unscoped External Class

Dictionary

Association: Unscoped External Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Unscoped Class

Dictionary

Association: Unscoped Class

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Dictionary


Dictionary.Local Class

Dictionary

Association: Local Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role connects to 0 or more objects of classes: Class
This role propagates delete

Parent Class: Dictionary


Dictionary.Column

Dictionary

Association: Column

Description:
Read/Write
This role can be used to create an object of Class: CID_Column
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Column

Parent Class: Dictionary
Inverse roles: Column


Dictionary.Parallel/Iteration

Dictionary

Association: Parallel/Iteration

Description:
Read/Write
This role is an alias of: RID_Dictionary_To_ComplexProcess
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named

Parent Class: Dictionary


Dictionary.Complex Process

Dictionary

Association: Complex Process

Description:
Read/Write
This role can be used to create an object of Class: CID_ComplexProcess
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: ComplexProcess


Dictionary.Database

Dictionary

Association: Database

Description:
Read/Write
This role can be used to create an object of Class: CID_Database
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Database
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Database


Dictionary.Dependency

Dictionary

Association: Dependency

Description:
Read/Write
This role can be used to create an object of Class: CID_Dependency
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Dependency
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Dependency


Dictionary.Dictionary Item

Dictionary

Association: Dictionary Item

Description:
Read/Write
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Dictionary


Dictionary.Exclusive Arc

Dictionary

Association: Exclusive Arc

Description:
Read/Write
This role can be used to create an object of Class: CID_ExclusiveArc
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Exclusive Arc
This role propagates delete

Parent Class: Dictionary
Inverse roles: ExclusiveArc


Dictionary.Qualifier

Dictionary

Association: Qualifier

Description:
Read/Write
This role can be used to create an object of Class: CID_Qualifier
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Qualifier
This role propagates delete

Parent Class: Dictionary
Inverse roles: Qualifier


Dictionary.Role

Dictionary

Association: Role

Description:
Read/Write
This role can be used to create an object of Class: CID_Role
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Role

Parent Class: Dictionary
Inverse roles: Role


Dictionary.Ternary Role

Dictionary

Association: Ternary Role

Description:
Read/Write
This role can be used to create an object of Class: CID_TernaryRole
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Ternary Role
This role propagates delete

Parent Class: Dictionary
Inverse roles: TernaryRole


Dictionary.Generalization

Dictionary

Association: Generalization

Description:
Read/Write
This role can be used to create an object of Class: CID_Generalization
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Generalization
This role propagates delete

Parent Class: Dictionary
Inverse roles: Generalization


Dictionary.Specialization

Dictionary

Association: Specialization

Description:
Read/Write
This role can be used to create an object of Class: CID_Specialization
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Specialization
This role propagates delete

Parent Class: Dictionary
Inverse roles: Specialization


Dictionary.Operation

Dictionary

Association: Operation

Description:
Read/Write
This role can be used to create an object of Class: CID_Operation
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Operation
This role propagates delete

Parent Class: Dictionary
Inverse roles: Operation


Dictionary.Parameter

Dictionary

Association: Parameter

Description:
Read/Write
This role can be used to create an object of Class: CID_Parameter
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Parameter

Parent Class: Dictionary
Inverse roles: Parameter


Dictionary.Enumeration Literal

Dictionary

Association: Enumeration Literal

Description:
Read/Write
This role can be used to create an object of Class: CID_EnumerationLiteral
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Enumeration Literal

Parent Class: Dictionary
Inverse roles: EnumerationLiteral


Dictionary.Typedef

Dictionary

Association: Typedef

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Typedef
This role propagates delete

Parent Class: Dictionary
Inverse roles: Typedef


Dictionary.Unscoped Item

Dictionary

Association: Unscoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Dictionary


Dictionary.Category

Dictionary

Association: Category

Description:
Read/Write
This role can be used to create an object of Class: CID_Package
This role is an alias of: RID_Dictionary_To_Package
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Package

Parent Class: Dictionary


Dictionary.Synchronization Bar

Dictionary

Association: Synchronization Bar

Description:
Read/Write
This role can be used to create an object of Class: CID_SynchronizationBar
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Synchronization Bar
This role propagates delete

Parent Class: Dictionary
Inverse roles: SynchronizationBar


Dictionary.OCD Instance

Dictionary

Association: OCD Instance

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Instance

Parent Class: Dictionary


Dictionary.Inheritance

Dictionary

Association: Inheritance

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Specialization

Parent Class: Dictionary


Dictionary.Realization

Dictionary

Association: Realization

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Specialization

Parent Class: Dictionary


Dictionary.Package

Dictionary

Association: Package

Description:
Read/Write
This role can be used to create an object of Class: CID_Package
This role connects to 0 or more objects of classes: Package
This role propagates delete

Parent Class: Dictionary
Inverse roles: Package


Dictionary.Process Break

Dictionary

Association: Process Break

Description:
Read/Write
This role can be used to create an object of Class: CID_ProcessBreak
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Process Break
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: ProcessBreak


Dictionary.Event

Dictionary

Association: Event

Description:
Read/Write
This role can be used to create an object of Class: CID_Event
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Event
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Event


Dictionary.Increment

Dictionary

Association: Increment

Description:
Read/Write
This role can be used to create an object of Class: CID_Increment
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Increment


Dictionary.Use Case

Dictionary

Association: Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: UseCase


Dictionary.Unscoped Typedef

Dictionary

Association: Unscoped Typedef

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Typedef

Parent Class: Dictionary


Dictionary.State

Dictionary

Association: State

Description:
Read/Write
This role can be used to create an object of Class: CID_State
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: State
This role propagates delete

Parent Class: Dictionary
Inverse roles: State


Dictionary.Transition

Dictionary

Association: Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_Transition
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Transition
This role propagates delete

Parent Class: Dictionary
Inverse roles: Transition


Dictionary.Ternary Association

Dictionary

Association: Ternary Association

Description:
Read/Write
This role can be used to create an object of Class: CID_TernaryAssociation
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Ternary Association
This role propagates delete

Parent Class: Dictionary
Inverse roles: TernaryAssociation


Dictionary.User Stereotype List

Dictionary

Association: User Stereotype List

Description:
Read/Write
This role can NOT be removed
This role can be used to create an object of Class: CID_UserStereotypeList
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: User Stereotype List
All objects connected in this role are uniquely named

Parent Class: Dictionary
Inverse roles: UserStereotypeList


Dictionary.User Stereotype

Dictionary

Association: User Stereotype

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: User Stereotype

Parent Class: Dictionary


Dictionary.Interaction

Dictionary

Association: Interaction

Description:
Read/Write
This role can be used to create an object of Class: CID_Interaction
This role connects to 0 or more objects of classes: Interaction

Parent Class: Dictionary
Inverse roles: Interaction


Dictionary.Requirement

Dictionary

Association: Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement
This role propagates delete

Parent Class: Dictionary
Inverse roles: Requirement


Dictionary.SCMComponent

Dictionary

Association: SCMComponent

Description:
Read/Write
This role can be used to create an object of Class: CID_SCMComponent
This role connects to 0 or more objects of classes: SCMComponent
This role propagates delete

Parent Class: Dictionary
Inverse roles: SCMComponent


Dictionary.Join Column

Dictionary

Association: Join Column

Description:
Read/Write
This role can be used to create an object of Class: CID_JoinColumn
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Join Column
All objects connected in this role are uniquely named

Parent Class: Dictionary
Inverse roles: JoinColumn


Dictionary.Unused Table

Dictionary

Association: Unused Table

Description:
Read/Write
This role connects to 0 or more objects of classes: Table
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Table


Dictionary.Index

Dictionary

Association: Index

Description:
Read/Write
This role can be used to create an object of Class: CID_Index
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Index

Parent Class: Dictionary
Inverse roles: Index


Dictionary.Relationship

Dictionary

Association: Relationship

Description:
Read/Write
This role can be used to create an object of Class: CID_Relationship
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Relationship
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Relationship


Dictionary.Table

Dictionary

Association: Table

Description:
Read/Write
This role can be used to create an object of Class: CID_Table
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Table
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Dictionary
Inverse roles: Table


Dictionary.Published Component

Dictionary

Association: Published Component

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: SCMComponent

Parent Class: Dictionary


Dictionary.Reused Component

Dictionary

Association: Reused Component

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: SCMComponent

Parent Class: Dictionary


Dictionary.External Reference

Dictionary

Association: External Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_ExternalReference
This role connects to 0 or more objects of classes: External Reference
This role propagates delete

Parent Class: Dictionary
Inverse roles: ExternalReference


Dictionary.Alias

Dictionary

Association: Alias

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef

Parent Class: Dictionary


Dictionary.Array

Dictionary

Association: Array

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef

Parent Class: Dictionary


Dictionary.Enumeration

Dictionary

Association: Enumeration

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef

Parent Class: Dictionary


Dictionary.Sequence

Dictionary

Association: Sequence

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef

Parent Class: Dictionary


Dictionary.File Reference

Dictionary

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference
This role propagates delete

Parent Class: Dictionary
Inverse roles: FileReference


Enumeration Literal

A single named constant used in an Enumeration typedef.

Attributes

Constraints
Description
Value
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Enumeration
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Enumeration Literal.Constraints

Enumeration Literal

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Enumeration Literal


Enumeration Literal.Description

Enumeration Literal

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Enumeration Literal


Enumeration Literal.Value

Enumeration Literal

Attribute: Value

Optional value assigned to the enumeration literal

Read/Write
String of up to 16385 characters

Parent class: Enumeration Literal


Enumeration Literal.Name

Enumeration Literal

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.Full Name

Enumeration Literal

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.Full Scoped Name

Enumeration Literal

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.Scoped Name

Enumeration Literal

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.Comp Pointer

Enumeration Literal

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Enumeration Literal


Enumeration Literal.External Link Last Updated

Enumeration Literal

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Enumeration Literal


Enumeration Literal.Is External

Enumeration Literal

Attribute: Is External

Read/Write
boolean

Parent class: Enumeration Literal


Enumeration Literal.Long Name

Enumeration Literal

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.UML Short Dotted Name

Enumeration Literal

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Enumeration Literal


Enumeration Literal.Type

Enumeration Literal

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Enumeration Literal


Enumeration Literal.Last Author

Enumeration Literal

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Enumeration Literal


Enumeration Literal.Last Change Date

Enumeration Literal

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Enumeration Literal


Enumeration Literal.Stereotype

Enumeration Literal

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Enumeration Literal


EnumerationLiteral.Enumeration

Enumeration Literal

Association: Enumeration

Description:
Read/Write
This role connects to 1 object of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Enumeration Literal
Inverse roles: Typedef


EnumerationLiteral.External Reference

Enumeration Literal

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Enumeration Literal
Inverse roles: ExternalReference


EnumerationLiteral.Decomposition Diagram

Enumeration Literal

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Enumeration Literal
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


EnumerationLiteral.Using Diagram

Enumeration Literal

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Enumeration Literal


EnumerationLiteral.Child Diagram

Enumeration Literal

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Enumeration Literal
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


EnumerationLiteral.External Dictionary Item

Enumeration Literal

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Enumeration Literal


EnumerationLiteral.The External Reference

Enumeration Literal

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Enumeration Literal
Inverse roles: ExternalReference


EnumerationLiteral.File Reference

Enumeration Literal

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Enumeration Literal
Inverse roles: FileReference


EnumerationLiteral.Target Requirement

Enumeration Literal

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Enumeration Literal
Inverse roles: Requirement


EnumerationLiteral.Source Requirement

Enumeration Literal

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Enumeration Literal
Inverse roles: Requirement


Event

Something that happens instantaneously at a point in time.

All objects of this class are name unique within a Model

Attributes

Formatted Uml Signature
Signature
Constraints
Description
Uml Signature
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Parameter
External Reference
Object Sequence Diagram
Object Collaboration Diagram
OCD Parent
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Event.Formatted Uml Signature

Event

Attribute: Formatted Uml Signature

A space separated string containing Event Name and Parameters (comma separated). It is formatted to display each parameter on a separate line.

Read only
String of up to 65536 characters

Parent class: Event


Event.Signature

Event

Attribute: Signature

A space separated string containing Event Name and Parameters (comma separated).

Read/Write
String of up to 65536 characters

Parent class: Event


Event.Constraints

Event

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Event


Event.Description

Event

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Event


Event.Uml Signature

Event

Attribute: Uml Signature

A space separated string containing Event Name and Parameters (comma separated). It is formatted to display each parameter on a separate line.

Read only
String of up to 65536 characters

Parent class: Event


Event.Full Name

Event

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Event


Event.Full Scoped Name

Event

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Event


Event.Local Full Scoped Name

Event

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Event


Event.Local Scoped Name

Event

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Event


Event.Scoped Name

Event

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Event


Event.UML Short Dotted Name

Event

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Event


Event.Name

Event

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Event


Event.Comp Pointer

Event

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Event


Event.External Link Last Updated

Event

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Event


Event.Is External

Event

Attribute: Is External

Read/Write
boolean

Parent class: Event


Event.Long Name

Event

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Event


Event.Type

Event

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Event


Event.Last Author

Event

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Event


Event.Last Change Date

Event

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Event


Event.Stereotype

Event

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Event


Event.Parameter

Event

Association: Parameter

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Parameter
This role connects to 0 or more objects of classes: Parameter
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Event
Inverse roles: Parameter


Event.External Reference

Event

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Event
Inverse roles: ExternalReference


Event.Object Sequence Diagram

Event

Association: Object Sequence Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectSequenceDiagram
This role connects to 0 or 1 object of classes: Object Sequence Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Event
Inverse roles: ObjectSequenceDiagram


Event.Object Collaboration Diagram

Event

Association: Object Collaboration Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectCollaborationDiagram
This role connects to 0 or more objects of classes: Object Collaboration Diagram
This role propagates delete

Parent Class: Event
Inverse roles: ObjectCollaborationDiagram


Event.OCD Parent

Event

Association: OCD Parent

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Parent

Parent Class: Event
Inverse roles: OCDParent


Event.Category

Event

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Event
Inverse roles: Package


Event.Package

Event

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Event
Inverse roles: Package


Event.Dependee Item

Event

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Event.Dependent Item

Event

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Event.Scoping Item

Event

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Event
Inverse roles: Class, Package, Model, Requirement


Event.Decomposition Diagram

Event

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Event.Using Diagram

Event

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event


Event.Child Diagram

Event

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Event.External Dictionary Item

Event

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Event


Event.The External Reference

Event

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Event
Inverse roles: ExternalReference


Event.File Reference

Event

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Event
Inverse roles: FileReference


Event.Target Requirement

Event

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Event
Inverse roles: Requirement


Event.Source Requirement

Event

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Event
Inverse roles: Requirement


Event Action Block

This represents an Event Action Block used in the State Model.

Attributes

Text
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Action State
State
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Event Action Block.Text

Event Action Block

Attribute: Text

The text of the event action block including any special characters to denote embedded dictionary items.

Read/Write
String of up to 65536 characters

Parent class: Event Action Block


Event Action Block.Name

Event Action Block

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.Full Name

Event Action Block

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.Full Scoped Name

Event Action Block

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.Scoped Name

Event Action Block

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.Comp Pointer

Event Action Block

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Event Action Block


Event Action Block.External Link Last Updated

Event Action Block

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Event Action Block


Event Action Block.Is External

Event Action Block

Attribute: Is External

Read/Write
boolean

Parent class: Event Action Block


Event Action Block.Long Name

Event Action Block

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.UML Short Dotted Name

Event Action Block

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Event Action Block


Event Action Block.Type

Event Action Block

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Event Action Block


Event Action Block.Last Author

Event Action Block

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Event Action Block


Event Action Block.Last Change Date

Event Action Block

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Event Action Block


Event Action Block.Stereotype

Event Action Block

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Event Action Block


EventActionBlock.Action State

Event Action Block

Association: Action State

Description:
Read/Write
This role connects to 0 or 1 object of classes: Action State
All objects connected in this role are uniquely named

Parent Class: Event Action Block
Inverse roles: ActionState


EventActionBlock.State

Event Action Block

Association: State

Description:
Read/Write
This role connects to 0 or 1 object of classes: State
All objects connected in this role are uniquely named

Parent Class: Event Action Block
Inverse roles: State


EventActionBlock.External Reference

Event Action Block

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Event Action Block
Inverse roles: ExternalReference


EventActionBlock.Decomposition Diagram

Event Action Block

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event Action Block
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


EventActionBlock.Using Diagram

Event Action Block

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event Action Block


EventActionBlock.Child Diagram

Event Action Block

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Event Action Block
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


EventActionBlock.External Dictionary Item

Event Action Block

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Event Action Block


EventActionBlock.The External Reference

Event Action Block

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Event Action Block
Inverse roles: ExternalReference


EventActionBlock.File Reference

Event Action Block

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Event Action Block
Inverse roles: FileReference


EventActionBlock.Target Requirement

Event Action Block

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Event Action Block
Inverse roles: Requirement


EventActionBlock.Source Requirement

Event Action Block

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Event Action Block
Inverse roles: Requirement


Exclusive Arc

This represents the exclusivity of transitions within the Business Process Model.

Attributes

Description
Constraints
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Bpm Transition
External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Exclusive Arc.Description

Exclusive Arc

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Exclusive Arc


Exclusive Arc.Constraints

Exclusive Arc

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Exclusive Arc


Exclusive Arc.Full Name

Exclusive Arc

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Exclusive Arc


Exclusive Arc.Full Scoped Name

Exclusive Arc

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Exclusive Arc


Exclusive Arc.Scoped Name

Exclusive Arc

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Exclusive Arc


Exclusive Arc.Comp Pointer

Exclusive Arc

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Exclusive Arc


Exclusive Arc.External Link Last Updated

Exclusive Arc

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Exclusive Arc


Exclusive Arc.Is External

Exclusive Arc

Attribute: Is External

Read/Write
boolean

Parent class: Exclusive Arc


Exclusive Arc.Long Name

Exclusive Arc

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Exclusive Arc


Exclusive Arc.UML Short Dotted Name

Exclusive Arc

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Exclusive Arc


Exclusive Arc.Type

Exclusive Arc

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Exclusive Arc


Exclusive Arc.Last Author

Exclusive Arc

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Exclusive Arc


Exclusive Arc.Last Change Date

Exclusive Arc

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Exclusive Arc


Exclusive Arc.Stereotype

Exclusive Arc

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Exclusive Arc


ExclusiveArc.Bpm Transition

Exclusive Arc

Association: Bpm Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition

Parent Class: Exclusive Arc
Inverse roles: BusinessTransition


ExclusiveArc.External Reference

Exclusive Arc

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Exclusive Arc
Inverse roles: ExternalReference


ExclusiveArc.Decomposition Diagram

Exclusive Arc

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Exclusive Arc
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ExclusiveArc.Using Diagram

Exclusive Arc

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Exclusive Arc


ExclusiveArc.Child Diagram

Exclusive Arc

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Exclusive Arc
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ExclusiveArc.External Dictionary Item

Exclusive Arc

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Exclusive Arc


ExclusiveArc.The External Reference

Exclusive Arc

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Exclusive Arc
Inverse roles: ExternalReference


ExclusiveArc.File Reference

Exclusive Arc

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Exclusive Arc
Inverse roles: FileReference


ExclusiveArc.Target Requirement

Exclusive Arc

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Exclusive Arc
Inverse roles: Requirement


ExclusiveArc.Source Requirement

Exclusive Arc

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Exclusive Arc
Inverse roles: Requirement


External Reference

An object representing a source of external model items

Attributes

Long Name
Type
Last Author
Last Change Date

Associations

Action State
Actor
Association
Attribute
Basic Type
Business Actor
Business Event
Business Process
Business Transition
Class
Column
Column Sort
Complex Process
Dependency
Dictionary
Dictionary Item
Enumeration Literal
Event
Event Action Block
Exclusive Arc
Join Column
Index
Synchronization Bar
Qualifier
State
Interaction
Specialization
Transition
Generalization
Ternary Role
Ternary Association
Parameter
Role
Operation
Requirement
Use Case
Increment
Typedef
Package
Process Break
Table
Relationship
User Stereotype


External Reference.Long Name

External Reference

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: External Reference


External Reference.Type

External Reference

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: External Reference


External Reference.Last Author

External Reference

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: External Reference


External Reference.Last Change Date

External Reference

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: External Reference


ExternalReference.Action State

External Reference

Association: Action State

Description:
Read/Write
This role connects to 0 or more objects of classes: Action State

Parent Class: External Reference
Inverse roles: ActionState


ExternalReference.Actor

External Reference

Association: Actor

Description:
Read/Write
This role connects to 0 or more objects of classes: Actor
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Actor


ExternalReference.Association

External Reference

Association: Association

Description:
Read/Write
This role connects to 0 or more objects of classes: Association

Parent Class: External Reference
Inverse roles: Association


ExternalReference.Attribute

External Reference

Association: Attribute

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Attribute

Parent Class: External Reference
Inverse roles: Attribute


ExternalReference.Basic Type

External Reference

Association: Basic Type

Description:
Read/Write
This role connects to 0 or more objects of classes: Basic Type
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: BasicType


ExternalReference.Business Actor

External Reference

Association: Business Actor

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Actor
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: BusinessActor


ExternalReference.Business Event

External Reference

Association: Business Event

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Event
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: BusinessEvent


ExternalReference.Business Process

External Reference

Association: Business Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: BusinessProcess


ExternalReference.Business Transition

External Reference

Association: Business Transition

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Transition

Parent Class: External Reference
Inverse roles: BusinessTransition


ExternalReference.Class

External Reference

Association: Class

Description:
Read/Write
This role connects to 0 or more objects of classes: Class

Parent Class: External Reference
Inverse roles: Class


ExternalReference.Column

External Reference

Association: Column

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Column

Parent Class: External Reference
Inverse roles: Column


ExternalReference.Column Sort

External Reference

Association: Column Sort

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Column Sort

Parent Class: External Reference
Inverse roles: ColumnSort


ExternalReference.Complex Process

External Reference

Association: Complex Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: ComplexProcess


ExternalReference.Dependency

External Reference

Association: Dependency

Description:
Read/Write
This role connects to 0 or more objects of classes: Dependency
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Dependency


ExternalReference.Dictionary

External Reference

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Dictionary


ExternalReference.Dictionary Item

External Reference

Association: Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: External Reference
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ExternalReference.Enumeration Literal

External Reference

Association: Enumeration Literal

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Enumeration Literal

Parent Class: External Reference
Inverse roles: EnumerationLiteral


ExternalReference.Event

External Reference

Association: Event

Description:
Read/Write
This role connects to 0 or more objects of classes: Event
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Event


ExternalReference.Event Action Block

External Reference

Association: Event Action Block

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Event Action Block

Parent Class: External Reference
Inverse roles: EventActionBlock


ExternalReference.Exclusive Arc

External Reference

Association: Exclusive Arc

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Exclusive Arc

Parent Class: External Reference
Inverse roles: ExclusiveArc


ExternalReference.Join Column

External Reference

Association: Join Column

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Join Column
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: JoinColumn


ExternalReference.Index

External Reference

Association: Index

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Index

Parent Class: External Reference
Inverse roles: Index


ExternalReference.Synchronization Bar

External Reference

Association: Synchronization Bar

Description:
Read/Write
This role connects to 0 or more objects of classes: Synchronization Bar

Parent Class: External Reference
Inverse roles: SynchronizationBar


ExternalReference.Qualifier

External Reference

Association: Qualifier

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Qualifier

Parent Class: External Reference
Inverse roles: Qualifier


ExternalReference.State

External Reference

Association: State

Description:
Read/Write
This role connects to 0 or more objects of classes: State

Parent Class: External Reference
Inverse roles: State


ExternalReference.Interaction

External Reference

Association: Interaction

Description:
Read/Write
This role connects to 0 or more objects of classes: Interaction

Parent Class: External Reference
Inverse roles: Interaction


ExternalReference.Specialization

External Reference

Association: Specialization

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Specialization

Parent Class: External Reference
Inverse roles: Specialization


ExternalReference.Transition

External Reference

Association: Transition

Description:
Read/Write
This role connects to 0 or more objects of classes: Transition

Parent Class: External Reference
Inverse roles: Transition


ExternalReference.Generalization

External Reference

Association: Generalization

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Generalization

Parent Class: External Reference
Inverse roles: Generalization


ExternalReference.Ternary Role

External Reference

Association: Ternary Role

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Ternary Role

Parent Class: External Reference
Inverse roles: TernaryRole


ExternalReference.Ternary Association

External Reference

Association: Ternary Association

Description:
Read/Write
This role connects to 0 or more objects of classes: Ternary Association

Parent Class: External Reference
Inverse roles: TernaryAssociation


ExternalReference.Parameter

External Reference

Association: Parameter

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Parameter

Parent Class: External Reference
Inverse roles: Parameter


ExternalReference.Role

External Reference

Association: Role

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Role

Parent Class: External Reference
Inverse roles: Role


ExternalReference.Operation

External Reference

Association: Operation

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Operation

Parent Class: External Reference
Inverse roles: Operation


ExternalReference.Requirement

External Reference

Association: Requirement

Description:
Read/Write
This role connects to 0 or more objects of classes: Requirement

Parent Class: External Reference
Inverse roles: Requirement


ExternalReference.Use Case

External Reference

Association: Use Case

Description:
Read/Write
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: UseCase


ExternalReference.Increment

External Reference

Association: Increment

Description:
Read/Write
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Increment


ExternalReference.Typedef

External Reference

Association: Typedef

Description:
Read/Write
This role connects to 0 or more objects of classes: Typedef

Parent Class: External Reference
Inverse roles: Typedef


ExternalReference.Package

External Reference

Association: Package

Description:
Read/Write
This role connects to 0 or more objects of classes: Package

Parent Class: External Reference
Inverse roles: Package


ExternalReference.Process Break

External Reference

Association: Process Break

Description:
Read/Write
This role connects to 0 or more objects of classes: Process Break
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: ProcessBreak


ExternalReference.Table

External Reference

Association: Table

Description:
Read/Write
This role connects to 0 or more objects of classes: Table
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Table


ExternalReference.Relationship

External Reference

Association: Relationship

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship
All objects connected in this role are uniquely named

Parent Class: External Reference
Inverse roles: Relationship


ExternalReference.User Stereotype

External Reference

Association: User Stereotype

Description:
Read/Write
This role connects to 0 or more objects of classes: User Stereotype

Parent Class: External Reference
Inverse roles: UserStereotype


File Reference

Attributes

Description
FileReference
Bookmark
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Dictionary
Requirement Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


File Reference.Description

File Reference

Attribute: Description

String containing the description of the file reference.

Read/Write
String of up to 16385 characters

Parent class: File Reference


File Reference.FileReference

File Reference

Attribute: FileReference

A string containing the file reference.

Read/Write
String of up to 1024 characters

Parent class: File Reference


File Reference.Bookmark

File Reference

Attribute: Bookmark

A string specifying the location within the file.

Read/Write
String of up to 1024 characters

Parent class: File Reference


File Reference.Name

File Reference

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: File Reference


File Reference.Full Name

File Reference

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: File Reference


File Reference.Full Scoped Name

File Reference

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: File Reference


File Reference.Scoped Name

File Reference

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: File Reference


File Reference.Comp Pointer

File Reference

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: File Reference


File Reference.External Link Last Updated

File Reference

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: File Reference


File Reference.Is External

File Reference

Attribute: Is External

Read/Write
boolean

Parent class: File Reference


File Reference.Long Name

File Reference

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: File Reference


File Reference.UML Short Dotted Name

File Reference

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: File Reference


File Reference.Type

File Reference

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: File Reference


File Reference.Last Author

File Reference

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: File Reference


File Reference.Last Change Date

File Reference

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: File Reference


File Reference.Stereotype

File Reference

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: File Reference


FileReference.Dictionary

File Reference

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: File Reference
Inverse roles: Dictionary


FileReference.Requirement Item

File Reference

Association: Requirement Item

Description:
Read/Write
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: File Reference
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


FileReference.Decomposition Diagram

File Reference

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: File Reference
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


FileReference.Using Diagram

File Reference

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: File Reference


FileReference.Child Diagram

File Reference

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: File Reference
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


FileReference.External Dictionary Item

File Reference

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: File Reference


FileReference.The External Reference

File Reference

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: File Reference
Inverse roles: ExternalReference


FileReference.File Reference

File Reference

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: File Reference
Inverse roles: FileReference


FileReference.Target Requirement

File Reference

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: File Reference
Inverse roles: Requirement


FileReference.Source Requirement

File Reference

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: File Reference
Inverse roles: Requirement


General Graphics Diagram

Represents a General Graphics Diagram.

Attributes

Default Node Style
Default Shape
Default Flow Style
Type
Page Ref
Default Start Shape
Default End Shape
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Container
General Flow
General Node
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


General Graphics Diagram.Default Node Style

General Graphics Diagram

Attribute: Default Node Style

Default drawing style to use

Read/Write
Enumeration, values: Solid, Dashed, None

Parent class: General Graphics Diagram


General Graphics Diagram.Default Shape

General Graphics Diagram

Attribute: Default Shape

The default node shape to use

Read/Write
Enumeration, values: Box, Soft Box, Circle, Ellipse, Parallel, Diamond

Parent class: General Graphics Diagram


General Graphics Diagram.Default Flow Style

General Graphics Diagram

Attribute: Default Flow Style

Default drawing style to use

Read/Write
Enumeration, values: Solid, Dashed

Parent class: General Graphics Diagram


General Graphics Diagram.Type

General Graphics Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Page Ref

General Graphics Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Default Start Shape

General Graphics Diagram

Attribute: Default Start Shape

The default shape to use at the end of a flow

Read/Write
Enumeration, values: None, Arrow, Large Arrow, Crows Foot, Circle, Filled Circle

Parent class: General Graphics Diagram


General Graphics Diagram.Default End Shape

General Graphics Diagram

Attribute: Default End Shape

The default shape to use at the end of a flow

Read/Write
Enumeration, values: None, Arrow, Large Arrow, Crows Foot, Circle, Filled Circle

Parent class: General Graphics Diagram


General Graphics Diagram.Filename

General Graphics Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Full Type

General Graphics Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Pathname

General Graphics Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Title

General Graphics Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Description

General Graphics Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Meta File

General Graphics Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Page Orientation

General Graphics Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: General Graphics Diagram


General Graphics Diagram.Page Count

General Graphics Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: General Graphics Diagram


General Graphics Diagram.Full Name

General Graphics Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Full Scoped Name

General Graphics Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Local Full Scoped Name

General Graphics Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Local Scoped Name

General Graphics Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Scoped Name

General Graphics Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.UML Short Dotted Name

General Graphics Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Long Name

General Graphics Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Last Author

General Graphics Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: General Graphics Diagram


General Graphics Diagram.Last Change Date

General Graphics Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: General Graphics Diagram


General Graphics Diagram.Stereotype

General Graphics Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: General Graphics Diagram


GeneralGraphicsDiagram.Container

General Graphics Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: General Graphics Diagram
Inverse roles: Model


GeneralGraphicsDiagram.General Flow

General Graphics Diagram

Association: General Flow

Description:
Read/Write
This role can be used to create an object of Class: CID_GeneralFlow
This role connects to 0 or more objects of classes: General Flow
This role propagates delete

Parent Class: General Graphics Diagram
Inverse roles: GeneralFlow


GeneralGraphicsDiagram.General Node

General Graphics Diagram

Association: General Node

Description:
Read/Write
This role can be used to create an object of Class: CID_GeneralNode
This role connects to 0 or more objects of classes: General Node
This role propagates delete

Parent Class: General Graphics Diagram
Inverse roles: GeneralNode


GeneralGraphicsDiagram.Decomposed Dictionary Item

General Graphics Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: General Graphics Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


GeneralGraphicsDiagram.Parent Dictionary Item

General Graphics Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: General Graphics Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


GeneralGraphicsDiagram.Category

General Graphics Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: General Graphics Diagram
Inverse roles: Package


GeneralGraphicsDiagram.Package

General Graphics Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: General Graphics Diagram
Inverse roles: Package


GeneralGraphicsDiagram.Dependee Item

General Graphics Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: General Graphics Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


GeneralGraphicsDiagram.Dependent Item

General Graphics Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: General Graphics Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


GeneralGraphicsDiagram.Scoping Item

General Graphics Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: General Graphics Diagram
Inverse roles: Class, Package, Model, Requirement


GeneralGraphicsDiagram.File Reference

General Graphics Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: General Graphics Diagram
Inverse roles: FileReference


GeneralGraphicsDiagram.Target Requirement

General Graphics Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: General Graphics Diagram
Inverse roles: Requirement


GeneralGraphicsDiagram.Source Requirement

General Graphics Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: General Graphics Diagram
Inverse roles: Requirement


Generalization

A relationship which indicates that characteristics of the start Class are part of the definition of the end Classes.

Attributes

Full Name
Full Scoped Name
Scoped Name
Constraints
Description
Name
Overlapping
Completeness
UML Short Dotted Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Class
External Reference
Specialization
Taxonomy
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Generalization.Full Name

Generalization

Attribute: Full Name

Full name for a Generalization, e.g. Gen1 [cat1.cat2.c3.]

Read only
String of up to 100 characters

Parent class: Generalization


Generalization.Full Scoped Name

Generalization

Attribute: Full Scoped Name

Full scoped name for a Generalization, e.g. cat1::cat2::c3.Gen1

Read only
String of up to 100 characters

Parent class: Generalization


Generalization.Scoped Name

Generalization

Attribute: Scoped Name

Scoped name for a Generalization, e.g. c3.Gen1

Read only
String of up to 100 characters

Parent class: Generalization


Generalization.Constraints

Generalization

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Generalization


Generalization.Description

Generalization

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Generalization


Generalization.Name

Generalization

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Generalization


Generalization.Overlapping

Generalization

Attribute: Overlapping

Indicates whether a class can be a sub-class of more than one of the sub-classes of the generalization (i.e. the sub-types of a super-type are not mutually exclusive e.g. vehicle power could be wind and engine).

Read/Write
boolean

Parent class: Generalization


Generalization.Completeness

Generalization

Attribute: Completeness

Indicates the completion state of the Generalization. If this value is set to Incomplete then the Generalization is incomplete meaning that there are still sub types and Specializations to be added to this Generalization.

Read/Write
Enumeration, values: Undefined, Incomplete, Complete

Parent class: Generalization


Generalization.UML Short Dotted Name

Generalization

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Generalization


Generalization.Comp Pointer

Generalization

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Generalization


Generalization.External Link Last Updated

Generalization

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Generalization


Generalization.Is External

Generalization

Attribute: Is External

Read/Write
boolean

Parent class: Generalization


Generalization.Long Name

Generalization

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Generalization


Generalization.Type

Generalization

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Generalization


Generalization.Last Author

Generalization

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Generalization


Generalization.Last Change Date

Generalization

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Generalization


Generalization.Stereotype

Generalization

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Generalization


Generalization.Class

Generalization

Association: Class

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Generalization


Generalization.External Reference

Generalization

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Generalization
Inverse roles: ExternalReference


Generalization.Specialization

Generalization

Association: Specialization

Description:
Read/Write
This role can be used to create an object of Class: CID_Specialization
This role connects to 0 or more objects of classes: Specialization
This role propagates delete

Parent Class: Generalization
Inverse roles: Specialization


Generalization.Taxonomy

Generalization

Association: Taxonomy

Description:
Read/Write
This role connects to 1 object of classes: Class, Actor, Use Case
All objects connected in this role are uniquely named

Parent Class: Generalization
Inverse roles: Class, Actor, UseCase


Generalization.Decomposition Diagram

Generalization

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Generalization
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Generalization.Using Diagram

Generalization

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Generalization


Generalization.Child Diagram

Generalization

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Generalization
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Generalization.External Dictionary Item

Generalization

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Generalization


Generalization.The External Reference

Generalization

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Generalization
Inverse roles: ExternalReference


Generalization.File Reference

Generalization

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Generalization
Inverse roles: FileReference


Generalization.Target Requirement

Generalization

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Generalization
Inverse roles: Requirement


Generalization.Source Requirement

Generalization

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Generalization
Inverse roles: Requirement


Increment

Container for the Use Cases indicating a proposed implementation order.

All objects of this class are name unique within a Model

Attributes

Description
Constraints
Expected Date Of Delivery
Actual Date Of Delivery
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Class
External Reference
Use Case
Targeted Requirement
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Increment.Description

Increment

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Increment


Increment.Constraints

Increment

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Increment


Increment.Expected Date Of Delivery

Increment

Attribute: Expected Date Of Delivery

The date which the increment is expected to be delivered (estimate).

Read/Write
String of up to 1024 characters

Parent class: Increment


Increment.Actual Date Of Delivery

Increment

Attribute: Actual Date Of Delivery

The date which the increment was actually delivered.

Read/Write
String of up to 1024 characters

Parent class: Increment


Increment.Full Name

Increment

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Increment


Increment.Full Scoped Name

Increment

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Increment


Increment.Local Full Scoped Name

Increment

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Increment


Increment.Local Scoped Name

Increment

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Increment


Increment.Scoped Name

Increment

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Increment


Increment.UML Short Dotted Name

Increment

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Increment


Increment.Name

Increment

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Increment


Increment.Comp Pointer

Increment

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Increment


Increment.External Link Last Updated

Increment

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Increment


Increment.Is External

Increment

Attribute: Is External

Read/Write
boolean

Parent class: Increment


Increment.Long Name

Increment

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Increment


Increment.Type

Increment

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Increment


Increment.Last Author

Increment

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Increment


Increment.Last Change Date

Increment

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Increment


Increment.Stereotype

Increment

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Increment


Increment.Class

Increment

Association: Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Increment
Inverse roles: Class


Increment.External Reference

Increment

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: ExternalReference


Increment.Use Case

Increment

Association: Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: UseCase


Increment.Targeted Requirement

Increment

Association: Targeted Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Increment
Inverse roles: Requirement


Increment.Category

Increment

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: Package


Increment.Package

Increment

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: Package


Increment.Dependee Item

Increment

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Increment
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Increment.Dependent Item

Increment

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Increment
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Increment.Scoping Item

Increment

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: Class, Package, Model, Requirement


Increment.Decomposition Diagram

Increment

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Increment
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Increment.Using Diagram

Increment

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Increment


Increment.Child Diagram

Increment

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Increment
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Increment.External Dictionary Item

Increment

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Increment


Increment.The External Reference

Increment

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Increment
Inverse roles: ExternalReference


Increment.File Reference

Increment

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Increment
Inverse roles: FileReference


Increment.Target Requirement

Increment

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Increment
Inverse roles: Requirement


Increment.Source Requirement

Increment

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Increment
Inverse roles: Requirement


Index

A column (or ordered set of columns) which are frequently used as an access mechanism.

Attributes

Full Name
Scoped Name
Full Scoped Name
Is Unique
Description
Constraints
Specific Report Details
Col Order
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Column
Column Sort
External Reference
Table
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Index.Full Name

Index

Attribute: Full Name

Full name for an Index, e.g. Index1 [t1.]

Read only
String of up to 100 characters

Parent class: Index


Index.Scoped Name

Index

Attribute: Scoped Name

Scoped name for an Index, e.g. t1.Index1

Read only
String of up to 100 characters

Parent class: Index


Index.Full Scoped Name

Index

Attribute: Full Scoped Name

Full scoped name for an Index, e.g. t1.Index1

Read only
String of up to 100 characters

Parent class: Index


Index.Is Unique

Index

Attribute: Is Unique

Indicates whether the index is unique or not (i.e. The index into the table will always identify one item e.g. postcode and house number will uniquely identify a house)

Read/Write
boolean

Parent class: Index


Index.Description

Index

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Index


Index.Constraints

Index

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Index


Index.Specific Report Details

Index

Attribute: Specific Report Details

String containing the report details body for the index. It contains details of the objects related to the index (e.g. columns etc.).

Read only
String of up to 16385 characters

Parent class: Index


Index.Col Order

Index

Attribute: Col Order

Carriage return + line feed separated ordered list of Column names prepended with "asc" or "dsc" to indicate ascending/descending column order.

Read/Write
String of up to 16385 characters

Parent class: Index


Index.UML Short Dotted Name

Index

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Index


Index.Name

Index

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Index


Index.Comp Pointer

Index

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Index


Index.External Link Last Updated

Index

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Index


Index.Is External

Index

Attribute: Is External

Read/Write
boolean

Parent class: Index


Index.Long Name

Index

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Index


Index.Type

Index

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Index


Index.Last Author

Index

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Index


Index.Last Change Date

Index

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Index


Index.Stereotype

Index

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Index


Index.Column

Index

Association: Column

Description:
Read/Write
This role can be specifically ordered
This role is derived
This role connects to 0 or more objects of classes: Column

Parent Class: Index
Inverse roles: Column


Index.Column Sort

Index

Association: Column Sort

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_ColumnSort
This role connects to 1 or more objects of classes: Column Sort
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Index
Inverse roles: ColumnSort


Index.External Reference

Index

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Index
Inverse roles: ExternalReference


Index.Table

Index

Association: Table

Description:
Read/Write
This role connects to 1 object of classes: Table
All objects connected in this role are uniquely named

Parent Class: Index
Inverse roles: Table


Index.Decomposition Diagram

Index

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Index
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Index.Using Diagram

Index

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Index


Index.Child Diagram

Index

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Index
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Index.External Dictionary Item

Index

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Index


Index.The External Reference

Index

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Index
Inverse roles: ExternalReference


Index.File Reference

Index

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Index
Inverse roles: FileReference


Index.Target Requirement

Index

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Index
Inverse roles: Requirement


Index.Source Requirement

Index

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Index
Inverse roles: Requirement


Interaction

Attributes

Navigation
End Multiplicity Text
Start Multiplicity Text
Description
Constraints
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Actor
Dictionary
External Reference
Use Case
UCD Interaction Flow
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Interaction.Navigation

Interaction

Attribute: Navigation

Indicates the direction the association can be navigated (e.g. start-to-end, bi-directional etc.).

Read/Write
Enumeration, values: start-end, end-start, bi-directional, none

Parent class: Interaction


Interaction.End Multiplicity Text

Interaction

Attribute: End Multiplicity Text

The multiplicity text for the end of the association.

Read/Write
String of up to 50 characters

Parent class: Interaction


Interaction.Start Multiplicity Text

Interaction

Attribute: Start Multiplicity Text

The multiplicity text for the start of the association.

Read/Write
String of up to 50 characters

Parent class: Interaction


Interaction.Description

Interaction

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Interaction


Interaction.Constraints

Interaction

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Interaction


Interaction.Name

Interaction

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Interaction


Interaction.Full Name

Interaction

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Interaction


Interaction.Full Scoped Name

Interaction

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Interaction


Interaction.Scoped Name

Interaction

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Interaction


Interaction.Comp Pointer

Interaction

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Interaction


Interaction.External Link Last Updated

Interaction

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Interaction


Interaction.Is External

Interaction

Attribute: Is External

Read/Write
boolean

Parent class: Interaction


Interaction.Long Name

Interaction

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Interaction


Interaction.UML Short Dotted Name

Interaction

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Interaction


Interaction.Type

Interaction

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Interaction


Interaction.Last Author

Interaction

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Interaction


Interaction.Last Change Date

Interaction

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Interaction


Interaction.Stereotype

Interaction

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Interaction


Interaction.Actor

Interaction

Association: Actor

Description:
Read/Write
This role connects to 1 object of classes: Actor
All objects connected in this role are uniquely named

Parent Class: Interaction
Inverse roles: Actor


Interaction.Dictionary

Interaction

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Interaction
Inverse roles: Dictionary


Interaction.External Reference

Interaction

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Interaction
Inverse roles: ExternalReference


Interaction.Use Case

Interaction

Association: Use Case

Description:
Read/Write
This role connects to 1 object of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Interaction
Inverse roles: UseCase


Interaction.UCD Interaction Flow

Interaction

Association: UCD Interaction Flow

Description:
Read/Write
This role connects to 0 or more objects of classes: UCD::Interaction Flow
This role propagates delete

Parent Class: Interaction
Inverse roles: UCDInteractionFlow


Interaction.Decomposition Diagram

Interaction

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Interaction
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Interaction.Using Diagram

Interaction

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Interaction


Interaction.Child Diagram

Interaction

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Interaction
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Interaction.External Dictionary Item

Interaction

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Interaction


Interaction.The External Reference

Interaction

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Interaction
Inverse roles: ExternalReference


Interaction.File Reference

Interaction

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Interaction
Inverse roles: FileReference


Interaction.Target Requirement

Interaction

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Interaction
Inverse roles: Requirement


Interaction.Source Requirement

Interaction

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Interaction
Inverse roles: Requirement


Join Column

Represents the implementation of a relationship. Replaces the PrimeColumn-ForeignColumn and Relationship-ForeignColumn associations

All objects of this class are name unique within a Model

Attributes

Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Relationship
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Join Column.Name

Join Column

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Join Column


Join Column.Full Name

Join Column

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Join Column


Join Column.Full Scoped Name

Join Column

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Join Column


Join Column.Scoped Name

Join Column

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Join Column


Join Column.Comp Pointer

Join Column

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Join Column


Join Column.External Link Last Updated

Join Column

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Join Column


Join Column.Is External

Join Column

Attribute: Is External

Read/Write
boolean

Parent class: Join Column


Join Column.Long Name

Join Column

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Join Column


Join Column.UML Short Dotted Name

Join Column

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Join Column


Join Column.Type

Join Column

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Join Column


Join Column.Last Author

Join Column

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Join Column


Join Column.Last Change Date

Join Column

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Join Column


Join Column.Stereotype

Join Column

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Join Column


JoinColumn.External Reference

Join Column

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Join Column
Inverse roles: ExternalReference


JoinColumn.Relationship

Join Column

Association: Relationship

Description:
Read/Write
This role connects to 1 object of classes: Relationship
All objects connected in this role are uniquely named

Parent Class: Join Column
Inverse roles: Relationship


JoinColumn.Decomposition Diagram

Join Column

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Join Column
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


JoinColumn.Using Diagram

Join Column

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Join Column


JoinColumn.Child Diagram

Join Column

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Join Column
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


JoinColumn.External Dictionary Item

Join Column

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Join Column


JoinColumn.The External Reference

Join Column

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Join Column
Inverse roles: ExternalReference


JoinColumn.File Reference

Join Column

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Join Column
Inverse roles: FileReference


JoinColumn.Target Requirement

Join Column

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Join Column
Inverse roles: Requirement


JoinColumn.Source Requirement

Join Column

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Join Column
Inverse roles: Requirement


Object Collaboration Diagram

Represents an Object Collaboration Diagram.

Attributes

Default View Instance Attribute Values
Page Ref
Type
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

OCD Actor
Container
OCD Link
OCD Node
OCD Parent
ParentOCD
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Object Collaboration Diagram.Default View Instance Attribute Values

Object Collaboration Diagram

Attribute: Default View Instance Attribute Values

Default setting for the ViewAttributeValues attribute for Instance symbols on this diagram.

Read/Write
boolean

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Page Ref

Object Collaboration Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Type

Object Collaboration Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Filename

Object Collaboration Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Full Type

Object Collaboration Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Pathname

Object Collaboration Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Title

Object Collaboration Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Description

Object Collaboration Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Meta File

Object Collaboration Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Page Orientation

Object Collaboration Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Page Count

Object Collaboration Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Full Name

Object Collaboration Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Full Scoped Name

Object Collaboration Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Local Full Scoped Name

Object Collaboration Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Local Scoped Name

Object Collaboration Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Scoped Name

Object Collaboration Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.UML Short Dotted Name

Object Collaboration Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Long Name

Object Collaboration Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Last Author

Object Collaboration Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Last Change Date

Object Collaboration Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Object Collaboration Diagram


Object Collaboration Diagram.Stereotype

Object Collaboration Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Object Collaboration Diagram


ObjectCollaborationDiagram.OCD Actor

Object Collaboration Diagram

Association: OCD Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_OCDActor
This role connects to 0 or more objects of classes: OCD::Actor
This role propagates delete

Parent Class: Object Collaboration Diagram
Inverse roles: OCDActor


ObjectCollaborationDiagram.Container

Object Collaboration Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Model


ObjectCollaborationDiagram.OCD Link

Object Collaboration Diagram

Association: OCD Link

Description:
Read/Write
This role can be used to create an object of Class: CID_OCDLink
This role connects to 0 or more objects of classes: OCD::Link
This role propagates delete

Parent Class: Object Collaboration Diagram
Inverse roles: OCDLink


ObjectCollaborationDiagram.OCD Node

Object Collaboration Diagram

Association: OCD Node

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Actor, OCD::Instance

Parent Class: Object Collaboration Diagram


ObjectCollaborationDiagram.OCD Parent

Object Collaboration Diagram

Association: OCD Parent

Description:
Read/Write
This role can be used to create an object of Class: CID_OCDParent
This role connects to 0 or 1 object of classes: OCD::Parent
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Object Collaboration Diagram
Inverse roles: OCDParent


ObjectCollaborationDiagram.ParentOCD

Object Collaboration Diagram

Association: ParentOCD

Description:
Read/Write
This role connects to 0 or 1 object of classes: Event, Use Case, Operation
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Event, UseCase, Operation


ObjectCollaborationDiagram.Decomposed Dictionary Item

Object Collaboration Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ObjectCollaborationDiagram.Parent Dictionary Item

Object Collaboration Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Object Collaboration Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ObjectCollaborationDiagram.Category

Object Collaboration Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Package


ObjectCollaborationDiagram.Package

Object Collaboration Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Package


ObjectCollaborationDiagram.Dependee Item

Object Collaboration Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Object Collaboration Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ObjectCollaborationDiagram.Dependent Item

Object Collaboration Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Object Collaboration Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ObjectCollaborationDiagram.Scoping Item

Object Collaboration Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Object Collaboration Diagram
Inverse roles: Class, Package, Model, Requirement


ObjectCollaborationDiagram.File Reference

Object Collaboration Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Object Collaboration Diagram
Inverse roles: FileReference


ObjectCollaborationDiagram.Target Requirement

Object Collaboration Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Object Collaboration Diagram
Inverse roles: Requirement


ObjectCollaborationDiagram.Source Requirement

Object Collaboration Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Object Collaboration Diagram
Inverse roles: Requirement


Object Sequence Diagram

Represents an Object Sequence Diagram.

Attributes

Page Ref
Type
View Construct Balancing
View Line Numbers
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Container
OSD Parent
ParentOSD
OSD Structured Description Heading
Root Statement
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Object Sequence Diagram.Page Ref

Object Sequence Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Type

Object Sequence Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.View Construct Balancing

Object Sequence Diagram

Attribute: View Construct Balancing

Indicates whether the construct balancing for the structured description is to be displayed when the OSD is drawn.

Read/Write
boolean

Parent class: Object Sequence Diagram


Object Sequence Diagram.View Line Numbers

Object Sequence Diagram

Attribute: View Line Numbers

Indicates whether line numbering for the structured description is to be displayed when the OSD is drawn.

Read/Write
boolean

Parent class: Object Sequence Diagram


Object Sequence Diagram.Filename

Object Sequence Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Full Type

Object Sequence Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Pathname

Object Sequence Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Title

Object Sequence Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Description

Object Sequence Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Meta File

Object Sequence Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Page Orientation

Object Sequence Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Object Sequence Diagram


Object Sequence Diagram.Page Count

Object Sequence Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Object Sequence Diagram


Object Sequence Diagram.Full Name

Object Sequence Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Full Scoped Name

Object Sequence Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Local Full Scoped Name

Object Sequence Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Local Scoped Name

Object Sequence Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Scoped Name

Object Sequence Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.UML Short Dotted Name

Object Sequence Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Long Name

Object Sequence Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Last Author

Object Sequence Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Object Sequence Diagram


Object Sequence Diagram.Last Change Date

Object Sequence Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Object Sequence Diagram


Object Sequence Diagram.Stereotype

Object Sequence Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Object Sequence Diagram


ObjectSequenceDiagram.Container

Object Sequence Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Model


ObjectSequenceDiagram.OSD Parent

Object Sequence Diagram

Association: OSD Parent

Description:
Read/Write
This role can be used to create an object of Class: CID_OSDParent
This role connects to 0 or 1 object of classes: OSD::Parent
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Object Sequence Diagram
Inverse roles: OSDParent


ObjectSequenceDiagram.ParentOSD

Object Sequence Diagram

Association: ParentOSD

Description:
Read/Write
This role connects to 0 or 1 object of classes: Event, Operation, Use Case
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Event, Operation, UseCase


ObjectSequenceDiagram.OSD Structured Description Heading

Object Sequence Diagram

Association: OSD Structured Description Heading

Description:
Read/Write
This role can be used to create an object of Class: CID_OSDStructuredDescriptionHeading
This role connects to 1 object of classes: OSD::Structured Description Heading
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Object Sequence Diagram
Inverse roles: OSDStructuredDescriptionHeading


ObjectSequenceDiagram.Root Statement

Object Sequence Diagram

Association: Root Statement

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OSD::Step

Parent Class: Object Sequence Diagram


ObjectSequenceDiagram.Decomposed Dictionary Item

Object Sequence Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ObjectSequenceDiagram.Parent Dictionary Item

Object Sequence Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Object Sequence Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ObjectSequenceDiagram.Category

Object Sequence Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Package


ObjectSequenceDiagram.Package

Object Sequence Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Package


ObjectSequenceDiagram.Dependee Item

Object Sequence Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Object Sequence Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ObjectSequenceDiagram.Dependent Item

Object Sequence Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Object Sequence Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ObjectSequenceDiagram.Scoping Item

Object Sequence Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Object Sequence Diagram
Inverse roles: Class, Package, Model, Requirement


ObjectSequenceDiagram.File Reference

Object Sequence Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Object Sequence Diagram
Inverse roles: FileReference


ObjectSequenceDiagram.Target Requirement

Object Sequence Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Object Sequence Diagram
Inverse roles: Requirement


ObjectSequenceDiagram.Source Requirement

Object Sequence Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Object Sequence Diagram
Inverse roles: Requirement


Operation

This represents a function/transformation that may be applied to objects of a class.

Attributes

Array Dimensions
Exception Order
Formatted Uml Signature
Full Name
Full Scoped Name
Has Interpreted Data Type
Param Order
Prototype
Return Type
Scoped Name
Short UmlSignature
Signature
Uml Signature
Access
Array Signature
Asynchronous
Binding
Constraints
Description
Immutable
Is Abstract
Is Array
Is Pointer
Is Static
Name
Post Conditions
Pre Conditions
Uninterpreted Data Type
UML Short Dotted Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Class
Exception
Return Type
External Reference
Parameter
Corporate Operation
Object Sequence Diagram
Object Collaboration Diagram
OCD Parent
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Activity Diagram


Operation.Array Dimensions

Operation

Attribute: Array Dimensions

Derived property returning the number of dimensions of an array

Read/Write
32 bit signed integer

Parent class: Operation


Operation.Exception Order

Operation

Attribute: Exception Order

Carriage return + line feed separated ordered list of Exception names.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Formatted Uml Signature

Operation

Attribute: Formatted Uml Signature

A space separated string containing Return Type, Operation Name and Parameters (comma separated). It is formatted to display each parameter on a separate line.

Read/Write
String of up to 65536 characters

Parent class: Operation


Operation.Full Name

Operation

Attribute: Full Name

Full name for an Operation, e.g. o1 [cat1.cat2.c3.]

Read only
String of up to 100 characters

Parent class: Operation


Operation.Full Scoped Name

Operation

Attribute: Full Scoped Name

Full scoped name for an Operation, e.g. cat1::cat2::c3.o1

Read only
String of up to 100 characters

Parent class: Operation


Operation.Has Interpreted Data Type

Operation

Attribute: Has Interpreted Data Type

Indicates if the Operation has an interpreted (Dictionary linked) return type.

Read only
boolean

Parent class: Operation


Operation.Param Order

Operation

Attribute: Param Order

Carriage return + line feed separated ordered list of Parameter names.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Prototype

Operation

Attribute: Prototype

A space separated string containing Return Type, Operation Name and Parameters prototypes (comma separated).

Read only
String of up to 65536 characters

Parent class: Operation


Operation.Return Type

Operation

Attribute: Return Type

A string containing the return data type. This is either the true data type which is the dotted name of the dictionary item connected via the data type dictionary link or the uninterpreted data type string.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Scoped Name

Operation

Attribute: Scoped Name

Scoped name for an Operation, e.g. c3.o1

Read only
String of up to 100 characters

Parent class: Operation


Operation.Short UmlSignature

Operation

Attribute: Short UmlSignature

A string giving the Operation signature in UML syntax. All data types are expressed with no scoping information.

Read only
String of up to 65536 characters

Parent class: Operation


Operation.Signature

Operation

Attribute: Signature

A space separated string containing Return Type, Operation Name and Parameters (comma separated).

Read/Write
String of up to 65536 characters

Parent class: Operation


Operation.Uml Signature

Operation

Attribute: Uml Signature

A string giving the Operation signature in UML syntax. All data types are expressed in dotted notation.

Read/Write
String of up to 65536 characters

Parent class: Operation


Operation.Access

Operation

Attribute: Access

The visibility/access of an operation of a class.

Read/Write
Enumeration, values: Public, Protected, Package Protected, Private

Parent class: Operation


Operation.Array Signature

Operation

Attribute: Array Signature

A comma separated string of array boundaries each array bound specified as lower bound , upperbound. e.g. the string "0,1,1,3" whould represent a 2D array of size [0..1,1..3]

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Asynchronous

Operation

Attribute: Asynchronous

Indicates a one-way operation (TRUE/FALSE)

Read/Write
boolean

Parent class: Operation


Operation.Binding

Operation

Attribute: Binding

Indicates the binding of the operation (static or dynamic).

Read/Write
Enumeration, values: At Compile, At Runtime

Parent class: Operation


Operation.Constraints

Operation

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Description

Operation

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Immutable

Operation

Attribute: Immutable

Indicate that the operation does not change the state of the class or any of its member variables.

Read/Write
boolean

Parent class: Operation


Operation.Is Abstract

Operation

Attribute: Is Abstract

Indicates whether the operation is abstract or not.

Read/Write
boolean

Parent class: Operation


Operation.Is Array

Operation

Attribute: Is Array

Indicates whether the operation return type is an array or not.

Read/Write
boolean

Parent class: Operation


Operation.Is Pointer

Operation

Attribute: Is Pointer

Indicates whether the operation return type is a pointer or not.

Read/Write
boolean

Parent class: Operation


Operation.Is Static

Operation

Attribute: Is Static

Indicates that the operation acts on static attributes only

Read/Write
boolean

Parent class: Operation


Operation.Name

Operation

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Operation


Operation.Post Conditions

Operation

Attribute: Post Conditions

String containing a specification of the state of the system following the execution of the operation.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Pre Conditions

Operation

Attribute: Pre Conditions

String containing a specification of the state of the system prior to execution of the operation.

Read/Write
String of up to 16385 characters

Parent class: Operation


Operation.Uninterpreted Data Type

Operation

Attribute: Uninterpreted Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Operation


Operation.UML Short Dotted Name

Operation

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Operation


Operation.Comp Pointer

Operation

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Operation


Operation.External Link Last Updated

Operation

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Operation


Operation.Is External

Operation

Attribute: Is External

Read/Write
boolean

Parent class: Operation


Operation.Long Name

Operation

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Operation


Operation.Type

Operation

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Operation


Operation.Last Author

Operation

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Operation


Operation.Last Change Date

Operation

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Operation


Operation.Stereotype

Operation

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Operation


Operation.Class

Operation

Association: Class

Description:
Read/Write
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Operation
Inverse roles: Class


Operation.Exception

Operation

Association: Exception

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Class
This role connects to 0 or more objects of classes: Class

Parent Class: Operation
Inverse roles: Class


Operation.Return Type

Operation

Association: Return Type

Description:
Read/Write
This role connects to 0 or 1 object of classes: Basic Type, Typedef, Class
All objects connected in this role are uniquely named

Parent Class: Operation
Inverse roles: BasicType, Typedef, Class


Operation.External Reference

Operation

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Operation
Inverse roles: ExternalReference


Operation.Parameter

Operation

Association: Parameter

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Parameter
This role connects to 0 or more objects of classes: Parameter
This role propagates delete

Parent Class: Operation
Inverse roles: Parameter


Operation.Corporate Operation

Operation

Association: Corporate Operation

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Operation
All objects connected in this role are uniquely named

Parent Class: Operation


Operation.Object Sequence Diagram

Operation

Association: Object Sequence Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectSequenceDiagram
This role connects to 0 or 1 object of classes: Object Sequence Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Operation
Inverse roles: ObjectSequenceDiagram


Operation.Object Collaboration Diagram

Operation

Association: Object Collaboration Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectCollaborationDiagram
This role connects to 0 or more objects of classes: Object Collaboration Diagram
This role propagates delete

Parent Class: Operation
Inverse roles: ObjectCollaborationDiagram


Operation.OCD Parent

Operation

Association: OCD Parent

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Parent

Parent Class: Operation
Inverse roles: OCDParent


Operation.Decomposition Diagram

Operation

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Operation
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Operation.Using Diagram

Operation

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Operation


Operation.Child Diagram

Operation

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Operation
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Operation.External Dictionary Item

Operation

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Operation


Operation.The External Reference

Operation

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Operation
Inverse roles: ExternalReference


Operation.File Reference

Operation

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Operation
Inverse roles: FileReference


Operation.Target Requirement

Operation

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Operation
Inverse roles: Requirement


Operation.Source Requirement

Operation

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Operation
Inverse roles: Requirement


Operation.Activity Diagram

Operation

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Operation
Inverse roles: ActivityDiagram


Package

conceptual grouping of items within class models.

Attributes

Constraints
Description
Type
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Child Category
Parent Category
Dependee Category
Dependent Category
Category Item
Container
Package Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Scoped Package
Corporate View
External User Class
External UML Interface
External Business Class
User Class
UML Interface
Exception
Business Class
External Exception
Class
External Class
Local Class
Typedef
Alias
Array
Enumeration
Sequence
Scoped Item
SCMComponent
Activity Diagram


Package.Constraints

Package

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Package


Package.Description

Package

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Package


Package.Type

Package

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Package


Package.Full Name

Package

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Package


Package.Full Scoped Name

Package

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Package


Package.Local Full Scoped Name

Package

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Package


Package.Local Scoped Name

Package

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Package


Package.Scoped Name

Package

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Package


Package.UML Short Dotted Name

Package

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Package


Package.Name

Package

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Package


Package.Comp Pointer

Package

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Package


Package.External Link Last Updated

Package

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Package


Package.Is External

Package

Attribute: Is External

Read/Write
boolean

Parent class: Package


Package.Long Name

Package

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Package


Package.Last Author

Package

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Package


Package.Last Change Date

Package

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Package


Package.Stereotype

Package

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Package


Package.External Reference

Package

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: ExternalReference


Package.Child Category

Package

Association: Child Category

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Package
This role propagates delete

Parent Class: Package
Inverse roles: Package


Package.Parent Category

Package

Association: Parent Category

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: Package


Package.Dependee Category

Package

Association: Dependee Category

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Package

Parent Class: Package
Inverse roles: Package


Package.Dependent Category

Package

Association: Dependent Category

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Package

Parent Class: Package
Inverse roles: Package


Package.Category Item

Package

Association: Category Item

Description:
Read/Write
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.Container

Package

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Package, Model
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: Package, Model


Package.Package Item

Package

Association: Package Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram
This role propagates delete

Parent Class: Package
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.Category

Package

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: Package


Package.Package

Package

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: Package


Package.Dependee Item

Package

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.Dependent Item

Package

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.Scoping Item

Package

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: Class, Package, Model, Requirement


Package.Decomposition Diagram

Package

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.Using Diagram

Package

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package


Package.Child Diagram

Package

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.External Dictionary Item

Package

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Package


Package.The External Reference

Package

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Package
Inverse roles: ExternalReference


Package.File Reference

Package

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Package
Inverse roles: FileReference


Package.Target Requirement

Package

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Package
Inverse roles: Requirement


Package.Source Requirement

Package

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Package
Inverse roles: Requirement


Package.Scoped Package

Package

Association: Scoped Package

Description:
Read/Write
This role can be used to create an object of Class: CID_Package
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Package
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package
Inverse roles: Package


Package.Corporate View

Package

Association: Corporate View

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is an alias of: RID_Namespace_To_ExternalClass
This role connects to 0 or more objects of classes: Class

Parent Class: Package


Package.External User Class

Package

Association: External User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.External UML Interface

Package

Association: External UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.External Business Class

Package

Association: External Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.User Class

Package

Association: User Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Package


Package.UML Interface

Package

Association: UML Interface

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Package


Package.Exception

Package

Association: Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Package


Package.Business Class

Package

Association: Business Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named

Parent Class: Package


Package.External Exception

Package

Association: External Exception

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.Class

Package

Association: Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package
Inverse roles: Class


Package.External Class

Package

Association: External Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.Local Class

Package

Association: Local Class

Description:
Read/Write
This role can be used to create an object of Class: CID_Class
This role is derived
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Class
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package


Package.Typedef

Package

Association: Typedef

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role returns an alphabetically sorted collection of objects over the automation interface
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Package
Inverse roles: Typedef


Package.Alias

Package

Association: Alias

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Package


Package.Array

Package

Association: Array

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Package


Package.Enumeration

Package

Association: Enumeration

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Package


Package.Sequence

Package

Association: Sequence

Description:
Read/Write
This role can be used to create an object of Class: CID_Typedef
This role is derived
This role connects to 0 or more objects of classes: Typedef
All objects connected in this role are uniquely named

Parent Class: Package


Package.Scoped Item

Package

Association: Scoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Package
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Package.SCMComponent

Package

Association: SCMComponent

Description:
Read/Write
This role connects to 0 or more objects of classes: SCMComponent
This role propagates delete

Parent Class: Package
Inverse roles: SCMComponent


Package.Activity Diagram

Package

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Package
Inverse roles: ActivityDiagram


Parameter

guage-dependent information about a formal parameter of an operation.

Attributes

Array Dimensions
Data Type
Full Name
Full Scoped Name
Has Interpreted Data Type
Scoped Name
Short UmlSignature
Signature
Uml Signature
Array Signature
Constraints
Default Value
Description
Is Array
Is Optional
Is Pointer
Mechanism
Name
Uninterpreted Data Type
UML Short Dotted Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Data Type
Event
External Reference
Operation
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Parameter.Array Dimensions

Parameter

Attribute: Array Dimensions

Derived property returning the number of dimensions of an array

Read/Write
32 bit signed integer

Parent class: Parameter


Parameter.Data Type

Parameter

Attribute: Data Type

A string containing the data type. This is either the true data type which is the dotted name of the dictionary item connected via the data type dictionary link or the uninterpreted data type string.

Read/Write
String of up to 1024 characters

Parent class: Parameter


Parameter.Full Name

Parameter

Attribute: Full Name

Full name for a Parameter, e.g. Param1 [cat1.cat2.class2.op1.] for a param belonging to an operation or Param1 [cat1.cat2.exc1.] for a param belonging to an exception or Param1 [evt1.] for a param belonging to an event

Read only
String of up to 100 characters

Parent class: Parameter


Parameter.Full Scoped Name

Parameter

Attribute: Full Scoped Name

Full scoped name for a Parameter, e.g. cat1::cat2::class2.op1.Param1 for a param belonging to an operation or cat1::cat2::exc1.Param1 for a param belonging to an exception or evt1.Param1 for a param belonging to an event

Read only
String of up to 100 characters

Parent class: Parameter


Parameter.Has Interpreted Data Type

Parameter

Attribute: Has Interpreted Data Type

Inidicates if the Parameter has an interpreted (Dictionary linked) data type.

Read only
boolean

Parent class: Parameter


Parameter.Scoped Name

Parameter

Attribute: Scoped Name

Scoped name for a Parameter, e.g. op1.Param1 for a param belonging to an operation or exc1.Param1 for a param belonging to an exception or evt1.Param1 for a param belonging to an event

Read only
String of up to 100 characters

Parent class: Parameter


Parameter.Short UmlSignature

Parameter

Attribute: Short UmlSignature

A string giving the Attribute signature in UML syntax. Data type is expressed with no scoping information.

Read only
String of up to 65536 characters

Parent class: Parameter


Parameter.Signature

Parameter

Attribute: Signature

A space separated string containing Mechanism, Data Type and Parameter Name.

Read only
String of up to 65536 characters

Parent class: Parameter


Parameter.Uml Signature

Parameter

Attribute: Uml Signature

A string giving the Attribute signature in UML syntax. Data type is expressed in dotted notation.

Read only
String of up to 65536 characters

Parent class: Parameter


Parameter.Array Signature

Parameter

Attribute: Array Signature

A comma separated string of array boundaries each array bound specified as lower bound , upperbound. e.g. the string "0,1,1,3" whould represent a 2D array of size [0..1,1..3]

Read/Write
String of up to 16385 characters

Parent class: Parameter


Parameter.Constraints

Parameter

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Parameter


Parameter.Default Value

Parameter

Attribute: Default Value

The default value the parameter should have, if a value is not supplied.

Read/Write
String of up to 16385 characters

Parent class: Parameter


Parameter.Description

Parameter

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Parameter


Parameter.Is Array

Parameter

Attribute: Is Array

Indicates whether the parameter is an array or not.

Read/Write
boolean

Parent class: Parameter


Parameter.Is Optional

Parameter

Attribute: Is Optional

Indicates if a parameter is optional or not.

Read/Write
boolean

Parent class: Parameter


Parameter.Is Pointer

Parameter

Attribute: Is Pointer

Indicates whether the parameter is a pointer or not.

Read/Write
boolean

Parent class: Parameter


Parameter.Mechanism

Parameter

Attribute: Mechanism

Indicates the mechanism of a parameter (e.g. in, out inout)

Read/Write
Enumeration, values: in, out, inout

Parent class: Parameter


Parameter.Name

Parameter

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Parameter


Parameter.Uninterpreted Data Type

Parameter

Attribute: Uninterpreted Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Parameter


Parameter.UML Short Dotted Name

Parameter

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Parameter


Parameter.Comp Pointer

Parameter

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Parameter


Parameter.External Link Last Updated

Parameter

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Parameter


Parameter.Is External

Parameter

Attribute: Is External

Read/Write
boolean

Parent class: Parameter


Parameter.Long Name

Parameter

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Parameter


Parameter.Type

Parameter

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Parameter


Parameter.Last Author

Parameter

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Parameter


Parameter.Last Change Date

Parameter

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Parameter


Parameter.Stereotype

Parameter

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Parameter


Parameter.Data Type

Parameter

Association: Data Type

Description:
Read/Write
This role connects to 0 or 1 object of classes: Basic Type, Typedef, Class
All objects connected in this role are uniquely named

Parent Class: Parameter
Inverse roles: BasicType, Typedef, Class


Parameter.Event

Parameter

Association: Event

Description:
Read/Write
This role connects to 1 object of classes: Event
All objects connected in this role are uniquely named

Parent Class: Parameter
Inverse roles: Event


Parameter.External Reference

Parameter

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Parameter
Inverse roles: ExternalReference


Parameter.Operation

Parameter

Association: Operation

Description:
Read/Write
This role connects to 1 object of classes: Operation
All objects connected in this role are uniquely named

Parent Class: Parameter
Inverse roles: Operation


Parameter.Decomposition Diagram

Parameter

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Parameter
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Parameter.Using Diagram

Parameter

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Parameter


Parameter.Child Diagram

Parameter

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Parameter
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Parameter.External Dictionary Item

Parameter

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Parameter


Parameter.The External Reference

Parameter

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Parameter
Inverse roles: ExternalReference


Parameter.File Reference

Parameter

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Parameter
Inverse roles: FileReference


Parameter.Target Requirement

Parameter

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Parameter
Inverse roles: Requirement


Parameter.Source Requirement

Parameter

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Parameter
Inverse roles: Requirement


AD::Parent

TODO

Attributes

Long Name
Type
Last Author
Last Change Date

Associations

Activity Diagram


AD::Parent.Long Name

AD::Parent

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: AD::Parent


AD::Parent.Type

AD::Parent

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: AD::Parent


AD::Parent.Last Author

AD::Parent

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: AD::Parent


AD::Parent.Last Change Date

AD::Parent

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: AD::Parent


ADParent.Activity Diagram

AD::Parent

Association: Activity Diagram

Description: TODO
Read/Write
This role connects to 1 object of classes: Activity Diagram
All objects connected in this role are uniquely named

Parent Class: AD::Parent
Inverse roles: ActivityDiagram


Process Break

A delay between business processes.

All objects of this class are name unique within a Model

Attributes

Description
Constraints
Full Scoped Name
Scoped Name
UML Short Dotted Name
Full Name
Local Full Scoped Name
Local Scoped Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Dictionary
External Reference
Parent
Out Transition
In Transition
Transition To
Transition From
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Process Break.Description

Process Break

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Process Break


Process Break.Constraints

Process Break

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Process Break


Process Break.Full Scoped Name

Process Break

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Scoped Name

Process Break

Attribute: Scoped Name

Scoped name for a Nestable Item, e.g. Iteration1:Business Process2

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.UML Short Dotted Name

Process Break

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Full Name

Process Break

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Local Full Scoped Name

Process Break

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Local Scoped Name

Process Break

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Name

Process Break

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Process Break


Process Break.Comp Pointer

Process Break

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Process Break


Process Break.External Link Last Updated

Process Break

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Process Break


Process Break.Is External

Process Break

Attribute: Is External

Read/Write
boolean

Parent class: Process Break


Process Break.Long Name

Process Break

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Process Break


Process Break.Type

Process Break

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Process Break


Process Break.Last Author

Process Break

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Process Break


Process Break.Last Change Date

Process Break

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Process Break


Process Break.Stereotype

Process Break

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Process Break


ProcessBreak.Dictionary

Process Break

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: Dictionary


ProcessBreak.External Reference

Process Break

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: ExternalReference


ProcessBreak.Parent

Process Break

Association: Parent

Description:
Read/Write
This role connects to 0 or more objects of classes: Complex Process
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: ComplexProcess


ProcessBreak.Out Transition

Process Break

Association: Out Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Process Break
Inverse roles: BusinessTransition


ProcessBreak.In Transition

Process Break

Association: In Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_BusinessTransition
This role connects to 0 or more objects of classes: Business Transition
This role propagates delete

Parent Class: Process Break
Inverse roles: BusinessTransition


ProcessBreak.Transition To

Process Break

Association: Transition To

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Process Break
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


ProcessBreak.Transition From

Process Break

Association: Transition From

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Event, Business Process, Process Break, Complex Process

Parent Class: Process Break
Inverse roles: BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess


ProcessBreak.Category

Process Break

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: Package


ProcessBreak.Package

Process Break

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: Package


ProcessBreak.Dependee Item

Process Break

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Break
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessBreak.Dependent Item

Process Break

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Break
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessBreak.Scoping Item

Process Break

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: Class, Package, Model, Requirement


ProcessBreak.Decomposition Diagram

Process Break

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Break
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessBreak.Using Diagram

Process Break

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Break


ProcessBreak.Child Diagram

Process Break

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Break
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessBreak.External Dictionary Item

Process Break

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Process Break


ProcessBreak.The External Reference

Process Break

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Process Break
Inverse roles: ExternalReference


ProcessBreak.File Reference

Process Break

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Process Break
Inverse roles: FileReference


ProcessBreak.Target Requirement

Process Break

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Break
Inverse roles: Requirement


ProcessBreak.Source Requirement

Process Break

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Break
Inverse roles: Requirement


Process Hierarchy Diagram

Represents a Process Hierarchy Diagram.

Attributes

Page Ref
Type
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

ParentPHD
PHD Business Process
Container
PHD Hierarchy Link
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Process Hierarchy Diagram.Page Ref

Process Hierarchy Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Type

Process Hierarchy Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Filename

Process Hierarchy Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Full Type

Process Hierarchy Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Pathname

Process Hierarchy Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Title

Process Hierarchy Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Description

Process Hierarchy Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Meta File

Process Hierarchy Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Page Orientation

Process Hierarchy Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Page Count

Process Hierarchy Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Full Name

Process Hierarchy Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Full Scoped Name

Process Hierarchy Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Local Full Scoped Name

Process Hierarchy Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Local Scoped Name

Process Hierarchy Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Scoped Name

Process Hierarchy Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.UML Short Dotted Name

Process Hierarchy Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Long Name

Process Hierarchy Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Last Author

Process Hierarchy Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Last Change Date

Process Hierarchy Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Process Hierarchy Diagram


Process Hierarchy Diagram.Stereotype

Process Hierarchy Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Process Hierarchy Diagram


ProcessHierarchyDiagram.ParentPHD

Process Hierarchy Diagram

Association: ParentPHD

Description:
Read/Write
This role connects to 0 or 1 object of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: BusinessProcess


ProcessHierarchyDiagram.PHD Business Process

Process Hierarchy Diagram

Association: PHD Business Process

Description:
Read/Write
This role can be used to create an object of Class: CID_PHDBusinessProcess
This role connects to 0 or more objects of classes: PHD::Business Process
This role propagates delete

Parent Class: Process Hierarchy Diagram
Inverse roles: PHDBusinessProcess


ProcessHierarchyDiagram.Container

Process Hierarchy Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: Model


ProcessHierarchyDiagram.PHD Hierarchy Link

Process Hierarchy Diagram

Association: PHD Hierarchy Link

Description:
Read/Write
This role can be used to create an object of Class: CID_PHDHierarchyLink
This role connects to 0 or more objects of classes: PHD::Hierarchy Link
This role propagates delete

Parent Class: Process Hierarchy Diagram
Inverse roles: PHDHierarchyLink


ProcessHierarchyDiagram.Decomposed Dictionary Item

Process Hierarchy Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ProcessHierarchyDiagram.Parent Dictionary Item

Process Hierarchy Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Process Hierarchy Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ProcessHierarchyDiagram.Category

Process Hierarchy Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: Package


ProcessHierarchyDiagram.Package

Process Hierarchy Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: Package


ProcessHierarchyDiagram.Dependee Item

Process Hierarchy Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Hierarchy Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessHierarchyDiagram.Dependent Item

Process Hierarchy Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Hierarchy Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessHierarchyDiagram.Scoping Item

Process Hierarchy Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Process Hierarchy Diagram
Inverse roles: Class, Package, Model, Requirement


ProcessHierarchyDiagram.File Reference

Process Hierarchy Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Process Hierarchy Diagram
Inverse roles: FileReference


ProcessHierarchyDiagram.Target Requirement

Process Hierarchy Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Hierarchy Diagram
Inverse roles: Requirement


ProcessHierarchyDiagram.Source Requirement

Process Hierarchy Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Hierarchy Diagram
Inverse roles: Requirement


Process Thread Diagram

Represents a Process Thread Diagram.

Attributes

Default View Exclusivity Show Name
Default View Transition Show Name
Page Ref
Type
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

ParentPTD
PTD Concurrence
Container
PTD Diagram Swimlane
Diagrams
PTD Iteration
PTD Parent
PTD Transition
PTD Swimlane
Swimlane
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Process Thread Diagram.Default View Exclusivity Show Name

Process Thread Diagram

Attribute: Default View Exclusivity Show Name

Indicates whether the default view option for a transition on a PTD is to display it's exclusive arc or not.

Read/Write
boolean

Parent class: Process Thread Diagram


Process Thread Diagram.Default View Transition Show Name

Process Thread Diagram

Attribute: Default View Transition Show Name

Indicates whether the default view option for a package is to display it's full name or not.

Read/Write
boolean

Parent class: Process Thread Diagram


Process Thread Diagram.Page Ref

Process Thread Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Type

Process Thread Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Filename

Process Thread Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Full Type

Process Thread Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Pathname

Process Thread Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Title

Process Thread Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Description

Process Thread Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Meta File

Process Thread Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Page Orientation

Process Thread Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Process Thread Diagram


Process Thread Diagram.Page Count

Process Thread Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Process Thread Diagram


Process Thread Diagram.Full Name

Process Thread Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Full Scoped Name

Process Thread Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Local Full Scoped Name

Process Thread Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Local Scoped Name

Process Thread Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Scoped Name

Process Thread Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.UML Short Dotted Name

Process Thread Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Long Name

Process Thread Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Last Author

Process Thread Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Process Thread Diagram


Process Thread Diagram.Last Change Date

Process Thread Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Process Thread Diagram


Process Thread Diagram.Stereotype

Process Thread Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Process Thread Diagram


ProcessThreadDiagram.ParentPTD

Process Thread Diagram

Association: ParentPTD

Description:
Read/Write
This role connects to 0 or 1 object of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: BusinessProcess


ProcessThreadDiagram.PTD Concurrence

Process Thread Diagram

Association: PTD Concurrence

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDConcurrence
This role connects to 0 or more objects of classes: PTD::Concurrence
This role propagates delete

Parent Class: Process Thread Diagram
Inverse roles: PTDConcurrence


ProcessThreadDiagram.Container

Process Thread Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Model


ProcessThreadDiagram.PTD Diagram Swimlane

Process Thread Diagram

Association: PTD Diagram Swimlane

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDDiagramSwimlane
This role connects to 1 object of classes: PTD::Diagram Swimlane
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Process Thread Diagram
Inverse roles: PTDDiagramSwimlane


ProcessThreadDiagram.Diagrams

Process Thread Diagram

Association: Diagrams

Description:
Read/Write
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Diagrams


ProcessThreadDiagram.PTD Iteration

Process Thread Diagram

Association: PTD Iteration

Description: TODO
Read/Write
This role can be used to create an object of Class: CID_PTDIteration
This role connects to 0 or more objects of classes: PTD::Iteration

Parent Class: Process Thread Diagram
Inverse roles: PTDIteration


ProcessThreadDiagram.PTD Parent

Process Thread Diagram

Association: PTD Parent

Description:
Read/Write
This role can be used to create an object of Class: CID_PTDParent
This role connects to 0 or 1 object of classes: PTD::Parent
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Process Thread Diagram
Inverse roles: PTDParent


ProcessThreadDiagram.PTD Transition

Process Thread Diagram

Association: PTD Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_PTDTransition
This role connects to 0 or more objects of classes: PTD::Transition
This role propagates delete

Parent Class: Process Thread Diagram
Inverse roles: PTDTransition


ProcessThreadDiagram.PTD Swimlane

Process Thread Diagram

Association: PTD Swimlane

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_PTDSwimlane
This role connects to 0 or more objects of classes: PTD::Swimlane
This role propagates delete

Parent Class: Process Thread Diagram
Inverse roles: PTDSwimlane


ProcessThreadDiagram.Swimlane

Process Thread Diagram

Association: Swimlane

Description: TODO
Read only
This role is derived
This role connects to 0 or more objects of classes: PTD::Swimlane, PTD::Diagram Swimlane

Parent Class: Process Thread Diagram


ProcessThreadDiagram.Decomposed Dictionary Item

Process Thread Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ProcessThreadDiagram.Parent Dictionary Item

Process Thread Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Process Thread Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


ProcessThreadDiagram.Category

Process Thread Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Package


ProcessThreadDiagram.Package

Process Thread Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Package


ProcessThreadDiagram.Dependee Item

Process Thread Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Thread Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessThreadDiagram.Dependent Item

Process Thread Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Process Thread Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


ProcessThreadDiagram.Scoping Item

Process Thread Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Process Thread Diagram
Inverse roles: Class, Package, Model, Requirement


ProcessThreadDiagram.File Reference

Process Thread Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Process Thread Diagram
Inverse roles: FileReference


ProcessThreadDiagram.Target Requirement

Process Thread Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Thread Diagram
Inverse roles: Requirement


ProcessThreadDiagram.Source Requirement

Process Thread Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Process Thread Diagram
Inverse roles: Requirement


Qualifier

This qualifies the association between two classes, thus indicating the attribute related to reduced selection for an association traversal. e.g. Tax Office [National Insurance Number] -> Tax payer. Thus a tax office is related to one tax payer when qualified with a national insurance number.

Attributes

Full Name
Array Dimensions
Has Interpreted Data Type
Type Declaration
Is Array
Is Pointer
Constraints
Description
Uninterpreted Data Type
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Association Start
External Reference
Data Type
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Qualifier.Full Name

Qualifier

Attribute: Full Name

Full name for a Qualifier, e.g. q1 [role1 - role2]

Read only
String of up to 100 characters

Parent class: Qualifier


Qualifier.Array Dimensions

Qualifier

Attribute: Array Dimensions

Derived property returning the number of dimensions of an array

Read/Write
32 bit signed integer

Parent class: Qualifier


Qualifier.Has Interpreted Data Type

Qualifier

Attribute: Has Interpreted Data Type

Indicates if the Attribute has an interpreted (Dictionary linked) data type.

Read only
boolean

Parent class: Qualifier


Qualifier.Type Declaration

Qualifier

Attribute: Type Declaration

A string containing the data type. This is either the true data type which is the dotted name of the dictionary item connected via the data type dictionary link or the uninterpreted data type string.

Read/Write
String of up to 16385 characters

Parent class: Qualifier


Qualifier.Is Array

Qualifier

Attribute: Is Array

Indicates whether the parameter is an array or not.

Read/Write
boolean

Parent class: Qualifier


Qualifier.Is Pointer

Qualifier

Attribute: Is Pointer

Indicates whether the attribute is a pointer or not.

Read/Write
boolean

Parent class: Qualifier


Qualifier.Constraints

Qualifier

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Qualifier


Qualifier.Description

Qualifier

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Qualifier


Qualifier.Uninterpreted Data Type

Qualifier

Attribute: Uninterpreted Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Qualifier


Qualifier.Name

Qualifier

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Qualifier


Qualifier.Full Scoped Name

Qualifier

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Qualifier


Qualifier.Scoped Name

Qualifier

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Qualifier


Qualifier.Comp Pointer

Qualifier

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Qualifier


Qualifier.External Link Last Updated

Qualifier

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Qualifier


Qualifier.Is External

Qualifier

Attribute: Is External

Read/Write
boolean

Parent class: Qualifier


Qualifier.Long Name

Qualifier

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Qualifier


Qualifier.UML Short Dotted Name

Qualifier

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Qualifier


Qualifier.Type

Qualifier

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Qualifier


Qualifier.Last Author

Qualifier

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Qualifier


Qualifier.Last Change Date

Qualifier

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Qualifier


Qualifier.Stereotype

Qualifier

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Qualifier


Qualifier.Association Start

Qualifier

Association: Association Start

Description:
Read/Write
This role connects to 0 or 1 object of classes: Association
All objects connected in this role are uniquely named

Parent Class: Qualifier
Inverse roles: Association


Qualifier.External Reference

Qualifier

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Qualifier
Inverse roles: ExternalReference


Qualifier.Data Type

Qualifier

Association: Data Type

Description:
Read/Write
This role connects to 0 or 1 object of classes: Basic Type, Typedef, Class
All objects connected in this role are uniquely named

Parent Class: Qualifier
Inverse roles: BasicType, Typedef, Class


Qualifier.Decomposition Diagram

Qualifier

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Qualifier
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Qualifier.Using Diagram

Qualifier

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Qualifier


Qualifier.Child Diagram

Qualifier

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Qualifier
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Qualifier.External Dictionary Item

Qualifier

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Qualifier


Qualifier.The External Reference

Qualifier

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Qualifier
Inverse roles: ExternalReference


Qualifier.File Reference

Qualifier

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Qualifier
Inverse roles: FileReference


Qualifier.Target Requirement

Qualifier

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Qualifier
Inverse roles: Requirement


Qualifier.Source Requirement

Qualifier

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Qualifier
Inverse roles: Requirement


Relationship

Allows users to visualise associations between tables. Is implemented as Foreign Keys in the RDBMS.

All objects of this class are name unique within a Model

Attributes

Specific Report Details
Parent Optional
One To One
Full Name
Constraints
On Delete Option
Description
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Prime Column
Foreign Column
External Reference
Join Column
Master Table
Detail Table
Class Model
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Relationship.Specific Report Details

Relationship

Attribute: Specific Report Details

String containing the report details body for the relationship. It contains details of the objects related to the relationship (e.g. master table, detail table etc.).

Read only
String of up to 16385 characters

Parent class: Relationship


Relationship.Parent Optional

Relationship

Attribute: Parent Optional

Indicates whether parent end of relationship is optional or not.

Read/Write
boolean

Parent class: Relationship


Relationship.One To One

Relationship

Attribute: One To One

Indicates whether the relationship is one-to-one or not.

Read/Write
boolean

Parent class: Relationship


Relationship.Full Name

Relationship

Attribute: Full Name

Full name for a Relationship, e.g. rel1 [t1 - t2]

Read only
String of up to 100 characters

Parent class: Relationship


Relationship.Constraints

Relationship

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Relationship


Relationship.On Delete Option

Relationship

Attribute: On Delete Option

Indicates the impact deleting the relationship will have (particularly important for SQL generator).

Read/Write
Enumeration, values: RESTRICT, CASCADE, SET NULL, None

Parent class: Relationship


Relationship.Description

Relationship

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Relationship


Relationship.Name

Relationship

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Relationship


Relationship.Full Scoped Name

Relationship

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Relationship


Relationship.Scoped Name

Relationship

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Relationship


Relationship.Comp Pointer

Relationship

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Relationship


Relationship.External Link Last Updated

Relationship

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Relationship


Relationship.Is External

Relationship

Attribute: Is External

Read/Write
boolean

Parent class: Relationship


Relationship.Long Name

Relationship

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Relationship


Relationship.UML Short Dotted Name

Relationship

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Relationship


Relationship.Type

Relationship

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Relationship


Relationship.Last Author

Relationship

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Relationship


Relationship.Last Change Date

Relationship

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Relationship


Relationship.Stereotype

Relationship

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Relationship


Relationship.Prime Column

Relationship

Association: Prime Column

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Column
All objects connected in this role are uniquely named

Parent Class: Relationship


Relationship.Foreign Column

Relationship

Association: Foreign Column

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Column
All objects connected in this role are uniquely named

Parent Class: Relationship


Relationship.External Reference

Relationship

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Relationship
Inverse roles: ExternalReference


Relationship.Join Column

Relationship

Association: Join Column

Description:
Read/Write
This role can be used to create an object of Class: CID_JoinColumn
This role connects to 0 or more objects of classes: Join Column
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Relationship
Inverse roles: JoinColumn


Relationship.Master Table

Relationship

Association: Master Table

Description:
Read/Write
This role can be used to create an object of Class: CID_Table
This role connects to 1 object of classes: Table
All objects connected in this role are uniquely named

Parent Class: Relationship
Inverse roles: Table


Relationship.Detail Table

Relationship

Association: Detail Table

Description:
Read/Write
This role can be used to create an object of Class: CID_Table
This role connects to 1 object of classes: Table
All objects connected in this role are uniquely named

Parent Class: Relationship
Inverse roles: Table


Relationship.Class Model

Relationship

Association: Class Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Class, Association, Ternary Association, Ternary Role, Attribute, Specialization

Parent Class: Relationship
Inverse roles: Class, Association, TernaryAssociation, TernaryRole, Attribute, Specialization


Relationship.Decomposition Diagram

Relationship

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Relationship
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Relationship.Using Diagram

Relationship

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Relationship


Relationship.Child Diagram

Relationship

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Relationship
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Relationship.External Dictionary Item

Relationship

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Relationship


Relationship.The External Reference

Relationship

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Relationship
Inverse roles: ExternalReference


Relationship.File Reference

Relationship

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Relationship
Inverse roles: FileReference


Relationship.Target Requirement

Relationship

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Relationship
Inverse roles: Requirement


Relationship.Source Requirement

Relationship

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Relationship
Inverse roles: Requirement


Requirement

A desired feature, property or behavior of a system.

Attributes

Priority
Description
Intent
Owner
RequirementReference
Originator
Status
Constraints
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Dictionary
External Reference
Increment
Container
Child Requirement
Parent Requirement
Dependent Requirement
Dependee Requirement
Source Item
Implementing Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Scoped Item
Scoped Requirement


Requirement.Priority

Requirement

Attribute: Priority

The priority of the requirement eg. Must, Should, Could, 1 to 5

Read/Write
String of up to 1024 characters

Parent class: Requirement


Requirement.Description

Requirement

Attribute: Description

String containing the description of the requirement.

Read/Write
String of up to 16385 characters

Parent class: Requirement


Requirement.Intent

Requirement

Attribute: Intent

String containing the intent of a requirement

Read/Write
String of up to 16385 characters

Parent class: Requirement


Requirement.Owner

Requirement

Attribute: Owner

String containing the name of the owner of the requirement.

Read/Write
String of up to 16385 characters

Parent class: Requirement


Requirement.RequirementReference

Requirement

Attribute: RequirementReference

String containing the Requirement reference.

Read/Write
String of up to 1024 characters

Parent class: Requirement


Requirement.Originator

Requirement

Attribute: Originator

String containing the name of the requirement originator.

Read/Write
String of up to 1024 characters

Parent class: Requirement


Requirement.Status

Requirement

Attribute: Status

String containing the requirement status.

Read/Write
String of up to 1024 characters

Parent class: Requirement


Requirement.Constraints

Requirement

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Requirement


Requirement.Full Name

Requirement

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Full Scoped Name

Requirement

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Local Full Scoped Name

Requirement

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Local Scoped Name

Requirement

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Scoped Name

Requirement

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.UML Short Dotted Name

Requirement

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Name

Requirement

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Requirement


Requirement.Comp Pointer

Requirement

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Requirement


Requirement.External Link Last Updated

Requirement

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Requirement


Requirement.Is External

Requirement

Attribute: Is External

Read/Write
boolean

Parent class: Requirement


Requirement.Long Name

Requirement

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Requirement


Requirement.Type

Requirement

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Requirement


Requirement.Last Author

Requirement

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Requirement


Requirement.Last Change Date

Requirement

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Requirement


Requirement.Stereotype

Requirement

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Requirement


Requirement.Dictionary

Requirement

Association: Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Dictionary


Requirement.External Reference

Requirement

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: ExternalReference


Requirement.Increment

Requirement

Association: Increment

Description:
Read/Write
This role can be used to create an object of Class: CID_Increment
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Increment


Requirement.Container

Requirement

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Requirement, Model
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Requirement, Model


Requirement.Child Requirement

Requirement

Association: Child Requirement

Description:
Read/Write
This role can NOT be removed
This role can be used to create an object of Class: CID_Requirement
This role is derived
This role connects to 0 or more objects of classes: Requirement
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Parent Requirement

Requirement

Association: Parent Requirement

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Requirement
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Dependent Requirement

Requirement

Association: Dependent Requirement

Description:
Read/Write
This role connects to 0 or more objects of classes: Requirement

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Dependee Requirement

Requirement

Association: Dependee Requirement

Description:
Read/Write
This role connects to 0 or more objects of classes: Requirement

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Source Item

Requirement

Association: Source Item

Description:
Read/Write
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Implementing Item

Requirement

Association: Implementing Item

Description:
Read/Write
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Category

Requirement

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Package


Requirement.Package

Requirement

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Package


Requirement.Dependee Item

Requirement

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Dependent Item

Requirement

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Scoping Item

Requirement

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: Class, Package, Model, Requirement


Requirement.Decomposition Diagram

Requirement

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Using Diagram

Requirement

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement


Requirement.Child Diagram

Requirement

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.External Dictionary Item

Requirement

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Requirement


Requirement.The External Reference

Requirement

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Requirement
Inverse roles: ExternalReference


Requirement.File Reference

Requirement

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Requirement
Inverse roles: FileReference


Requirement.Target Requirement

Requirement

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Source Requirement

Requirement

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Requirement
Inverse roles: Requirement


Requirement.Scoped Item

Requirement

Association: Scoped Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Requirement
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Requirement.Scoped Requirement

Requirement

Association: Scoped Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Requirement
Inverse roles: Requirement


Role

This overrides the default role of a class in an association.

Attributes

Full Name
Multiplicity Text
Qualifier
Role Name
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype
Constraints
Description
Is Ordered

Associations

Attribute
Class
Other Class
External Reference
Qualifier
Other Role
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Role.Full Name

Role

Attribute: Full Name

Full name for a Role, e.g. role1 [c1 - c2]

Read only
String of up to 100 characters

Parent class: Role


Role.Multiplicity Text

Role

Attribute: Multiplicity Text

The multiplicity text for the end of the association to which the role is related.

Read/Write
String of up to 50 characters

Parent class: Role


Role.Qualifier

Role

Attribute: Qualifier

The name of the qualifier for the end of the association to which the role is related.

Read/Write
String of up to 50 characters

Parent class: Role


Role.Role Name

Role

Attribute: Role Name

The possibly derived name of the Role.

Read/Write
String of up to 50 characters

Parent class: Role


Role.Name

Role

Attribute: Name

Over ride required for OnConverNameToString so that blank name is converted to ''

Read/Write
String of up to 100 characters

Parent class: Role


Role.Full Scoped Name

Role

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Role


Role.Scoped Name

Role

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Role


Role.Comp Pointer

Role

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Role


Role.External Link Last Updated

Role

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Role


Role.Is External

Role

Attribute: Is External

Read/Write
boolean

Parent class: Role


Role.Long Name

Role

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Role


Role.UML Short Dotted Name

Role

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Role


Role.Type

Role

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Role


Role.Last Author

Role

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Role


Role.Last Change Date

Role

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Role


Role.Stereotype

Role

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Role


Role.Constraints

Role

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Role


Role.Description

Role

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Role


Role.Is Ordered

Role

Attribute: Is Ordered

Read/Write
boolean

Parent class: Role


Role.Attribute

Role

Association: Attribute

Description:
Read/Write
This role connects to 0 or 1 object of classes: Attribute
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Role
Inverse roles: Attribute


Role.Class

Role

Association: Class

Description:
Read/Write
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Role
Inverse roles: Class


Role.Other Class

Role

Association: Other Class

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Role


Role.External Reference

Role

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Role
Inverse roles: ExternalReference


Role.Qualifier

Role

Association: Qualifier

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Qualifier
This role is derived
This role connects to 0 or more objects of classes: Qualifier

Parent Class: Role


Role.Other Role

Role

Association: Other Role

Description:
Read only
This role is derived
This role connects to 1 object of classes: Role
All objects connected in this role are uniquely named

Parent Class: Role


Role.Decomposition Diagram

Role

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Role
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Role.Using Diagram

Role

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Role


Role.Child Diagram

Role

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Role
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Role.External Dictionary Item

Role

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Role


Role.The External Reference

Role

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Role
Inverse roles: ExternalReference


Role.File Reference

Role

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Role
Inverse roles: FileReference


Role.Target Requirement

Role

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Role
Inverse roles: Requirement


Role.Source Requirement

Role

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Role
Inverse roles: Requirement


Specialization

A relationship which indicates that characteristics of the end Class is part of the definition of the start Class.

Attributes

Full Scoped Name
Scoped Name
Full Name
Inheritance Type
Description
Constraints
Virtual Base Class
Private Access
Overlapping
Completeness
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Class
External Reference
Generalization
Taxonomy
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Storage Model


Specialization.Full Scoped Name

Specialization

Attribute: Full Scoped Name

Alias of PID_ScopedName

Read only
String of up to 100 characters

Parent class: Specialization


Specialization.Scoped Name

Specialization

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Specialization


Specialization.Full Name

Specialization

Attribute: Full Name

Full name for a Specialization, e.g. [c1 - c2.Generalization 266]

Read only
String of up to 100 characters

Parent class: Specialization


Specialization.Inheritance Type

Specialization

Attribute: Inheritance Type

Read only
Enumeration, values: Generalization, Realization, Invalid

Parent class: Specialization


Specialization.Description

Specialization

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Specialization


Specialization.Constraints

Specialization

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Specialization


Specialization.Virtual Base Class

Specialization

Attribute: Virtual Base Class

Indicates whether the super-class of the generalization is a virtual base class.

Read/Write
boolean

Parent class: Specialization


Specialization.Private Access

Specialization

Attribute: Private Access

Indicates whether access to the related sub-class is private or not.

Read/Write
boolean

Parent class: Specialization


Specialization.Overlapping

Specialization

Attribute: Overlapping

Indicates whether a class can be a sub-class of more than one of the sub-classes of the generalization (i.e. the sub-types of a super-type are not mutually exclusive e.g. vehicle power could be wind and engine).

Read/Write
boolean

Parent class: Specialization


Specialization.Completeness

Specialization

Attribute: Completeness

Indicates the completion state of the Generalization. If this value is set to Incomplete then the Generalization is incomplete meaning that there are still sub types and Specializations to be added to this Generalization.

Read/Write
Enumeration, values: Undefined, Incomplete, Complete

Parent class: Specialization


Specialization.UML Short Dotted Name

Specialization

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Specialization


Specialization.Name

Specialization

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Specialization


Specialization.Comp Pointer

Specialization

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Specialization


Specialization.External Link Last Updated

Specialization

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Specialization


Specialization.Is External

Specialization

Attribute: Is External

Read/Write
boolean

Parent class: Specialization


Specialization.Long Name

Specialization

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Specialization


Specialization.Type

Specialization

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Specialization


Specialization.Last Author

Specialization

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Specialization


Specialization.Last Change Date

Specialization

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Specialization


Specialization.Stereotype

Specialization

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Specialization


Specialization.Class

Specialization

Association: Class

Description:
Read/Write
This role is derived
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Specialization


Specialization.External Reference

Specialization

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Specialization
Inverse roles: ExternalReference


Specialization.Generalization

Specialization

Association: Generalization

Description:
Read/Write
This role connects to 1 object of classes: Generalization
All objects connected in this role are uniquely named

Parent Class: Specialization
Inverse roles: Generalization


Specialization.Taxonomy

Specialization

Association: Taxonomy

Description:
Read/Write
This role connects to 1 object of classes: Class, Actor, Use Case
All objects connected in this role are uniquely named

Parent Class: Specialization
Inverse roles: Class, Actor, UseCase


Specialization.Decomposition Diagram

Specialization

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Specialization
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Specialization.Using Diagram

Specialization

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Specialization


Specialization.Child Diagram

Specialization

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Specialization
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Specialization.External Dictionary Item

Specialization

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Specialization


Specialization.The External Reference

Specialization

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Specialization
Inverse roles: ExternalReference


Specialization.File Reference

Specialization

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Specialization
Inverse roles: FileReference


Specialization.Target Requirement

Specialization

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Specialization
Inverse roles: Requirement


Specialization.Source Requirement

Specialization

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Specialization
Inverse roles: Requirement


Specialization.Storage Model

Specialization

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Specialization
Inverse roles: Relationship, Column, Table


State

This decribes an equilibrium/constraints for the values of the attributes and links of an object at a particular time.

Attributes

Event Action Block
Full Name
Full Scoped Name
Is Result State
Is Start State
Scoped Name
Constraints
Description
State Type
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Event Action Block
External Reference
Activities
Operation
Sub States
Super State
Composite State
Concurrent States
Transition End
Transition From States
Transition To States
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


State.Event Action Block

State

Attribute: Event Action Block

String containing a "|| " separated list of all the Event Action Blocks for the State. Note: "|" is a split vertical bar symbol.

Read only
String of up to 1024 characters

Parent class: State


State.Full Name

State

Attribute: Full Name

Full name for a State, e.g. State1 [cat1.c1.]

Read only
String of up to 100 characters

Parent class: State


State.Full Scoped Name

State

Attribute: Full Scoped Name

Full scoped name for a State, e.g. cat1::c1.State1

Read only
String of up to 100 characters

Parent class: State


State.Is Result State

State

Attribute: Is Result State

Flag to indicate if the State is a result state.

Read only
boolean

Parent class: State


State.Is Start State

State

Attribute: Is Start State

Flag to indicate if the State is a start state.

Read only
boolean

Parent class: State


State.Scoped Name

State

Attribute: Scoped Name

Scoped name for a State, e.g. c1.State1

Read only
String of up to 100 characters

Parent class: State


State.Constraints

State

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: State


State.Description

State

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: State


State.State Type

State

Attribute: State Type

Describes the type of the state - Start / Result / Normal

Read/Write
Enumeration, values: Start, Result, Normal

Parent class: State


State.UML Short Dotted Name

State

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: State


State.Name

State

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: State


State.Comp Pointer

State

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: State


State.External Link Last Updated

State

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: State


State.Is External

State

Attribute: Is External

Read/Write
boolean

Parent class: State


State.Long Name

State

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: State


State.Type

State

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: State


State.Last Author

State

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: State


State.Last Change Date

State

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: State


State.Stereotype

State

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: State


State.Event Action Block

State

Association: Event Action Block

Description:
Read/Write
This role can be used to create an object of Class: CID_EventActionBlock
This role connects to 0 or more objects of classes: Event Action Block
This role propagates delete

Parent Class: State
Inverse roles: EventActionBlock


State.External Reference

State

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: ExternalReference


State.Activities

State

Association: Activities

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Operation

Parent Class: State


State.Operation

State

Association: Operation

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Operation

Parent Class: State


State.Sub States

State

Association: Sub States

Description:
Read/Write
This role can be used to create an object of Class: CID_State
This role connects to 0 or more objects of classes: State
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: State


State.Super State

State

Association: Super State

Description:
Read/Write
This role connects to 0 or 1 object of classes: State
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: State


State.Composite State

State

Association: Composite State

Description:
Read/Write
This role connects to 1 object of classes: State
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: State


State.Concurrent States

State

Association: Concurrent States

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_State
This role connects to 1 or more objects of classes: State
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: State


State.Transition End

State

Association: Transition End

Description:
Read/Write
This role connects to 0 or more objects of classes: Transition
This role propagates delete

Parent Class: State
Inverse roles: Transition


State.Transition From States

State

Association: Transition From States

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: State

Parent Class: State
Inverse roles: State


State.Transition To States

State

Association: Transition To States

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: State

Parent Class: State
Inverse roles: State


State.Decomposition Diagram

State

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: State
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


State.Using Diagram

State

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: State


State.Child Diagram

State

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: State
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


State.External Dictionary Item

State

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: State


State.The External Reference

State

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: State
Inverse roles: ExternalReference


State.File Reference

State

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: State
Inverse roles: FileReference


State.Target Requirement

State

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: State
Inverse roles: Requirement


State.Source Requirement

State

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: State
Inverse roles: Requirement


State Diagram

Represents a State Diagram.

Attributes

Default View Composite State Show Activity
Default View Composite State Show E A B
Default View Transition Show E A B
Page Ref
Default View Result State Show Name
Default View Start State Show Name
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

SD Composite State
Container
Diagrams
SD Result State
SD Start State
SD Synchronization Bar
SD Transition
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


State Diagram.Default View Composite State Show Activity

State Diagram

Attribute: Default View Composite State Show Activity

Indicates whether the default view option for a state is to display it's activities or not.

Read/Write
boolean

Parent class: State Diagram


State Diagram.Default View Composite State Show E A B

State Diagram

Attribute: Default View Composite State Show E A B

Indicates whether the default view option for a state is to display it's EABs or not.

Read/Write
boolean

Parent class: State Diagram


State Diagram.Default View Transition Show E A B

State Diagram

Attribute: Default View Transition Show E A B

Indicates whether the default view option for a transition on an SD is to display it's EABs or not.

Read/Write
boolean

Parent class: State Diagram


State Diagram.Page Ref

State Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: State Diagram


State Diagram.Default View Result State Show Name

State Diagram

Attribute: Default View Result State Show Name

Indicates whether the default view option for a package is to display it's full name or not.

Read/Write
boolean

Parent class: State Diagram


State Diagram.Default View Start State Show Name

State Diagram

Attribute: Default View Start State Show Name

Indicates whether the default view option for a package is to display it's full name or not.

Read/Write
boolean

Parent class: State Diagram


State Diagram.Filename

State Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: State Diagram


State Diagram.Full Type

State Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: State Diagram


State Diagram.Pathname

State Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: State Diagram


State Diagram.Title

State Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: State Diagram


State Diagram.Description

State Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: State Diagram


State Diagram.Meta File

State Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: State Diagram


State Diagram.Page Orientation

State Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: State Diagram


State Diagram.Page Count

State Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: State Diagram


State Diagram.Full Name

State Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Full Scoped Name

State Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Local Full Scoped Name

State Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Local Scoped Name

State Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Scoped Name

State Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.UML Short Dotted Name

State Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Long Name

State Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: State Diagram


State Diagram.Type

State Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: State Diagram


State Diagram.Last Author

State Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: State Diagram


State Diagram.Last Change Date

State Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: State Diagram


State Diagram.Stereotype

State Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: State Diagram


StateDiagram.SD Composite State

State Diagram

Association: SD Composite State

Description:
Read/Write
This role can be used to create an object of Class: CID_SDCompositeState
This role connects to 0 or more objects of classes: SD::Composite State
This role propagates delete

Parent Class: State Diagram
Inverse roles: SDCompositeState


StateDiagram.Container

State Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Model


StateDiagram.Diagrams

State Diagram

Association: Diagrams

Description:
Read/Write
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Diagrams


StateDiagram.SD Result State

State Diagram

Association: SD Result State

Description:
Read/Write
This role can be used to create an object of Class: CID_SDResultState
This role connects to 0 or more objects of classes: SD::Result State
This role propagates delete

Parent Class: State Diagram
Inverse roles: SDResultState


StateDiagram.SD Start State

State Diagram

Association: SD Start State

Description:
Read/Write
This role can be used to create an object of Class: CID_SDStartState
This role connects to 0 or more objects of classes: SD::Start State
This role propagates delete

Parent Class: State Diagram
Inverse roles: SDStartState


StateDiagram.SD Synchronization Bar

State Diagram

Association: SD Synchronization Bar

Description:
Read/Write
This role can be used to create an object of Class: CID_SDSynchronizationBar
This role connects to 0 or more objects of classes: SD::Synchronization Bar
This role propagates delete

Parent Class: State Diagram
Inverse roles: SDSynchronizationBar


StateDiagram.SD Transition

State Diagram

Association: SD Transition

Description:
Read/Write
This role can be used to create an object of Class: CID_SDTransition
This role connects to 0 or more objects of classes: SD::Transition
This role propagates delete

Parent Class: State Diagram
Inverse roles: SDTransition


StateDiagram.Decomposed Dictionary Item

State Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


StateDiagram.Parent Dictionary Item

State Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: State Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


StateDiagram.Category

State Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Package


StateDiagram.Package

State Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Package


StateDiagram.Dependee Item

State Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: State Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


StateDiagram.Dependent Item

State Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: State Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


StateDiagram.Scoping Item

State Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: State Diagram
Inverse roles: Class, Package, Model, Requirement


StateDiagram.File Reference

State Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: State Diagram
Inverse roles: FileReference


StateDiagram.Target Requirement

State Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: State Diagram
Inverse roles: Requirement


StateDiagram.Source Requirement

State Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: State Diagram
Inverse roles: Requirement


Synchronization Bar

This represents complex transitions, to show synchronization and/or splitting of control, in the State Model.

Attributes

Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Synchronization Bar.Name

Synchronization Bar

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.Full Name

Synchronization Bar

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.Full Scoped Name

Synchronization Bar

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.Scoped Name

Synchronization Bar

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.Comp Pointer

Synchronization Bar

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Synchronization Bar


Synchronization Bar.External Link Last Updated

Synchronization Bar

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Synchronization Bar


Synchronization Bar.Is External

Synchronization Bar

Attribute: Is External

Read/Write
boolean

Parent class: Synchronization Bar


Synchronization Bar.Long Name

Synchronization Bar

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.UML Short Dotted Name

Synchronization Bar

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Synchronization Bar


Synchronization Bar.Type

Synchronization Bar

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Synchronization Bar


Synchronization Bar.Last Author

Synchronization Bar

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Synchronization Bar


Synchronization Bar.Last Change Date

Synchronization Bar

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Synchronization Bar


Synchronization Bar.Stereotype

Synchronization Bar

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Synchronization Bar


SynchronizationBar.External Reference

Synchronization Bar

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Synchronization Bar
Inverse roles: ExternalReference


SynchronizationBar.Decomposition Diagram

Synchronization Bar

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Synchronization Bar
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


SynchronizationBar.Using Diagram

Synchronization Bar

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Synchronization Bar


SynchronizationBar.Child Diagram

Synchronization Bar

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Synchronization Bar
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


SynchronizationBar.External Dictionary Item

Synchronization Bar

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Synchronization Bar


SynchronizationBar.The External Reference

Synchronization Bar

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Synchronization Bar
Inverse roles: ExternalReference


SynchronizationBar.File Reference

Synchronization Bar

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Synchronization Bar
Inverse roles: FileReference


SynchronizationBar.Target Requirement

Synchronization Bar

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Synchronization Bar
Inverse roles: Requirement


SynchronizationBar.Source Requirement

Synchronization Bar

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Synchronization Bar
Inverse roles: Requirement


Table

The SOM representation of a table to be created using a database schema.

All objects of this class are name unique within a Model

Attributes

Specific Report Details
Constraints
Description
Owner
Trigger SQL
Name
Full Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

Column
Database
The Dictionary
External Reference
Index
Start Relationship
End Relationship
Class Model
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Table.Specific Report Details

Table

Attribute: Specific Report Details

String containing the report details body for the table. It contains details of the objects scoped by the table (e.g. columns, indexes etc.) and the objects related to the table (e.g. relationships, class model items etc.).

Read only
String of up to 16385 characters

Parent class: Table


Table.Constraints

Table

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Table


Table.Description

Table

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Table


Table.Owner

Table

Attribute: Owner

String containing the designated user who owns the table.

Read/Write
String of up to 16385 characters

Parent class: Table


Table.Trigger SQL

Table

Attribute: Trigger SQL

String containing SQL statements needed to ensure referential integrity during updates to the Table.

Read/Write
String of up to 16385 characters

Parent class: Table


Table.Name

Table

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Table


Table.Full Name

Table

Attribute: Full Name

Name used to more closely identify an non-unique dictionary item. The intention was to generate a unique name, but with the size limitation this is not possible.

Read only
String of up to 100 characters

Parent class: Table


Table.Full Scoped Name

Table

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Table


Table.Scoped Name

Table

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Table


Table.Comp Pointer

Table

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Table


Table.External Link Last Updated

Table

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Table


Table.Is External

Table

Attribute: Is External

Read/Write
boolean

Parent class: Table


Table.Long Name

Table

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Table


Table.UML Short Dotted Name

Table

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Table


Table.Type

Table

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Table


Table.Last Author

Table

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Table


Table.Last Change Date

Table

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Table


Table.Stereotype

Table

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Table


Table.Column

Table

Association: Column

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_Column
This role connects to 0 or more objects of classes: Column
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Table
Inverse roles: Column


Table.Database

Table

Association: Database

Description:
Read/Write
This role connects to 0 or 1 object of classes: Database
All objects connected in this role are uniquely named

Parent Class: Table
Inverse roles: Database


Table.The Dictionary

Table

Association: The Dictionary

Description:
Read/Write
This role connects to 1 object of classes: Dictionary
All objects connected in this role are uniquely named

Parent Class: Table
Inverse roles: Dictionary


Table.External Reference

Table

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Table
Inverse roles: ExternalReference


Table.Index

Table

Association: Index

Description:
Read/Write
This role can be used to create an object of Class: CID_Index
This role connects to 0 or more objects of classes: Index
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Table
Inverse roles: Index


Table.Start Relationship

Table

Association: Start Relationship

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Table
Inverse roles: Relationship


Table.End Relationship

Table

Association: End Relationship

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Table
Inverse roles: Relationship


Table.Class Model

Table

Association: Class Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Class, Association, Ternary Association, Ternary Role, Attribute, Specialization

Parent Class: Table
Inverse roles: Class, Association, TernaryAssociation, TernaryRole, Attribute, Specialization


Table.Decomposition Diagram

Table

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Table
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Table.Using Diagram

Table

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Table


Table.Child Diagram

Table

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Table
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Table.External Dictionary Item

Table

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Table


Table.The External Reference

Table

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Table
Inverse roles: ExternalReference


Table.File Reference

Table

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Table
Inverse roles: FileReference


Table.Target Requirement

Table

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Table
Inverse roles: Requirement


Table.Source Requirement

Table

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Table
Inverse roles: Requirement


Ternary Association

An association between three or more class instances.

Attributes

Full Name
Description
Constraints
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
Ternary Role
Link Class
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Storage Model


Ternary Association.Full Name

Ternary Association

Attribute: Full Name

Full name for a Ternary Association, e.g. ter1 [c1 - c2 - c3]

Read only
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.Description

Ternary Association

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Ternary Association


Ternary Association.Constraints

Ternary Association

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Ternary Association


Ternary Association.Name

Ternary Association

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.Full Scoped Name

Ternary Association

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.Scoped Name

Ternary Association

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.Comp Pointer

Ternary Association

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Ternary Association


Ternary Association.External Link Last Updated

Ternary Association

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Ternary Association


Ternary Association.Is External

Ternary Association

Attribute: Is External

Read/Write
boolean

Parent class: Ternary Association


Ternary Association.Long Name

Ternary Association

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.UML Short Dotted Name

Ternary Association

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Ternary Association


Ternary Association.Type

Ternary Association

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Ternary Association


Ternary Association.Last Author

Ternary Association

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Ternary Association


Ternary Association.Last Change Date

Ternary Association

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Ternary Association


Ternary Association.Stereotype

Ternary Association

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Ternary Association


TernaryAssociation.External Reference

Ternary Association

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Ternary Association
Inverse roles: ExternalReference


TernaryAssociation.Ternary Role

Ternary Association

Association: Ternary Role

Description:
Read/Write
This role can be used to create an object of Class: CID_TernaryRole
This role connects to 0 or more objects of classes: Ternary Role
This role propagates delete

Parent Class: Ternary Association
Inverse roles: TernaryRole


TernaryAssociation.Link Class

Ternary Association

Association: Link Class

Description:
Read/Write
This role connects to 0 or 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Ternary Association
Inverse roles: Class


TernaryAssociation.Decomposition Diagram

Ternary Association

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Association
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TernaryAssociation.Using Diagram

Ternary Association

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Association


TernaryAssociation.Child Diagram

Ternary Association

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Association
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TernaryAssociation.External Dictionary Item

Ternary Association

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Ternary Association


TernaryAssociation.The External Reference

Ternary Association

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Ternary Association
Inverse roles: ExternalReference


TernaryAssociation.File Reference

Ternary Association

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Ternary Association
Inverse roles: FileReference


TernaryAssociation.Target Requirement

Ternary Association

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Ternary Association
Inverse roles: Requirement


TernaryAssociation.Source Requirement

Ternary Association

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Ternary Association
Inverse roles: Requirement


TernaryAssociation.Storage Model

Ternary Association

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Ternary Association
Inverse roles: Relationship, Column, Table


Ternary Role

This is our mechanism for extending ternary associations to have a specific role name and multiplicity for each related class.

Attributes

Full Name
Multiplicity Text
Role Name
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype
Constraints
Description
Is Ordered

Associations

Class
External Reference
Ternary Association
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Storage Model


Ternary Role.Full Name

Ternary Role

Attribute: Full Name

Dotted name for a Ternary Role, e.g. c2 [c2 - c3 - c4]

Read only
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.Multiplicity Text

Ternary Role

Attribute: Multiplicity Text

The multiplicity text for the role.

Read/Write
String of up to 50 characters

Parent class: Ternary Role


Ternary Role.Role Name

Ternary Role

Attribute: Role Name

The possibly derived name of the Ternary Role.

Read/Write
String of up to 50 characters

Parent class: Ternary Role


Ternary Role.Name

Ternary Role

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.Full Scoped Name

Ternary Role

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.Scoped Name

Ternary Role

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.Comp Pointer

Ternary Role

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Ternary Role


Ternary Role.External Link Last Updated

Ternary Role

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Ternary Role


Ternary Role.Is External

Ternary Role

Attribute: Is External

Read/Write
boolean

Parent class: Ternary Role


Ternary Role.Long Name

Ternary Role

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.UML Short Dotted Name

Ternary Role

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Ternary Role


Ternary Role.Type

Ternary Role

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Ternary Role


Ternary Role.Last Author

Ternary Role

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Ternary Role


Ternary Role.Last Change Date

Ternary Role

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Ternary Role


Ternary Role.Stereotype

Ternary Role

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Ternary Role


Ternary Role.Constraints

Ternary Role

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Ternary Role


Ternary Role.Description

Ternary Role

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Ternary Role


Ternary Role.Is Ordered

Ternary Role

Attribute: Is Ordered

Read/Write
boolean

Parent class: Ternary Role


TernaryRole.Class

Ternary Role

Association: Class

Description:
Read/Write
This role connects to 1 object of classes: Class
All objects connected in this role are uniquely named

Parent Class: Ternary Role
Inverse roles: Class


TernaryRole.External Reference

Ternary Role

Association: External Reference

Description:
Read only
This role is derived
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Ternary Role
Inverse roles: ExternalReference


TernaryRole.Ternary Association

Ternary Role

Association: Ternary Association

Description:
Read/Write
This role connects to 1 object of classes: Ternary Association
All objects connected in this role are uniquely named

Parent Class: Ternary Role
Inverse roles: TernaryAssociation


TernaryRole.Decomposition Diagram

Ternary Role

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Role
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TernaryRole.Using Diagram

Ternary Role

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Role


TernaryRole.Child Diagram

Ternary Role

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Ternary Role
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TernaryRole.External Dictionary Item

Ternary Role

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Ternary Role


TernaryRole.The External Reference

Ternary Role

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Ternary Role
Inverse roles: ExternalReference


TernaryRole.File Reference

Ternary Role

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Ternary Role
Inverse roles: FileReference


TernaryRole.Target Requirement

Ternary Role

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Ternary Role
Inverse roles: Requirement


TernaryRole.Source Requirement

Ternary Role

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Ternary Role
Inverse roles: Requirement


TernaryRole.Storage Model

Ternary Role

Association: Storage Model

Description:
Read/Write
This role connects to 0 or more objects of classes: Relationship, Column, Table

Parent Class: Ternary Role
Inverse roles: Relationship, Column, Table


Text Diagram

Represents a Text Diagram.

Attributes

Page Ref
Type
Text Data
Text File
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Container
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Text Diagram.Page Ref

Text Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Text Diagram


Text Diagram.Type

Text Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Text Diagram


Text Diagram.Text Data

Text Diagram

Attribute: Text Data

The text for this diagram

Read/Write
String of up to 200001 characters

Parent class: Text Diagram


Text Diagram.Text File

Text Diagram

Attribute: Text File

Name of file containing the text. The file is stored in the project directory.

Read only
String of up to 255 characters

Parent class: Text Diagram


Text Diagram.Filename

Text Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Text Diagram


Text Diagram.Full Type

Text Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Text Diagram


Text Diagram.Pathname

Text Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Text Diagram


Text Diagram.Title

Text Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Text Diagram


Text Diagram.Description

Text Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Text Diagram


Text Diagram.Meta File

Text Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Text Diagram


Text Diagram.Page Orientation

Text Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Text Diagram


Text Diagram.Page Count

Text Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Text Diagram


Text Diagram.Full Name

Text Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Full Scoped Name

Text Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Local Full Scoped Name

Text Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Local Scoped Name

Text Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Scoped Name

Text Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.UML Short Dotted Name

Text Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Long Name

Text Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Text Diagram


Text Diagram.Last Author

Text Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Text Diagram


Text Diagram.Last Change Date

Text Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Text Diagram


Text Diagram.Stereotype

Text Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Text Diagram


TextDiagram.Container

Text Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Text Diagram
Inverse roles: Model


TextDiagram.Decomposed Dictionary Item

Text Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Text Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


TextDiagram.Parent Dictionary Item

Text Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Text Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


TextDiagram.Category

Text Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Text Diagram
Inverse roles: Package


TextDiagram.Package

Text Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Text Diagram
Inverse roles: Package


TextDiagram.Dependee Item

Text Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Text Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TextDiagram.Dependent Item

Text Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Text Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


TextDiagram.Scoping Item

Text Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Text Diagram
Inverse roles: Class, Package, Model, Requirement


TextDiagram.File Reference

Text Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Text Diagram
Inverse roles: FileReference


TextDiagram.Target Requirement

Text Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Text Diagram
Inverse roles: Requirement


TextDiagram.Source Requirement

Text Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Text Diagram
Inverse roles: Requirement


Transition

This represents a Transition in the State Model.

Attributes

Full Name
Name
Full Scoped Name
Scoped Name
Comp Pointer
External Link Last Updated
Is External
Long Name
UML Short Dotted Name
Type
Last Author
Last Change Date
Stereotype

Associations

External Reference
End State
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement


Transition.Full Name

Transition

Attribute: Full Name

Dotted name for a Transition, e.g. Trans1 [state1 - state2]

Read only
String of up to 100 characters

Parent class: Transition


Transition.Name

Transition

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Transition


Transition.Full Scoped Name

Transition

Attribute: Full Scoped Name

A scoped dictionary name, which includes full parent hierarchy. e.g. Package2::Package1::Class1.Operation1 - Full scoped name of Operation1 on Class1 scoped to Package1, which is scoped to Package2. e.g. Class2 - Full scoped name of Class1 which is unscoped e.g. Table.Column - Full scoped name of Column on Table

Read only
String of up to 100 characters

Parent class: Transition


Transition.Scoped Name

Transition

Attribute: Scoped Name

A scoped dictionary name, which includes parent. e.g. Package1::Class1 e.g. Package1::Class1.Operation1 e.g. Class2 e.g. Table.Column

Read only
String of up to 100 characters

Parent class: Transition


Transition.Comp Pointer

Transition

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Transition


Transition.External Link Last Updated

Transition

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Transition


Transition.Is External

Transition

Attribute: Is External

Read/Write
boolean

Parent class: Transition


Transition.Long Name

Transition

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Transition


Transition.UML Short Dotted Name

Transition

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Transition


Transition.Type

Transition

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Transition


Transition.Last Author

Transition

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Transition


Transition.Last Change Date

Transition

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Transition


Transition.Stereotype

Transition

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Transition


Transition.External Reference

Transition

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Transition
Inverse roles: ExternalReference


Transition.End State

Transition

Association: End State

Description:
Read/Write
This role connects to 0 or 1 object of classes: State
All objects connected in this role are uniquely named

Parent Class: Transition
Inverse roles: State


Transition.Decomposition Diagram

Transition

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Transition
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Transition.Using Diagram

Transition

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Transition


Transition.Child Diagram

Transition

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Transition
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Transition.External Dictionary Item

Transition

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Transition


Transition.The External Reference

Transition

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Transition
Inverse roles: ExternalReference


Transition.File Reference

Transition

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Transition
Inverse roles: FileReference


Transition.Target Requirement

Transition

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Transition
Inverse roles: Requirement


Transition.Source Requirement

Transition

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Transition
Inverse roles: Requirement


Typedef

A definition of one type in terms of another.

Attributes

Array Bounds
Array Dimensions
Data Type
Has Interpreted Data Type
Is Array
Lower Array Bound
Upper Array Bound
Array Signature
Constraints
Description
Construction
Is Pointer
Max Size
Type
Uninterpreted Data Type
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

Namespace
Enumeration Literal
External Reference
Typed Attribute
Type Definition
Typed Operation
Typed Parameter
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Typed Column


Typedef.Array Bounds

Typedef

Attribute: Array Bounds

Comma Separated array bounds. For example: lower1,upper1,lower2,upper2. If one of the bounds is unlimited, a asterisk (*) is used.

Read/Write
String of up to 1024 characters

Parent class: Typedef


Typedef.Array Dimensions

Typedef

Attribute: Array Dimensions

Read/Write
32 bit signed integer

Parent class: Typedef


Typedef.Data Type

Typedef

Attribute: Data Type

A string containing the data type. This is either the true data type which is the dotted name of the dictionary item connected via the data type dictionary link or the uninterpreted data type string.

Read/Write
String of up to 1024 characters

Parent class: Typedef


Typedef.Has Interpreted Data Type

Typedef

Attribute: Has Interpreted Data Type

True if this based type has an underlying data type

Read only
boolean

Parent class: Typedef


Typedef.Is Array

Typedef

Attribute: Is Array

Read/Write
boolean

Parent class: Typedef


Typedef.Lower Array Bound

Typedef

Attribute: Lower Array Bound

The value of the lower array bound of an array type definition.

Read only
32 bit signed integer

Parent class: Typedef


Typedef.Upper Array Bound

Typedef

Attribute: Upper Array Bound

The value of the upper array bound of an array type definition. Returns -1 if the upper bound is unlimited.

Read only
32 bit signed integer

Parent class: Typedef


Typedef.Array Signature

Typedef

Attribute: Array Signature

A comma separated string of array boundaries each array bound specified as lowerbound..upperbound. e.g. the string "0..1,1..3" whould represent a 2D array whose first dimension has 2 elements (0 and 1), and whose second dimension has 3 elements (1, 2 and 3)

Read/Write
String of up to 16385 characters

Parent class: Typedef


Typedef.Constraints

Typedef

Attribute: Constraints

String containing the user defined constraints applying to the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Typedef


Typedef.Description

Typedef

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Typedef


Typedef.Construction

Typedef

Attribute: Construction

Indicates the construction of the Typedef (e.g. Array, Enumeration etc.).

Read/Write
Enumeration, values: enumeration, alias, sequence, array

Parent class: Typedef


Typedef.Is Pointer

Typedef

Attribute: Is Pointer

Indicates whether the type definition is a pointer or not.

Read/Write
boolean

Parent class: Typedef


Typedef.Max Size

Typedef

Attribute: Max Size

The value of the max size of a sequence type definition.

Read/Write
32 bit signed integer

Parent class: Typedef


Typedef.Type

Typedef

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Typedef


Typedef.Uninterpreted Data Type

Typedef

Attribute: Uninterpreted Data Type

A string containing text which names a data type. This text is not linked to a data type (e.g. typedef, class etc) which exists in the system.

Read/Write
String of up to 1024 characters

Parent class: Typedef


Typedef.Full Name

Typedef

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Full Scoped Name

Typedef

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Local Full Scoped Name

Typedef

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Local Scoped Name

Typedef

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Scoped Name

Typedef

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.UML Short Dotted Name

Typedef

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Name

Typedef

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Typedef


Typedef.Comp Pointer

Typedef

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Typedef


Typedef.External Link Last Updated

Typedef

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Typedef


Typedef.Is External

Typedef

Attribute: Is External

Read/Write
boolean

Parent class: Typedef


Typedef.Long Name

Typedef

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Typedef


Typedef.Last Author

Typedef

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Typedef


Typedef.Last Change Date

Typedef

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Typedef


Typedef.Stereotype

Typedef

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Typedef


Typedef.Namespace

Typedef

Association: Namespace

Description:
Read/Write
This role connects to 1 object of classes: Class, Package, Model
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: Class, Package, Model


Typedef.Enumeration Literal

Typedef

Association: Enumeration Literal

Description:
Read/Write
This role can be specifically ordered
This role can be used to create an object of Class: CID_EnumerationLiteral
This role connects to 0 or more objects of classes: Enumeration Literal
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Typedef
Inverse roles: EnumerationLiteral


Typedef.External Reference

Typedef

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: ExternalReference


Typedef.Typed Attribute

Typedef

Association: Typed Attribute

Description:
Read/Write
This role connects to 0 or more objects of classes: Qualifier, Attribute

Parent Class: Typedef
Inverse roles: Qualifier, Attribute


Typedef.Type Definition

Typedef

Association: Type Definition

Description:
Read/Write
This role connects to 0 or more objects of classes: Typedef

Parent Class: Typedef
Inverse roles: Typedef


Typedef.Typed Operation

Typedef

Association: Typed Operation

Description:
Read/Write
This role connects to 0 or more objects of classes: Operation

Parent Class: Typedef
Inverse roles: Operation


Typedef.Typed Parameter

Typedef

Association: Typed Parameter

Description:
Read/Write
This role connects to 0 or more objects of classes: Parameter

Parent Class: Typedef
Inverse roles: Parameter


Typedef.Category

Typedef

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: Package


Typedef.Package

Typedef

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: Package


Typedef.Dependee Item

Typedef

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Typedef
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Typedef.Dependent Item

Typedef

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Typedef
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Typedef.Scoping Item

Typedef

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: Class, Package, Model, Requirement


Typedef.Decomposition Diagram

Typedef

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Typedef
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Typedef.Using Diagram

Typedef

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Typedef


Typedef.Child Diagram

Typedef

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Typedef
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


Typedef.External Dictionary Item

Typedef

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Typedef


Typedef.The External Reference

Typedef

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Typedef
Inverse roles: ExternalReference


Typedef.File Reference

Typedef

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Typedef
Inverse roles: FileReference


Typedef.Target Requirement

Typedef

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Typedef
Inverse roles: Requirement


Typedef.Source Requirement

Typedef

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Typedef
Inverse roles: Requirement


Typedef.Typed Column

Typedef

Association: Typed Column

Description: TODO
Read/Write
This role connects to 0 or more objects of classes: Column

Parent Class: Typedef
Inverse roles: Column


Use Case

A behaviourly related sequence of interactions performed by an actor in a dialogue with the system to provide some measureable value to the actor.

All objects of this class are name unique within a Model

Attributes

Alternate Courses
Description
Intent
Post Conditions
Pre Conditions
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Name
Comp Pointer
External Link Last Updated
Is External
Long Name
Type
Last Author
Last Change Date
Stereotype
Is Abstract

Associations

Actor
Business Process
Class
Initializing Event
External Reference
Increment
Interaction
Extended By Use Case
Extended Use Case
Used Use Case
Used By Use Case
Included Use Case
Included By Use Case
Object Sequence Diagram
Object Collaboration Diagram
OCD Parent
Category
Package
Dependee Item
Dependent Item
Scoping Item
Decomposition Diagram
Using Diagram
Child Diagram
External Dictionary Item
The External Reference
File Reference
Target Requirement
Source Requirement
Generalization
Specialization
SubType
SuperType
Activity Diagram


Use Case.Alternate Courses

Use Case

Attribute: Alternate Courses

String containing alternate courses (errors and exceptions) of a use case.

Read/Write
String of up to 16385 characters

Parent class: Use Case


Use Case.Description

Use Case

Attribute: Description

String containing the description of the dictionary item.

Read/Write
String of up to 16385 characters

Parent class: Use Case


Use Case.Intent

Use Case

Attribute: Intent

String containing the intent (requirements) of a Use Case.

Read/Write
String of up to 16385 characters

Parent class: Use Case


Use Case.Post Conditions

Use Case

Attribute: Post Conditions

String containing a specification of the state of the system following execution of the use case.

Read/Write
String of up to 16385 characters

Parent class: Use Case


Use Case.Pre Conditions

Use Case

Attribute: Pre Conditions

String containing a specification of the state of the system prior to execution of the use case.

Read/Write
String of up to 16385 characters

Parent class: Use Case


Use Case.Full Name

Use Case

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Full Scoped Name

Use Case

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Local Full Scoped Name

Use Case

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Local Scoped Name

Use Case

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Scoped Name

Use Case

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.UML Short Dotted Name

Use Case

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Name

Use Case

Attribute: Name

Name of the object

Read/Write
String of up to 100 characters

Parent class: Use Case


Use Case.Comp Pointer

Use Case

Attribute: Comp Pointer

Component Manager external item reference.

Read/Write
String of up to 1024 characters

Parent class: Use Case


Use Case.External Link Last Updated

Use Case

Attribute: External Link Last Updated

The date time last updated from the related external object.

Read/Write
Date

Parent class: Use Case


Use Case.Is External

Use Case

Attribute: Is External

Read/Write
boolean

Parent class: Use Case


Use Case.Long Name

Use Case

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Use Case


Use Case.Type

Use Case

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Use Case


Use Case.Last Author

Use Case

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Use Case


Use Case.Last Change Date

Use Case

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Use Case


Use Case.Stereotype

Use Case

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Use Case


Use Case.Is Abstract

Use Case

Attribute: Is Abstract

Indicates whether the taxonomy is abstract or not.

Read/Write
boolean

Parent class: Use Case


UseCase.Actor

Use Case

Association: Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_Actor
This role is derived
This role connects to 0 or more objects of classes: Actor
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: Actor


UseCase.Business Process

Use Case

Association: Business Process

Description:
Read/Write
This role connects to 0 or more objects of classes: Business Process
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: BusinessProcess


UseCase.Class

Use Case

Association: Class

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class

Parent Class: Use Case
Inverse roles: Class


UseCase.Initializing Event

Use Case

Association: Initializing Event

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Event
All objects connected in this role are uniquely named

Parent Class: Use Case


UseCase.External Reference

Use Case

Association: External Reference

Description:
Read/Write
This role connects to 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: ExternalReference


UseCase.Increment

Use Case

Association: Increment

Description:
Read/Write
This role can be used to create an object of Class: CID_Increment
This role connects to 0 or more objects of classes: Increment
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: Increment


UseCase.Interaction

Use Case

Association: Interaction

Description:
Read/Write
This role connects to 0 or more objects of classes: Interaction
This role propagates delete

Parent Class: Use Case
Inverse roles: Interaction


UseCase.Extended By Use Case

Use Case

Association: Extended By Use Case

Description:
Read/Write
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Extended Use Case

Use Case

Association: Extended Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Used Use Case

Use Case

Association: Used Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role is an alias of: RID_IncludedByUseCase_To_IncludedUseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Used By Use Case

Use Case

Association: Used By Use Case

Description:
Read/Write
This role is an alias of: RID_IncludedUseCase_To_IncludedByUseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Included Use Case

Use Case

Association: Included Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UseCase
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Included By Use Case

Use Case

Association: Included By Use Case

Description:
Read/Write
This role connects to 0 or more objects of classes: Use Case
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: UseCase


UseCase.Object Sequence Diagram

Use Case

Association: Object Sequence Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectSequenceDiagram
This role connects to 0 or 1 object of classes: Object Sequence Diagram
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Use Case
Inverse roles: ObjectSequenceDiagram


UseCase.Object Collaboration Diagram

Use Case

Association: Object Collaboration Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ObjectCollaborationDiagram
This role connects to 0 or more objects of classes: Object Collaboration Diagram
This role propagates delete

Parent Class: Use Case
Inverse roles: ObjectCollaborationDiagram


UseCase.OCD Parent

Use Case

Association: OCD Parent

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: OCD::Parent

Parent Class: Use Case
Inverse roles: OCDParent


UseCase.Category

Use Case

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: Package


UseCase.Package

Use Case

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: Package


UseCase.Dependee Item

Use Case

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCase.Dependent Item

Use Case

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCase.Scoping Item

Use Case

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: Class, Package, Model, Requirement


UseCase.Decomposition Diagram

Use Case

Association: Decomposition Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCase.Using Diagram

Use Case

Association: Using Diagram

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case


UseCase.Child Diagram

Use Case

Association: Child Diagram

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case
Inverse roles: ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCase.External Dictionary Item

Use Case

Association: External Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Use Case


UseCase.The External Reference

Use Case

Association: The External Reference

Description:
Read only
This role is derived
This role connects to 0 or 1 object of classes: External Reference
All objects connected in this role are uniquely named

Parent Class: Use Case
Inverse roles: ExternalReference


UseCase.File Reference

Use Case

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Use Case
Inverse roles: FileReference


UseCase.Target Requirement

Use Case

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Use Case
Inverse roles: Requirement


UseCase.Source Requirement

Use Case

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Use Case
Inverse roles: Requirement


UseCase.Generalization

Use Case

Association: Generalization

Description:
Read/Write
This role can be used to create an object of Class: CID_Generalization
This role connects to 0 or more objects of classes: Generalization
All objects connected in this role are uniquely named
This role propagates delete

Parent Class: Use Case
Inverse roles: Generalization


UseCase.Specialization

Use Case

Association: Specialization

Description:
Read/Write
This role can be used to create an object of Class: CID_Specialization
This role connects to 0 or more objects of classes: Specialization
This role propagates delete

Parent Class: Use Case
Inverse roles: Specialization


UseCase.SubType

Use Case

Association: SubType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Use Case
Inverse roles: Class, Actor, UseCase


UseCase.SuperType

Use Case

Association: SuperType

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Class, Actor, Use Case

Parent Class: Use Case
Inverse roles: Class, Actor, UseCase


UseCase.Activity Diagram

Use Case

Association: Activity Diagram

Description:
Read/Write
This role can be used to create an object of Class: CID_ActivityDiagram
This role connects to 0 or more objects of classes: Activity Diagram
This role propagates delete

Parent Class: Use Case
Inverse roles: ActivityDiagram


Use Case Diagram

Represents a Use Case Diagram.

Attributes

Page Ref
Filename
Full Type
Pathname
Title
Description
Meta File
Page Orientation
Page Count
Full Name
Full Scoped Name
Local Full Scoped Name
Local Scoped Name
Scoped Name
UML Short Dotted Name
Long Name
Type
Last Author
Last Change Date
Stereotype

Associations

UCD Actor
Container
Diagrams
UCD Extends Flow
UCD Generalization
UCD Interaction Flow
UCD Use Case
UCD Uses Flow
Decomposed Dictionary Item
Parent Dictionary Item
Category
Package
Dependee Item
Dependent Item
Scoping Item
File Reference
Target Requirement
Source Requirement


Use Case Diagram.Page Ref

Use Case Diagram

Attribute: Page Ref

A textual reference for the diagram.

Read/Write
String of up to 50 characters

Parent class: Use Case Diagram


Use Case Diagram.Filename

Use Case Diagram

Attribute: Filename

Hang over from 5.1 should be unique within all Diagrams

Read only
String of up to 12 characters

Parent class: Use Case Diagram


Use Case Diagram.Full Type

Use Case Diagram

Attribute: Full Type

Concatination of Diagram Type as a string and Diagram sub-type if one exists.

Read only
String of up to 41 characters

Parent class: Use Case Diagram


Use Case Diagram.Pathname

Use Case Diagram

Attribute: Pathname

Gets directory from Model and adds this->Filename Converts to short filename equivalent. Note that this will tend to get called from the AI

Read only
String of up to 255 characters

Parent class: Use Case Diagram


Use Case Diagram.Title

Use Case Diagram

Attribute: Title

The name of the diagram.

Read/Write
String of up to 50 characters

Parent class: Use Case Diagram


Use Case Diagram.Description

Use Case Diagram

Attribute: Description

String containing the description of the diagram.

Read/Write
String of up to 16385 characters

Parent class: Use Case Diagram


Use Case Diagram.Meta File

Use Case Diagram

Attribute: Meta File

Creates a uniquely named meta file of the diagram. Returning the filename of the meta file.

Read only
String of up to 12 characters

Parent class: Use Case Diagram


Use Case Diagram.Page Orientation

Use Case Diagram

Attribute: Page Orientation

Indicates the orientation of the diagram when printing (e.g. landscape or portrait).

Read/Write
Enumeration, values: Portrait, Landscape

Parent class: Use Case Diagram


Use Case Diagram.Page Count

Use Case Diagram

Attribute: Page Count

Number of pages the diagram is to be printed on.

Read/Write
32 bit signed integer

Parent class: Use Case Diagram


Use Case Diagram.Full Name

Use Case Diagram

Attribute: Full Name

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Full Scoped Name

Use Case Diagram

Attribute: Full Scoped Name

Full scoped name for a Scoped Item, e.g. package2::package3::package1 package2::class1 class1::class2 [\\Enabler\select_uk_build\users\test model\0]

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Local Full Scoped Name

Use Case Diagram

Attribute: Local Full Scoped Name

A fully scoped name without a model reference

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Local Scoped Name

Use Case Diagram

Attribute: Local Scoped Name

A scoped name showing direct parent only without a model reference

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Scoped Name

Use Case Diagram

Attribute: Scoped Name

Scoped name for a PackageItem, e.g. package3::package1 package3::class1 class2::class1

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.UML Short Dotted Name

Use Case Diagram

Attribute: UML Short Dotted Name

UML Dotted name for a Scoped Item, only showing immediate scope e.g. package2.package3, package3.class1, class2.class1

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Long Name

Use Case Diagram

Attribute: Long Name

Read only
String of up to 100 characters

Parent class: Use Case Diagram


Use Case Diagram.Type

Use Case Diagram

Attribute: Type

Indicates the class of the object. This is the alias of class name.

Read only
String of up to 50 characters

Parent class: Use Case Diagram


Use Case Diagram.Last Author

Use Case Diagram

Attribute: Last Author

The author who last changed any property of diagrams or any property of a diagram.

Read only
String of up to 16 characters

Parent class: Use Case Diagram


Use Case Diagram.Last Change Date

Use Case Diagram

Attribute: Last Change Date

The date when any property of diagrams was last changed.

Read only
Date

Parent class: Use Case Diagram


Use Case Diagram.Stereotype

Use Case Diagram

Attribute: Stereotype

The stereotype of the Class

Read only
Enumeration, values:

Parent class: Use Case Diagram


UseCaseDiagram.UCD Actor

Use Case Diagram

Association: UCD Actor

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDActor
This role connects to 0 or more objects of classes: UCD::Actor
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDActor


UseCaseDiagram.Container

Use Case Diagram

Association: Container

Description:
Read/Write
This role connects to 1 object of classes: Model
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Model


UseCaseDiagram.Diagrams

Use Case Diagram

Association: Diagrams

Description:
Read/Write
This role connects to 1 object of classes: Diagrams
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Diagrams


UseCaseDiagram.UCD Extends Flow

Use Case Diagram

Association: UCD Extends Flow

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDExtendsFlow
This role connects to 0 or more objects of classes: UCD::Extends Flow
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDExtendsFlow


UseCaseDiagram.UCD Generalization

Use Case Diagram

Association: UCD Generalization

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDGeneralization
This role connects to 0 or more objects of classes: UCD::Generalization
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDGeneralization


UseCaseDiagram.UCD Interaction Flow

Use Case Diagram

Association: UCD Interaction Flow

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDInteractionFlow
This role connects to 0 or more objects of classes: UCD::Interaction Flow
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDInteractionFlow


UseCaseDiagram.UCD Use Case

Use Case Diagram

Association: UCD Use Case

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDUseCase
This role connects to 0 or more objects of classes: UCD::Use Case
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDUseCase


UseCaseDiagram.UCD Uses Flow

Use Case Diagram

Association: UCD Uses Flow

Description:
Read/Write
This role can be used to create an object of Class: CID_UCDUsesFlow
This role connects to 0 or more objects of classes: UCD::Uses Flow
This role propagates delete

Parent Class: Use Case Diagram
Inverse roles: UCDUsesFlow


UseCaseDiagram.Decomposed Dictionary Item

Use Case Diagram

Association: Decomposed Dictionary Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


UseCaseDiagram.Parent Dictionary Item

Use Case Diagram

Association: Parent Dictionary Item

Description:
Read/Write
This role is derived
This role connects to 0 or more objects of classes: Dependency, Operation, Attribute, Parameter, Enumeration Literal, Association, Ternary Association, Ternary Role, Generalization, Specialization, Transition, Event Action Block, Synchronization Bar, Business Transition, Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Basic Type, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, Column Sort, Join Column, Database, File Reference, Action State, VB Project, Exclusive Arc, Role, User Stereotype

Parent Class: Use Case Diagram
Inverse roles: Dependency, Operation, Attribute, Parameter, EnumerationLiteral, Association, TernaryAssociation, TernaryRole, Generalization, Specialization, Transition, EventActionBlock, SynchronizationBar, BusinessTransition, BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, BasicType, Interaction, State, SCMComponent, Qualifier, Index, Relationship, Column, Table, ColumnSort, JoinColumn, Database, FileReference, ActionState, VBProject, ExclusiveArc, Role, UserStereotype


UseCaseDiagram.Category

Use Case Diagram

Association: Category

Description:
Read/Write
This role is an alias of: RID_PackageItem_To_Package
This role connects to 0 or 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Package


UseCaseDiagram.Package

Use Case Diagram

Association: Package

Description:
Read/Write
This role can NOT be removed
This role is derived
This role connects to 1 object of classes: Package
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Package


UseCaseDiagram.Dependee Item

Use Case Diagram

Association: Dependee Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCaseDiagram.Dependent Item

Use Case Diagram

Association: Dependent Item

Description:
Read only
This role is derived
This role connects to 0 or more objects of classes: Business Actor, Use Case, Actor, Increment, Package, Event, Business Event, Business Process, Process Break, Complex Process, Requirement, Class, Typedef, Class Diagram, Use Case Diagram, State Diagram, Object Sequence Diagram, Object Collaboration Diagram, Process Thread Diagram, Process Hierarchy Diagram, General Graphics Diagram, Text Diagram, Activity Diagram, Table Relationships Diagram

Parent Class: Use Case Diagram
Inverse roles: BusinessActor, UseCase, Actor, Increment, Package, Event, BusinessEvent, BusinessProcess, ProcessBreak, ComplexProcess, Requirement, Class, Typedef, ClassDiagram, UseCaseDiagram, StateDiagram, ObjectSequenceDiagram, ObjectCollaborationDiagram, ProcessThreadDiagram, ProcessHierarchyDiagram, GeneralGraphicsDiagram, TextDiagram, ActivityDiagram, TableRelationshipsDiagram


UseCaseDiagram.Scoping Item

Use Case Diagram

Association: Scoping Item

Description:
Read only
This role is derived
This role connects to 1 object of classes: Class, Package, Model, Requirement
All objects connected in this role are uniquely named

Parent Class: Use Case Diagram
Inverse roles: Class, Package, Model, Requirement


UseCaseDiagram.File Reference

Use Case Diagram

Association: File Reference

Description:
Read/Write
This role can be used to create an object of Class: CID_FileReference
This role connects to 0 or more objects of classes: File Reference

Parent Class: Use Case Diagram
Inverse roles: FileReference


UseCaseDiagram.Target Requirement

Use Case Diagram

Association: Target Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Use Case Diagram
Inverse roles: Requirement


UseCaseDiagram.Source Requirement

Use Case Diagram

Association: Source Requirement

Description:
Read/Write
This role can be used to create an object of Class: CID_Requirement
This role connects to 0 or more objects of classes: Requirement

Parent Class: Use Case Diagram
Inverse roles: Requirement